0

For most file types in my Windows machine, I can create a default program to Open the file and any additional programs that I can choose to open with. For example, my .jpg file type is set to open by default with Paint.Net but also has 4 other products I can use to open it with.

This presents itself on the context menu as a bolded Open menu item AND an Open With> direct sub-menu item. I can click on Open With> and get the list of programs to open the file with (as a sub-menu) and the "Choose the Default Program..." menu item.

I use Sparx Systems Enterprise Architect UML Modelling Tool and I want to open my .eap (EA's repository or repository shortcut) files with 4 programs: The latest version of Sparx EA (default), build 909 of Sparx EA (the last, fast version - used for automation), MS Access for DB direct work and further automation and an editor for the EAP Shortcut files.

With my .eap files however, there is NO Open With> sub menu, but only the Open With... dialog menu item, which takes me directly to the Choose Program dialog which has the [X]Always use the selected program to open this kind of file - marked!

So if I want to open the .EAP file with anything other than the default I have to make sure I unmark the checkbox and select the program appropriately.

After a while this gets wearing and the possibility of mis-assigning the default program always present.

So, how can I set up things so the my .EAP file's context menu behaves like my .jpg file menu?

TIA, Paolo

1 Answer 1

1

These instructions are for Windows 7 and were tested on my work machine. If you have a different version of Windows, some of this process may be different.

In Control Panel, go to Default Programs and "Associate a file type or protocol with a program". Scroll down in the list until you see the .eap extension.

Click on the "Change program..." button and browse for the additional program you want to open it with. You'll see that you can't uncheck the "always use this program" option, but don't worry, we'll fix that up later. Select the program and press Open in the browse dialog, then OK to confirm it as your selection. Repeat this until you have added all the additional programs you want to use to open .eap files.

Now do the same once more, this time selecting Sparx EA to open it with. This will reset Sparx EA to being the default handler.

Now confirm your way out of the dialog, and you should have all the additional programs listed in the Open With popout menu.

5
  • Hi Scarlett, I can see how that should work (my machine is also Windows 7) however, I can't add any programs. I'm running under an SOE/MOE setup so I'll talk to my Help Desk to see if there's a policy stopping me from doing that. Commented Jul 30, 2015 at 7:51
  • BTW, did you know there is a suburb called Manuka in our national capital of Canberra here in Oz? Commented Jul 30, 2015 at 7:52
  • I tried it on my home machines. Unfortunately they're already set for Open With>, but at least I was able to get the additional programs on the list. Commented Jul 30, 2015 at 22:32
  • You may also need local administrative rights to do this, I don't know if you have that at your work. Commented Jul 31, 2015 at 2:06
  • I already have that - that's what makes the whole thing so confusing. At least the Help Desk has agreed there's anomalous behaviour here. Now, I just have to wait... Commented Jul 31, 2015 at 7:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .