11

After I finally managed to upgrade from Windows 8.1 to Windows 10, everything seems to run smooth except one thing:

If I right click on the desktop and select "Display settings" I get an error message

"The operating system cannot run ms-settings:display"

On my German Windows 10 this looks like:

enter image description here

Beside this thread on the Microsoft forums which suggests to create a new profile (which I want to avoid) I found no solution.

My question:

Do you have any idea how to resolve this issue?

Update 1:

It happens for other items, too like

  • ms-settings:notifications
  • ms-settings:personalization-background

Update 2:

As pointed out, this seems to (also) be a general problem with URL protocol handling in Windows Explorer.

Doing a Win+R and typing "http://www.google.com" does result in the same error.

Also, clicking links in HTML emails in Microsoft Outlook 2013 results in an error message:

Something unexpected went wrong with this URL:

"http://www.google.com". The operating system cannot run %1.

1
  • One suggestion was that the installation is corrupt and that a re-install of the update or a clean install of the PC might help.
    – Uwe Keim
    Jul 30, 2015 at 7:24

3 Answers 3

13

I uninstalled IE developer channel and it started working for me

4
  • That's incredible awesome! I tried that too, and after a reboot, it worked. Thanks a lot.
    – Uwe Keim
    Jul 30, 2015 at 21:26
  • 2
    Ha. Some people here don't have IE Dev Channel and had fixed the problem by installing it then uninstalling it... Aug 17, 2015 at 13:32
  • 1
    Not sure about others, but in my case it did help to install and uninstall (used Win8.1 distributive from microsoft.com/en-us/download/details.aspx?id=43359). I did had the Dev Channel installed at the Win10 upgrade time and then removed it. I guess it has not been removed completely. Sep 5, 2015 at 15:31
  • 1
    I had multiple problems after my Windows 10 update: - Clicking on links in Outlook shows the error message "The operating system cannot run %1" - I wasn't able to open zip files in Windows Explorer. If I used the extract menu I got the same error message and the error code 0x800700B6 Both problems were gone after uninstalling Internet Explorer developer channel(!) Jul 29, 2016 at 6:53
4

You can fix it by editing the registry.

  1. Type Win+R, then regedit

  2. Browse to key: Computer\HKEY_CURRENT_USER\Software\Classes\ms-settings

  3. Make sure you have this:

    .--------------.--------.-----------------.
    |    Name      |  Type  |      Data       |
    :--------------+--------+-----------------:
    | (Default)    | REG_SZ | URL:ms-settings |
    :--------------+--------+-----------------:
    | URL Protocol | REG_SZ |                 |
    '--------------'--------'-----------------'
    

If not:

  • remove all sub-keys below ms-settings.
  • remove all other values in ms-settings.
  • add missing values (right-click, new "String Value")

Works for Windows 10 (1803). May work for other versions too.

The result should look like this: What you must get

4
  • This doesn't seem to work for me in build 1809, unfortunately. :( Oct 13, 2018 at 22:09
  • I was, however, able to fix the issue by using System Restore. Oct 13, 2018 at 23:09
  • Thanks for your feedback. I haven't upgraded yet to 1809...
    – sdive
    Oct 17, 2018 at 10:26
  • Thank you for this solution it worked. I searched through 15 websites and google search results before finding your solution. Everyone else made irrelevant suggestions such as system restore, sfc /scannow and generic answers. Yours works. 100% Apr 16, 2019 at 10:44
1

This happened to me because something disabled my Connected Devices Platform Service.

To enable it, go to Start and type "services.msc", press Enter. Look down the list for "Connected Devices Platform Service" and double-click it, then you'll be able to click "Start".

Not the answer you're looking for? Browse other questions tagged or ask your own question.