It's kind of hard to read sometimes so I have scaling set to 125% on 1920x1080 resolution. ClearType doesn't fix this I tried turning it on and off. Everything looks great and fine (Explorer, Firefox...), except some things. See here:

Link to full-sized image

Same issue in Computer Management for example. However in 100% scaling it looks like there's no issues.

  • 3
    Just to add: I upgraded from Windows 8.1 where this was NOT an issue.
    – John Smith
    Commented Jul 30, 2015 at 8:31
  • Can you try 150%? Maybe there is a glitch which is specific to 125%
    – MonkeyZeus
    Commented Jul 30, 2015 at 14:08
  • Make sure you have the latest Windows 10 certified display driver
    – steve
    Commented Jul 30, 2015 at 19:31
  • I have the same issue. Please try this tool (windows10_dpi_blurry_fix.xpexplorer.com). It fixes all the blurry issue with 125% DPI on Windows 10. Commented Feb 1, 2017 at 14:39
  • I really don't know why this question is protected. It looks more like a PR conspiracy than some spam attack. Commented Feb 1, 2017 at 14:40

4 Answers 4


I had this problem too but was able to fix it with the specific programs that has the issue (like Steam and Rainmeter). You'll need to do the following:

  1. Note down which specific programs have the font problem.
  2. Right-click on the program icon (not the shortcut) and choose properties.
  3. Click the "Compatibility" tab.
  4. Check the box labeled "Disable display scaling on high DPI settings".
  5. Restart the program.
  6. Repeat for each affected program.
  • 5
    That's all nice and good, but how do you do it for things like: powershell, wscript, and pretty much all items in C:\Users\user\AppData\Local\Microsoft\Windows\WinX? It seems this is only an issue on some old mmc snap-ins. Just starting mmc looks blurry as well. It's like Windows 10 doesn't properly render old tools and there's no way to disable display scaling on high DPI settings for these things I listed and have the issue.
    – John Smith
    Commented Jul 30, 2015 at 21:34
  • I had the same problem in 8.1 and was able to fix it somehow. I have no idea how and it screws me up that it's back now that I've upgraded to win 10. :( This method works, but I would prefer a solution that grabs this problem at the root.
    – codepleb
    Commented Aug 20, 2015 at 18:54
  • 1
    I had exactly the same problem after installing Clover. Thanks to this fix it's no longer blurry, and thanks to deselecting "Launch folder windows in a separate process" it now seems to be working: reddit.com/r/Windows10/comments/3dmfqf/…
    – SharpC
    Commented Sep 18, 2015 at 14:27
  • @JohnSmith For fixing/setting DPI settings for builtin Windows apps, see this answer: serverfault.com/questions/570785/… Commented Jan 13, 2020 at 12:06
  • 1
    In 2020 it seems this is now in a subdialog from the compatibility settings. After going to the 'Compatibility' tab there is a button now called 'Change high DPI settings'. Inside activate 'Override high DPI scaling behavior. Scaling performed by'. Selecting 'Application' helped me solve this problem in FreeCommander XE.
    – neurosock
    Commented Feb 14, 2020 at 12:28

Here is how I solved it the simplest way. Simply set whatever DPI Windows is recommending as a custom DPI. That is, if Windows is recommending 125%, set a custom DPI of 125% and log out and log back in. This works fantastically, at least in the windows 10 build I am using now (Update 1803, Version 10.0.16299.15)

Edit: Also found it to be working great on Update 1809, Version 10.0.17763.134

Update: still default DPI is crap. Setting custom DPI still works with version 1909

Update: this technique still works like charm in Windows version 20H2.

  • Confirmed it works. Looks like by default Windows 10 leaves old apps from scaling. But with custom scaling, it actually enlarges old apps fonts as well. Commented Jan 21, 2019 at 8:36

I've managed to get sharp fonts in CMD, Device Manager, etc at once using standard Windows settings UI (i.e., without changing the compatibility settings or using the auto-start registry script).

Basically, you need to go to the Control Panel > Appearance and Personalization > Display and set a custom scaling level to 125%.

The nuance is that the UI won't let you to apply the setting if you already have the recommended 125% setting in the Settings > Display. But there are at least two workarounds:

Workaround 1: You can just set the scaling level to some other value in the Settings > Display UI, just before changing the settings back to 125% in the custom scaling level UI.

Workaround 2: You can set the custom scaling level to some other value in the custom scaling level UI, Apply, choose to re-logon later in the popped dialog, then set the custom scaling level back to 125%, Apply, and re-logon manually.

I've tested both workarounds and they both worked on two of my laptops.

  • This is a good method to get the clear font back, the only problem is when connecting to montior it has to be the same scale as well, which is really annoying.
    – Deqing
    Commented Nov 16, 2017 at 1:35
  • This doesn't work anymore. As soon as you set a custom DPI, Windows doesn't let you change DPI settings (the controls get disabled) unless you log out. Commented Oct 26, 2018 at 19:46

This is a window10 scaling method problem. There is a step by step manual on Lifehacker using a tool that allows you to switch to win8.1 scaling method. This worked fine for me.

Lifehacker Hot To Fix Blurry Fonts

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .