This question already has an answer here:

I have problem with Windows 10 Enterprise N x64. When I press "Start" and start to type application name it never finds it.

I can't even find applications like "Calculator", "Microsoft Word" or any other. Just moving dots and I let it run for 30 minutes without any success.

PS. There is chance that this will not work for you if you did upgrade instead of clean install of Windows 10. But you can always try.

This are my indexing options. Indexing Options

marked as duplicate by Journeyman Geek windows Oct 10 '17 at 8:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 17
    Looks like I'm not the only one with this problem then! Can't wait for the answer.. – xstnc Jul 30 '15 at 14:55
  • @xstnc I posted my own answer (Can't accept it now) that I figured by reading posts regarding similar issues in previous Windows versions. You can give it a try. It worked for me. – Hooch Jul 30 '15 at 19:50
  • Didn't seem to do anything for me at first. Didn't try a reboot. I will check later today and upvote if it did help! @Hooch – xstnc Jul 31 '15 at 8:54
  • Since I am having a lot of trouble with Windows 10 search, I posted this feature suggestion. If you end up here, you might want to vote on it. – Jesko Hüttenhain Aug 11 '15 at 10:31
  • 4
    I found that if you go to C:\ProgramData\Microsoft\Windows\Start Menu\Programs and open the shortcut "Search", it opens the "Search Everywhere" feature from Win 8, and there all the apps appear, so it has to be a bug in the new search UI of win 10, and not in the indexing options. I just wish that "win + s" could open "Search Everywhere" instead of Cortana. – Augusto Barreto Aug 11 '15 at 17:52

13 Answers 13

up vote 95 down vote accepted

I have no idea why or what I have broken in the process. But here is what worked for me.

  1. Ctrl+Shift+Right-click on an empty part of the taskbar and clicking "Exit Explorer" (or kill it via Task Manager if that doesn't work).

  2. Delete this registry key.

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{ef87b4cb-f2ce-4785-8658-4ca6c63e38c6}\TopViews\{00000000-0000-0000-0000-000000000000}

  1. Start process Explorer.exe via Task Manager.

This is one of many answers posted here. Feel free to try other people's suggestions. If you combine all answers in one I'll accept your answer.

enter image description here


Method for Creator's update Check out this answer.

  • 29
    For me does not work :/ – Ev0oD Aug 1 '15 at 10:07
  • 3
    Simply killing Explorer and restarting did it for me. Expanded instructions for bringing back your taskbar at superuser.com/a/313998/197108 – Noumenon Sep 5 '15 at 19:29
  • 2
    This worked for me, but can I just point out how bizarre it is – Jared Beach May 27 '16 at 12:56
  • 7
    Please don't advise people to kill explorer.exe if it is still responding. Instead advise them to exit explorer. In Windows 10 this is (apparently) done by Ctrl+Shift+Right-click on an empty part of the taskbar and clicking "Exit Explorer". That feature exists for precisely this sort of thing. – Kevin Cathcart Jul 13 '16 at 15:47
  • 9
    Nice spelling mistake in the screenshot :D – Matthew Cawley Sep 19 '17 at 20:49

Found a solution here: Cortana not finding Desktop apps when searching for them

Here is the relevant part:

I reinstalled Cortana using the following procedure:

  1. Open an elevated Command Prompt window (press win + X, and then press A)
  2. Type start powershell and press enter
  3. Run the command (in one line):

    Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
    

After 30 seconds the problem was solved on my machine. Incredible.

  • 2
    Same here, behaviour was different from OP because mine would find default apps but not ones I'd installed (like Word, Excel etc) and which I could find in the All Apps list. This fixed it for me, thanks! – DannyT Oct 14 '15 at 17:16
  • 2
    It may seem absurd, but this helps even when Cortana is NOT supported in your language or country. Just give it a try. – Radek Pech Oct 20 '15 at 11:25
  • for additional reference, cross-posted from superuser.com/a/955713 – drzaus Feb 24 '16 at 20:22
  • 1
    This question was about Windows Search , Not Cortana. i have samen problem but i stoped and uninstalled cortana , im using normail windows search now – Sam Nikzad Mar 17 '17 at 10:03
  • 1
    @AbbasNikzad Windows Search in Windows 10 is handled by Cortana, whether or not you use the AI functionality of it. – cybermonkey Aug 8 '17 at 12:01

Disabling the "Let apps run in the background" toggle on the "Background apps" page of the new Windows Privacy settings causes start-menu search to break, at least on Windows 10 with the Creator's Update!

I recently reinstalled Windows 10 with the Creator's Update on three machines. After installing Windows, my first step on all of the machines was to click through all the pages under Settings -> Privacy, disabling every single toggle. Included among these was the "Let apps run in the background" setting on the Background apps page.

Soon, thereafter, I noticed that newly installed applications would not show up in the start-menu search - either through win+S or by simply starting to type when the start-menu had focus. On all machines, some results would show and others would be missing. Newly installed stuff would not show. On one, typing google or chrom would yield nothing but the full word, chrome, would show "execute command". At one point, one machine would only complete notepad and the result could not be clicked or activated.

This thread helped me to learn that creating a new local-administrator user on the machines would temporarily solve the issue - thanks! Unfortunately, the problem would ocurr again and so I started trying to track down when, precisely, it started happening. I did this with a process involving many, many restarts and repeatedly installing and uninstalling 7-zip.

I was pleased to discover that my registry hacks that disable Cortana's web-search and windows-store search were not responsible - they were my first guess. Hacking out other parts of Windows didn't break the search; neither did my power-shell script that uninstalls all the bloatware that ships with Windows 10: Facebook, Twitter, XING, Keeper, the list goes on. (This stuff is also automatically reinstalled, repeatedly, and reinstalled for new user accounts.)

Finally, I tracked the problem to this privacy setting - another thing that is user-account specific!

My tests show that you can still disable all applications from running in the background as long as the primary toggle at the top of the "Background apps" page remains On. Here's a screenshot of my settings with start-menu search working:

Working Privacy Settings

All the rest of the privacy toggles can be switched off, on all the other pages.

And, lastly, it seems that if the "Let apps run in the background" toggle is Off, turning it on again and restarting appears to repair the start-menu search although it seems to take a while before the results are 100% again.

Of the solutions listed on this question, only the suggestion to create a new local user account worked and that only until I once again switched off this problematic toggle.


If you don't see the let "apps run in the background" toggle, you can still enable it via the registry. To do so;

  1. Press windows logo key + R to open the run dialog. Type "regedit" then press enter.
  2. Navigate to the following key: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\BackgroundAccessApplications
  3. Right click on BackgroundAccessApplications, and select New -> DWORD (32-bit) Value. Name it GlobalUserDisabled and set its value to 0.
  4. Restart.
  • 4
    Thank you. This worked for me with the Creator's update. – jordanbtucker May 13 '17 at 19:28
  • 6
    THANK YOU! Absolute life saver. Microsoft is so frustrating sometimes. – anon58192932 May 17 '17 at 2:18
  • 1
    Thanks a heap! +1 good answer - esp for also mentioning that the registry tweaks were not responsible. I too created a new profile.. – Jeremy J Wong Jun 6 '17 at 11:05
  • 5
    Well, this UI makes no sense. Anyone would expect a master switch put on top of several more specific switches to control only said switches, and not some totally unrelated and basic feature of the OS. It's Microsoft being Microsoft, I guess. – Arno Jul 9 '17 at 11:23
  • 1
    This is the answer! – udog Apr 18 at 14:48

For those who make their way here, but for whom the accepted answer doesn't work, I got this type of application searching to work with the following steps:

  1. Go to Indexing Options in the Control Panel (you can just search for 'index').
  2. Click the Modify button to get the Indexed Locations window.
  3. Expand your OS disk and check the checkboxes for Program Files and Program Files (x86).

It may take a few minutes for everything to start working the way you're hoping for.

  • 8
    7 and 8 seem to be doing this by automatically including C:\Users\<user>\AppData\Roaming\Microsoft\Windows\Start Menu in Indexed Locations, and 10 does not. So my method as posted above is kind of a brute-force method, but I chose it because sometimes I install things without an "Add To The Start Menu" option (which makes this application search even more useful). – Karim Temple Aug 5 '15 at 14:00
  • For me everything there was correct. – Hooch Aug 14 '15 at 7:40
  • 1
    @KarimTemple - Sir, you advised the people to use the search ("[...]you can just search for 'index'[...]) in your answer to a question, which explains that op doesn't find anything in the search ... lol – WoIIe Feb 17 '16 at 8:35
  • 1
    @Wolle Good point! Sorry! I was able to search for Indexing Options so I guess the nature of my issue was slightly different. – Karim Temple Feb 18 '16 at 13:20
  • I had this issue on an upgrade install of Win10 from Win8.1 and also on another machine with fresh Win10 install. I could search for 'index' as @KarimTemple found. – AnneTheAgile May 25 '16 at 9:47

How I solved my problem:

The service Windows Search was disabled somehow, I believe I have disabled it using msconfig without knowing about the consequences.

However, try to run services.msc and make sure Windows Search is enabled and started. You should see the result immediately.

Good luck!

  • This was what I discovered. Windows Search is disabled by default, in Windows 10. – ironywrit Aug 10 '15 at 23:13
  • 2
    This was precisely the issue for me too, on a fresh Windows 10 install. The Windows Search service was disabled. However it wasn't Windows' fault, it was the software "Samsung Magician" that ships with Samsung SSDs. It disables the Windows Search service as part of its optimizations. – jlh Nov 3 '15 at 9:54
  • @ironywrit: It's actually enabled by default (Automatic Start Delay). – surfasb Oct 31 '16 at 17:13

I had the same issue. My solution for this was to go to Indexing Options, chose Advanced, then choose to Rebuild the index. That fixed it right away.

  • 6
    Didn't help me. Tried that option. But maybe it will work for others. This looks much more like a really complex problem. – Hooch Aug 5 '15 at 8:04
  • This solved the problem for me. – Billy Aug 19 '15 at 10:21

I am just adding a summary based on my own experience.

Augusto's answer works for me but only temporarily. Just reinstall cortana. Go to powershell and type

Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

After a while the stuff went the way it used to be. Sometimes, if I type zend, zend studio will show up. Sometimes not.

I am also using one of the comment as another answer in case that didn't work for you.

I found that if you go to C:\ProgramData\Microsoft\Windows\Start Menu\Programs and open the shortcut "Search", it opens the "Search Everywhere" feature from Win 8, and there all the apps appear, so it has to be a bug in the new search UI of win 10, and not in the indexing options. I just wish that "win + s" could open "Search Everywhere" instead of Cortana. – Augusto Barreto Aug 11 at 17:52

That is written by augusto again. BOTH of this works for me.

I did rebuilding index and other solutions. That didn't work or only work temporarily.

Thanks Augusto. I think I should add my own answer so everybody knows which solutions work in my case and probably on their cases either.

Local administrator account was the issue

I was building a Windows 10 Pro SOE based on x64 1607 when I came across the start menu search not finding any applications.

To be specific, as stated above in a couple posts, i could find default pre-installed applications but not anything new, eg. when I installed Adobe Acrobat Reader DC, I would get no results when searching "Adobe" or "Acrobat" or "Reader".

I tried all of the suggestions above but unfortunately nothing worked.

I realised that the issue was specific to the builtin local administrator account. When I tried the same thing with multiple new users on the system my searches were working as expected. I suspect it's related to how some UWP apps (calc, edge) can't run under the local administrator account, maybe Cortana / Windows Search is broken for the local administrator.

  • 3
    Yes. Same here. But how to solve this? – Leonel Feb 15 '17 at 0:13
  • The problem is Cortana. If it's not activated or not working, the Search won't work. In my case it wasn't active because my Windows is in English but my Location settings were for Brazil. Once I changed it to United States everythin worked. – Leonel Feb 15 '17 at 2:07
  • Creating a new local user account does solve the problem but the reason it does is because the new user account has the default "Privacy" settings. I have identified which of these is related to the problem - see my new answer. (Even with the new user account, turning off the offending setting will cause the problem to occurr again.) – Xharlie May 13 '17 at 15:54

This answer is my own discovery on Windows 10 Pro 1703 x64. (That's Creators Update, folks.) I had to resort to it because, to my surprise, the answer by Augusto Barreto did not work for me. Without further ado:

  1. Do either of the following:
    • Create a new temporary user account with Administrative privileges, log out of your current account (very important) and log into the temporary account
    • Start your computer in Windows Recovery Environment
  2. Delete, rename or move the following folder:

    C:\Users\[Your username]\AppData\Local\Packages\Microsoft.Windows.Cortana_cw5n1h2txyewy
    

    Note: In Windows Recovery Environment, C: can sometimes become D:, E: or even F:, depending on your computer's configuration.

  3. Log back into your original account.

Cortana will not work immediately. (It is busy recreating the folder you just deleted.) But when it does, everything will be alright. Don't forget to delete the temporary user account.

Important notice: By the time I reached the conclusion to do this, I had ascertained that Windows Search Indexer was working okay and it was Cortana's problem that didn't show the result well. My evidence was that Cortana could find literally everything else (including my music) and searches from File Explorer worked well.

  • After trying every solution this was the only one who solved my problem (windows version 1709), I knew of this folder but didn't think of deleting it, great idea! – GGG Jan 16 at 16:12

I solved it this way.

  • Open Control Panel.
  • Open Indexing Options.
  • At the bottom there is Troubleshoot search and indexing.
  • Click on it and select the 2 top options in the next window.
  • Let the system run a diagnostic and select a fix.
  • Troubleshooting couldn’t identify the problem, even with Administrator permission. – dakab Sep 13 '17 at 16:22

In short if you are exhausted like me

create a new local admin user

And because I have recently reset my Windows 10 with keep my files option and everything was new it was not a bad solution and I forgot my previous Windows live account and started enjoying a clean and fast new user.

After trying a few solutions from here and there I finally created a new local Administrator Account and now everything works very fast and perfect. I tried below unsuccessful solutions before creating new account

  • Resetting Cortana with powershell commands
  • Disabling Cortana with Group Policy
  • Rebuilding search indexes and added many extra start and programs files

My Problem starts when my previous windows 10 with anniversary updates and my connected windows live user account encountered lots of BSOD and because of mix of maybe following events

  • Driver booster updates all my drivers and restoring was not avaiable
  • Visual studio 2017 install and lastest Windows 10 SDK and emulator which was required for UWP development

I have to add that in my situation Calculator apps and other win settings and builtin apps were shown in search by any other installed apps were not searched no matter how hard i tried.

  • I disabled Cortana using a local group policy and experienced, that some applications were indexed and found, while others were not, e.g. the cygwin terminal. Very odd. After removing the Cortana-block in GP, everything works again like a charm. Great idea! – Jinxed Jul 10 '17 at 16:53

I found a way to work this out by following a suggestion on this link.

Just copy the contents of the old start menu from

    C:\Windows.old\Users\All Users\Microsoft\Windows\Start Menu\Programs

to

    C:\Users\<username>\AppData\Roaming\Microsoft\Windows\Start Menu\Programs

as apparently only the to programs were copied during the installation, but the missing ones could be found in "All Users".

I even prematurely removed all the contents of the Windows.old folder, but managed to recover the contents of the folder using Recuva. You can use it too if this is the case for you too. However, useless for SSD. Fortunately I copied the contents first to a HDD before I removed and I could recover the files from there.

I copied it all there and in a few seconds everything was working as it should.

  • 2
    I didn't upgrade. I did clean install. So this wasn't for me. – Hooch Aug 3 '15 at 6:56
  • Registry key solution didn't help? – Ev0oD Aug 3 '15 at 8:20

Turning Cortana off helped me. However, once a month or so I will find that Search stops working again. Then I find "Cortana" in Task Manager and kill it. That works immediately.

  • 1
    This does not "turn off" Cortana this just kills the process. This also would only make search work until a system reboot happened. This answer seems incomplete. – Ramhound Oct 16 '15 at 11:27
  • 1
    I edited to address your concerns. This lasts longer than one reboot simply because the problem doesn't crop up on every reboot for me, only occasionally once I turned off Cortana with its on/off switch. – Noumenon Oct 16 '15 at 13:05
  • kill 'Cortana' make my search work! – qun May 19 '16 at 2:33

protected by Community Oct 25 '15 at 21:50

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.