8

I've just upgraded to Windows 10 from Windows 8.1, but after upgrading I can't connect to the internet. I select my wifi network and click "Connect". Even though it says it's connected I cannot open any page and the troubleshoot helper says that I'm not connected to any network.

Has anyone experienced this?

  • Is your WiFi protected with a password? Did you enter it correctly? – DeleteMe Jul 30 '15 at 9:47
  • @NoneOfYourBusiness Yes, I've entered it correctly. Windows says it's connected. – Cornwell Jul 30 '15 at 9:53
  • Can you ping the gateway? e.g. ping 192.168.1.1 – DeleteMe Jul 30 '15 at 10:21
  • Good to see this question and answer solve a few issues others had, original thought it was a specific configuration I had when experienced this that was a virtual Wifi-bridge with the problem until I spotted these options were changed! – RoguePlanetoid Aug 6 '15 at 15:21
  • I have a similar issue. Pls see superuser.com/questions/1023244/… – kp91 Jan 18 '16 at 14:41
10

Make sure the IPv4 and IPv6 protocols are enabled:

  • Go to Advanced Network settings
  • Go to Network and Sharing Centre
  • Go to Change Adapter Settings

    Network

  • Select Properties for the Wifi Adapter (right-click your connection):

  • Make sure the IPv4 and IPv6 protocols are selected

I also couldn't connect to internet after upgrading and found that these had been disabled. Once enabled you should be able to connect.

  • 1
    That solved it! Thank you. Not sure why Windows disabled all of those during upgrade, must be some sort of bug. – Cornwell Jul 30 '15 at 10:29
  • Great glad that worked - I had no idea why it did that it was seemly connected fine but getting no internet, was very strange until I checked this! – RoguePlanetoid Jul 30 '15 at 10:31
3

After sleepless weekend got rid of this problem. It is Bitdefender TS in my case. Uninstalled it and Internet came back in a flash. Also updated all drivers for my Mobo Gigabyte D3H B85M from official site to Windows 10. Re-install latest version of Bitdefender TS. All fine now. Thank God.

  • So you updated all your drivers, and you still argue that it's Bitdefender TS (a.k.a. "total security") that was the culprit? You should have had a look at the answer above before you updated the drivers. It might have saved you at least one good night's sleep. Because when you re-installed drivers, one or several of your network devices may have become enabled (if they were previously disabled). – Samir Aug 4 '15 at 11:06
  • I know I'm a bit late, but I just wanted to say thanks, this solution did work for me (I was also connected but with no internet). My problem was the Comodo firewall; right after I uninstalled and restarted, the internet was working fine. – qwersjc Jan 3 '16 at 16:13
  • It was ESET for me. Looks like anti-virus/firewall programs can have compatibility issues. – totymedli Mar 25 '16 at 1:21
  • For me it was Avast! It is recommended to remove anti-virus of all types as one of the steps to trouble shoot this. I didn't do anything with the drivers; I just read a bunch and picked the least harmful, easiest solution first (after ipconfig, other simple trouble shooting steps). – rholmes Mar 26 '16 at 19:05

protected by Community Aug 6 '15 at 18:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.