A few hours ago I upgraded my Dell Optiplex 3020 from Windows 8.1 to Windows 10 via the updater. Since then I have no network connection. I did the same update on a similar machine and the Internet works fine. The troubleshooter won't identify the problem. The network adapter is visible in Device Manager and the driver is fine but in the network settings it is absent.

I ran netsh int ipv4 reset from Command Prompt but it gave me the error:

Resetting failed , access is denied.

I read that I should find some keys in Regedit and give everyone full control over them, but this did not work.

How can I get my networking to work again?

  • Windows decided today to do an update, notifying me that the Cisco VPN Client has been removed. However netsh int ipv4 reset got back the network connections in the Network Connections screen. Dec 14, 2015 at 11:56

4 Answers 4


I had the same problem, do you have VPN software installed? I had an old Cisco VPN installation and I couldn't remove it under windows 10. To fix I had to revert the upgrade and uninstall the VPN then upgrade again. My revert only took a couple minutes, it's usually very fast.

  1. Open start menu and search for "windows 8" you will see a settings option to "Go back to Windows 8.1"

  2. Uninstall VPN

  3. Upgrade again

  • Oh my , yes. That probably was the problem, but unfortunately the go back to Windows 8.1 did not work. Thank you anyway, I had the Cisco VPN installed so probably that was the problem, I will accept the answer. Not going back to Win10 anytime soon though. Jul 30, 2015 at 17:05
  • I had the same problem, and indeed I have VPN software installed. I returned to Windows 8.1, and before trying again, I'll uninstall it.
    – Tobias
    Nov 29, 2015 at 19:36

I had the same problem with network connections not showing up after the upgrade. The issue is with Cisco VPN software client. uninstalling it in windows 10 won't fix the issue. The solution here is to do the following: Revert back to windows 8.1 (recovery options > revert to windows 8.1), next After restore of windows 8.1, go to programs and features > uninstall the cisco VPN client or cisco anyconnect software client, next upgrade your instance of windows to version 10.

This worked and fixed the issue. There weren't any other complications in upgrading from windows 8.1 to windows 10 on my laptop - lenovo thinkpad yoga 12 [2014] with intel dual band 7260ac wireless adapter.

  • 2
    I don't see what this adds to the accepted answer (posted hours earlier), especially given that the asker hasn't even confirmed that they're using Cisco's software. Jul 31, 2015 at 9:44

I do not have the points to comment so i have answered instead.

I had the same trouble and for me @TechnoCore answer worked like a charm!

But later when Windows 10 was up and running with wifi connected correctly I needed to install Cisco VPN Client (version
Cisco VPN Client did not install.
I lost some hours finding a solution but i found the answer there.
Resolving issues with Cisco VPN on Windows 10 Release

In a nutshell, you need to perform the following:

  • Completely remove the Cisco VPN client and any other VPN clients you may have installed while struggling with this.
  • Completely remove Citrix DNE update.
  • Install SonicWall VPN found here.
  • Install Cisco VPN found here. You will need to extract the .exe to a folder, then run the .MSI installer found inside the archive.
  • Apply the following Windows registry fix if you receive the error for enabling the adapter:
  1. Edit: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\CVirtA\DisplayName
  2. Replace value: @oem8.inf,%CVirtA_Desc%Cisco Systems VPN Adapter for 64-bit Windows
  3. With: Cisco Systems VPN Adapter for 64-bit Windows
  • Re-import your .pcf

Hope it helps

  • Hello, slamballx welcome to superuser, if you could when answering a question add detail with the source link as often the links can change and then the users have no information to work from, thanks for the effort Thankyou
    – mic84
    Aug 3, 2015 at 10:48
  • If you have a .pcf I really recommend Shrew Soft VPN Client. SonicWall VPN + Legacy Cisco is a huge bummer. For one example I can no longer communicate to / from guest / host when using virtual machines. Shrew Soft doesn't even install a virtual adapter, it's fantastic. Install and import and connect. I even made a batch script that does it all. cd C:\Program Files\ShrewSoft\VPN Client\ start ipsecc.exe -r MyPcfFile.pcf -u UserName -p Password -a
    – TechnoCore
    Aug 12, 2015 at 23:35

Uninstalling Wireshark along with its WinPCAP driver, rebooting helped to get past the "Identifying" status of the adapter, so I guess it proceeded to IP communication and obtained an IP address from the wireless router.

Not the answer you're looking for? Browse other questions tagged or ask your own question.