20

I have a HP ENVY 17-3200 (switchable graphics: Intel HD 4000 + AMD Radeon HD 7800M) with a triple monitor setup:

  • Laptop's builtin LVDS 1080p display
  • DisplayPort WQXGA display
  • DisplayPort 1080p display

This configuration worked under Windows 7, 8, and 8.1. After upgrading to Windows 10, only 2 displays work. I have the latest drivers.

  • Intel driver 10.18.10.4252
  • AMD driver 15.7.1 (15.200.1062.1002)

I suspect this may have something to do with the fact the 4000's drivers only support WDDM 1.3 and the AMD drivers support WDDM 2.0.

How do I get all 3 monitors working again?

  • same here, I can't get my 3 monitor setup with amd working too - which was working with windows 7 and 8. – HuseyinUslu Aug 8 '15 at 9:58

11 Answers 11

14

I had the same problem. Also tried reinstalling my drivers, did not work.

This is what worked for me:

  1. Right click "Start" and select "Control Panel" (Open classic Control Panel)
  2. In the right corner -> View by: "Small Icons"
  3. Display
  4. Change Display Settings

Now you will see the traditional display configuration screen.

  1. Select ("black/gray") extended monitor
  2. Make sure "Multiple displays" is not set to "Disabled ..."
  3. Select apply once done for all displays.

Done! :-)

I am not sure if I always used the correct terms; my computer isn't in English.

| improve this answer | |
  • Just to elaborate, Right Click on the Start Icon and select Control Panel (ie, open up the classic control panel) Click on Display I had to click on "Change Display Settings" on the left hand panel As Ian said, click on the "black" monitor and make it Extend Desktop to this display, this will enable it and then you can use the normal Screen Resolution window in Windows 10 to manage your displays, just seems Windows 10 doesn't enable the third screen and "hides" the option in the current settings app. – AussieALF Jan 26 '16 at 12:16
  • Perfect solution! – Paul Suart Feb 16 '16 at 23:15
  • 2
    Starting at #4......your 'instructions' don't work for me. I have no "black/gray" anything......and no "extended monitor" anything. Not able to see or bring up or select "Multiple Displays". – Michael Scott Aug 2 '16 at 15:39
  • Then I think there is a problem with your drivers, it looks like your computer is not detecting your monitor at all. When installing the display's on my system the computer recognized the display's but simply disabled them. – Ian van Wijk Aug 3 '16 at 19:17
2

Had a similar problem and got it fixed without reinstalling the drivers.

Basically, all I had to do, was figure out which graphics card is controlling each display and then setup that specific card in its own control panel.

My setup was:

  • ThinkPad T420
    • Intel HD Graphics 3000
    • NVIDIA NVS 4200M
  • 3 external monitors

First of all, basic Windows display settings may be useless.

So next, right click on desktop and select Graphic Properties to get the Intel Graphics Control Panel. There you can check if there are multiple displays listed and/or if you can activate some. For me, there was just one.

Finally, right click on desktop and select NVIDIA Control Panel. Again, check in the multiple displays section, how many displays are listed and if any can be reactivated. For me, there were two and one of them could be activated.

So that solved the problem for me. Just go through all the individual control panels for all the graphics cards and don't rely too much on default Windows display settings.

Substitute NVIDIA Control Center for ATI Catalyst Control Center when applicable.

| improve this answer | |
1

I had a similar problem with NVidia driver. After upgrading to Win 10, only one monitor was working but the NVidia graphics card was not recognized in device manager. I tried to uninstall the driver installed for Win 8.1 in vain. Uninstaller said it couldn't uninstall any Nvidia-related software without any information on the reason.

After repeating reboot a couple of times, I went to device manager and updated driver of the Nvidia graphics card using internet and rebooted again. That did it for me. All four monitors are working alright now. I didn't even have to reinstall CUDA toolkit for the new driver.

BTW, main reason I upgraded to Win 10 was that I can have %^&* Start menu back again. But to my surprise, the upgrading process was very smooth - I didn't even have to reinstall my software packages again - except for the display driver. mess.

| improve this answer | |
  • I am having a similar issue, but not how many ways I try to uninstall and reinstall drivers, it still isn't working, Was Device Manager giving you a Code 43 on the driver? – zeel Jul 31 '15 at 6:07
  • @zeel As I said, trying to uninstall or reinstall drivers never worked for me. 1. Make sure your machine is connected to internet, 2. Go to device manager and right-click Ndivia graphics card and select upgrade driver. It will ask you to reboot. Then it worked. – Tae-Sung Shin Jul 31 '15 at 14:37
  • Yeah, that isn't working for me unfortunately. – zeel Jul 31 '15 at 18:29
1

Try this...

Right click anywhere on your screen and select "Graphic Properties". When the Intel HD Graphics Control Panel comes up click the "Display" tab.

Right under Intel HD Graphics Control Panel is a "Display" with a dropdown arrow. Don't confuse it with the "Select Display". Click the dropdown and select "Multiple Displays". Then select your primary #1 and #2 monitor. Click apply and that should work.

| improve this answer | |
  • Right clicking on the desktop doesn't brring up a Display window/command. I'm on an HP Elite....with Win 10 and Intel HD 4000 graphics card......which, when I try to update the driver, gives me the message that the installed driver is the latest and greatest. Right!! Not. Help!! – Michael Scott Aug 2 '16 at 15:42
1

I tried every suggestion found throughout the world wide web (driver updates, settings, cables, miraculous utilities, etc.) and finally found my solution. I have 2 LG 24" monitors currently. I had already experience the issue of a 2nd monitor not working when the 2nd monitor was my older 19" LG LCD monitor. I fixed once by luck.

It turned out that an LG utility called "Dual Solutions" was loaded up and running in the system tray. When I clicked it, it displayed extended monitors, only it showed it for an even shorter amount of time (1 sec).

I uninstalled the utility via Control Panel/Add Remove programs, and viola! Problem fixed after over 2 weeks of searching and trying various 'solutions'. Now I am enjoying 2 LG 24" LCD monitors running extended display using DVI to HDMI conversion cables (HDMI connection at monitor end).

| improve this answer | |
0

I have a desktop setup with four monitors - two powered by an AMD Radeon HD 7700 and two powered by the on-board Intel HD 4000. After I upgraded to Windows 10, the Intel monitors were black. Windows didn't recognize the Intel HD 4000 display adapter.

What I did to get them going is install the Windows 7 driver for the Intel HD 4000. I found the driver on the disk that came with the Motherboard (I could have downloaded it too) and installed it using Device Manager. Once I did this, my monitors work.

A couple of things to note. First, for some reason I cannot update the Intel driver to the Windows 10 version (the one you are using). I've tried everything but it just won't update. Second, I tried using the Win 8.1 driver for Intel HD 4000 and it causes an infinite loop of BSODs. Only the Win 7/8 (they are the same) driver worked for me.

I guess what I'm saying is that you might want to try using the Win 7 driver for the Intel HD 4000 and see if it works.

| improve this answer | |
  • "Win 8.1 driver for Intel HD 4000 and it causes an infinite loop of BSODs. Only the Win 7/8 (they are the same) driver worked for me." It's funny you say that, cause when I go to Intel's HD 4000 driver download site, it says on two of the drivers descriptions that they're for win 7, 8 and 8.1 – Michael Scott Aug 2 '16 at 17:50
0

I have a Lenovo Thinkpad T410 laptop (dual videocard) in combination with a Lenovo Mini Dock 3. I have 2 external monitors connected and a tv. Windows did not recognize the second monitor.

I was able to solve the problem by activating the second monitor by using the Multi monitor tool from Nirsoft --> http://www.nirsoft.net/utils/multi_monitor_tool.html

| improve this answer | |
0

Please download the latest Intel display drivers.
https://downloadcenter.intel.com/product/81499/Intel-HD-Graphics-4000-for-3rd-Generation-Intel-Core-Processors

The newest driver just came out 2 days ago (19-9-2015).

For other models:
https://downloadcenter.intel.com/

I have a dual-monitor setup with my laptop (Intel i7-4700HQ with Intel HD Graphics 4600, NVIDIA GeForce GT 745M) and upgraded from Windows 8.1 to 10. My laptop screen flickered all the time, even with the cable unplugged. In the end, the problem lies in the Intel display driver. Updating to the new Intel display driver for Windows 10 solved the problem. Reinstalling the latest NVIDIA driver doesn't help, since the desktop or in general Windows is rendered with the Intel HD Graphics.

| improve this answer | |
0

For a Lenovo T530 using Intel HD Graphics 4000 and Nvidia NVS 5400M, upgrading to Intel Driver 15.33.39.4276 (released 9/19/2015) did NOT solve multi-monitor issues.

Intel Graphics control does only show my notebook display in the drop down-list under "Display".

However, notebook display and two external screens work fine as soon as I deactivate the Intel graphics card in device manager.

I am really happy to have an NVidia graphics card built in, otherwise I could not use external screens under Windows 10 as it seems...

| improve this answer | |
0

I had the same problem. Nothing helps. If I deactivated the Intel-Driver the 2 external Displays work. If I activated the Intel-Driver just the Screen of the Lenovo was working.

The suggestion to use the "MultiMonitorTool" was the only solution that works for me.

| improve this answer | |
  • Cool tool, didn't work for me though. My third monitor doesn't show up in MultiMonitorTool either. This was working on Windows 10 before the "anniversary update". – Timothy Lee Russell Aug 13 '16 at 7:09
0

My laptop has intel HD4600 which after upgrading to Win 10 was not willing to use more than one screen. Besides the two external monitors, it detected 4 (four!) additional non-existing screens, but only one displayed content. The current installed Win10 driver was 154028.4501 with release date of Aug 12, 2016. I downgraded the driver to the previous version (release date of 17th June, 2016) and every thing is fine.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.