2

So I have a standard PPTP VPN connection in Windows (8 or 10, behavior is the same). When I connect to the VPN, I'm using a standard username/password combination, not a Windows password and not my machine login password.

The trouble is Windows will save that password as *Session and I have to go remove it from "Manage network passwords" every time I connect or I will lose the ability to connect to any of my regular servers via SMB because it tries to log into those servers using the VPN password.

I've searched around and can find almost no other information about this.

  • Found a 7 year old post that seems related, but I don't think Windows uses PBK files for VPNs anymore social.technet.microsoft.com/Forums/windows/en-US/… – CoreyH Jul 30 '15 at 20:13
  • I've just tried this, from that post: "1. Locate the .pbk file that contains the entry that you dial. To do so, click Start, type *.pbk in the Research Bar, and then press Enter. 2. Open the file in Notepad. 3. Locate the following entry: UseRasCredentials=1 4. Modify the entry to the following: UseRasCredentials=0 5. On the File menu, click Save, and the click Exit." -on Windows 10 1803 and it worked. – colmob Oct 10 '18 at 6:13
0

On Windows 7 you were able to control this via either registry or Connection Manager Admin Kit

The registry to edit is:

User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings]

Value Name: DisablePasswordCaching

Data Type: REG_DWORD

(DWORD Value) Value Data: (0 = default, 1 = disable password cache)

Alternatively you can clear the password by right click (but still every time) enter image description here

0

Check this link: https://docs.microsoft.com/en-us/windows/security/threat-protection/security-policy-settings/network-access-do-not-allow-storage-of-passwords-and-credentials-for-network-authentication

Some of the caveats are listed above. The setting is found by going to Control Panel->Administrative Tools->Local Security Policies. Then open: Local Policies->Security Options->Network access: Do not allow storage of passwords and credentials for network authentication Set it to Enabled

This is not as narrow a setting as you might like, and may not apply to your situation. But for me it prevents our laptop users on laptops from saving their VPN credentials.

At first glance it does not appear to work; it does not prevent the check box from appearing, and the user name appears to be saved in the setup window, but after setup, the VPN connection always prompts for credentials.

-1

On destination server open The Local Group Policy Editor

Go to: User Configuration | Administrative Templates | Windows Components | Remote Desktop Services

Select the Remote Desktop Connection Client item under Remote Desktop Services. In the Setting list on the right, double-click on the Do not allow passwords to be saved setting. Set it to enable.

Now the password will not be saved.

  • 1
    I don't think this is it - this refers to remote desktop and I'm talking about vpn and the windows session password for browsing network shares. – CoreyH Aug 7 '15 at 18:17
  • aren't You authenticating vpn users with local or active directory users? – integratorIT Sep 28 '15 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.