5

Last night I tried to upgrade my Lenovo G580 laptop from Windows 8.1 to Windows 10 using the icon/reserve feature in the corner.

It completed 100%, rebooted, asked me whether to use Express Settings regarding their data collection, rebooted and presented me with a login screen.

I entered my password and clicked Enter and it gave me a black screen with a cursor. I left it for over half an hour and still nothing.

I tried pressing all key combinations. Ctrl Alt Del worked and brings up the menu, but clicking Task Manager wouldn't do anything. I was able to log out or lock the screen and could re-enter my password but still black screen. I tried plugging into external monitors and also using the Windows Key + Enter for narrator and Windows Key + P for projection settings but nothing.

I did a proper restart from the power menu, still nothing. I tried a shut down. Tried to cold boot by pressing and holding the power button, followed by a warm boot. I also tried removing the battery.

I rebooted into the advanced startup settings and tried low resolution mode, but still the same issue. Then I tried the thing about unsigned drivers. Then tried safe mode (normal), same issue. Nothing. I tried safe mode with networking, nothing. (The network side panel would show as well). I tried safe mode with command prompt and the command prompt did show.

I tried opening task manager, which did flash up the small task manager window for a second and then it vanished. Control panel won't open. None of the control panel applets. Regedit did open. "mmc" management centre did open with no snap-ins. I manually added device manager, disk management, services, and event log.

Disk management looked normal. Services seemed normal. Device manager looked okay too except a warning sign on the laptop screen (I think this is caused by safe mode). I uninstalled the drivers for webcam, bluetooth and graphics. Event log showed an error to do with a scheduled task for the browser chooser task, so I navigated in CMD and deleted this task, but on reboot still nothing.

At this point I was worried of losing my data so I went into recovery mode and clicked "Rollback to previous build" which gave me Windows 8.1 back just how I left it.

At this point I am unsure whether to attempt it again or wait. Is it possible to delete the downloaded Windows 10 and get it to re-download just in case it was corrupt or something?

My laptop is a Core i3 with Intel 4000 graphics. 8GB of RAM and a Crucial MX100 512GB SSD (replaced the original hard drive with this SSD).

I am in the UK and the laptop came with Windows 8, I got the upgrade to Windows 8.1 which went smoothly.

Thanks

  • This is likely connected to your GPU. Are you able to boot into safe mode, download the driver from another machine, and attempt to install the production drivers ( if that even works ) otherwise uninstall the drivers and then try booting – Ramhound Jul 30 '15 at 20:16
  • I booted into safe mode but I just had a black screen. The only thing that worked was safe mode with command prompt. I tried to uninstall the drivers and rebooted and still black screen. In safe mode I had no explorer or ability to run any programs, except regedit and mmc management console. – djtwigg Jul 30 '15 at 20:19
  • I missed the part where you are back to Windows 8.1. My best advice wait about 10 days for Intel to release better drivers. You should also perform a backup. – Ramhound Jul 30 '15 at 20:21
  • I'm voting to close this question as off-topic because the poster explains in this post that they have reverted the OS back, meaning, the issue no longer exists superuser.com/questions/948166/… – Dave Jul 31 '15 at 8:59
  • @Dave I understand. I did state in the post above that I managed to revert back to Windows 8.1, but I want to upgrade to Windows 10. This post outlines the issues I had and I want to know how I can avoid it if I try to upgrade again. – djtwigg Jul 31 '15 at 9:21
1

I found the answer. It was because I had installed OldNewExplorer before to modify which folders display in "My Computer" and I think it was to bring back libraries in Win 8.1.

People have reported problems when explorer has been modified by things such as ClassicShell etc. Anything that modifies explorer may break the Win10 upgrade.

I uninstalled OldNewExplorer and the upgrade completed successfully.

0

Had this problem and solved it myself.

I opened Task Manager first and then opened the Device manager and I noticed had a yellow triangle next to Nvidia graphics card.

I used the Task Manager to open Firefox.exe and downloaded updated graphics drivers.

Installed and hey presto!
We have a full gui again :)

  • I tried uninstalling my graphics drivers but to no avail. – djtwigg Aug 4 '15 at 10:10
0

I had this same problem and solved it by booting in safe mode with networking. Then I opened the device manager and under display adapters I uninstalled both my Intel HD grapics driver and NVidia driver, then I restarted it and it worked.

  • I tried uninstalling my graphics drivers but to no avail. – djtwigg Aug 4 '15 at 10:10
0

Had the same thing. Just wait it out. Go get coffee or something and when you get back you'll be at the right screen.

I'm sure MS will fix this with some kind of thing showing activity... but the login screen will appear if you give it a few minutes.

  • Same thing happens to me. Usually it is about 20 mins. But last night I waited it for 1 hour... well, rebooted rebooted and desperately rebooted and tried to access it for an hour an a half. Maybe I never waited for the full 20 mins. This problem sucks and I have no idea what it is. I don't have any nVidia drivers on my machine. I also don't have OldNewExplorer instaled. – Pedro Oct 15 '15 at 2:51
  • One good workaround to mention is that RDP works. So if you have that enabled you can still access your computer from another computer. – Pedro Oct 15 '15 at 2:54
0

The problem could be because Windows Explorer is crashing after login (Symptom: You can see the desktop for a few seconds before the black screen comes up).

The answer here solved this problem for me: (http://www.tenforums.com/general-discussion/15245-file-explorer-keeps-crashing-post477925.html#post477925) in the thread: (http://www.tenforums.com/general-discussion/15245-file-explorer-keeps-crashing-post477925.html#post477925)

Here is a copy/paste of that answer for the purpose of completeness:

"[soporifics Junior Member Join Date : Nov 2015 Posts : 1 Windows 10] This sounds like a manufacturer sound audio issue for some of us. I found this solution and it worked for me. I found some error in the Events Manager and this one was relevant "IDTNC64.cpl." "The root cause of the problem is that the audio software supplied by IDT and used by several PC manufacturers (Dell, HP and probably others) is not compatible with Windows 10. IDTNC64.CPL is one component of that software and the correct solution is to uninstall the IDT audio altogether. Provided you have just restarted your PC, you should be able to use a Windows Run Box (Win Key + R) before the crashes get too serious. Type 'control panel' into the run box prompt and when the Control Panel appears, use Uninstall to seek out the offending IDT program - on my PC it had an icon of a musical note with the letters IDT next to it - and Uninstall. On rebooting the PC (use Ctrl-Alt-Del to power down if necessary) and restarting, Windows will automatically detect any missing audio drivers and install appropriate ones (not from IDT). You can then check that IDTNC64.CPL is no longer present in C:\windows\system32. If you have not yet migrated from an earlier version of Windows, it is best to Uninstall the IDT software in the old operating system (again, Windows will automatically reinstall compatible drivers) before attempting the upgrade to Windows 10." After days of troubleshooting, I finally have no desktop or file explorer loop crashes! Thanks (Mikedt10 !)"

protected by magicandre1981 Sep 12 '15 at 6:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.