2

I have a similar problem to this user: No network connection after upgrading to Windows 10

I have a surface Pro 3 and after upgrading I have no internet. Recovery says there are no points to rollback to. Settings, and the rollback to windows 8.1 options both open and close immediately.

I have cisco VPN installed and I get an error when I attempt to uninstall. Any thoughts on possible solutions?

  • Please provide details of the symptoms you're experiencing, and what does or doesn't show in Control Panel / Network Connections etc - "no internet" is not much to go on. – Reg Edit Jul 30 '15 at 21:18
  • I had this issue as well, it seems legacy cisco vpn really destroys the windows 10 upgrade. Symptoms: network adapters show in device manager and look normal. However, in "Control Panel\Network and Internet\Network Connections" it's completely empty. – TechnoCore Jul 30 '15 at 21:52
  • I was able to get the network adapters working following the instructions below from bonh. However I am still stuck as I cannot rollback or access settings. I just got an error that closed itself when trying to access update settings. It said something along the lines of cannot run this program as it is not in the correct group. – Dan Jul 30 '15 at 21:57
3

Getting your network connections back

I had the same problem on a Lenovo Yoga 2 Pro. I got my network devices by running the following in an Administrator command prompt:

netcfg -s n
reg delete HKCR\CLSID\{988248f3-a1ad-49bf-9170-676cbbc36ba3} /va /f
netcfg -v -u dni_dne

It has to do with the legacy Cisco VPN client:

We believe in cases where there is a Legacy Cisco VPN that the filter driver is only migrated partially. This filter driver is marked as Mandatory and causing issues with the Network Interfaces. There is a fix in the pipeline that blocks this particular version of the Cisco VPN solution that has this Filter driver from upgrading. The latest versions of Cisco VPN do not have this driver.

Reinstalling the Cisco VPN Client

If you get this error when trying to install the Cisco VPN client:

Error 27850. Unable to manage networking component. Operating system corruption may be preventing installation.

...then it's time to reinstall DNE.

  1. Download and install winfix.exe from http://www.citrix.com/go/lp/dne.html
  2. Reboot.
  3. Download and install dneupdate.msi (32-bit) or dneupdate64.msi (64-bit)
  4. Reboot.

Now you should be able to reinstall the VPN Client.

Re: registry

One piece of advice was to change the registry key for HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Network\MaxNumFilters from 8 to 14. I didn't have this key on Windows 10, and when I created it (with a value of 14), it didn't solve the problem.

  • Thanks. I was able to get networking working using by deleting the reg entry but am still having issues. I am still having the problem where settings and the rollback feature closes immediately. I am reading through your link, but will need to dig in further later as I am at work. – Dan Jul 30 '15 at 21:45
  • @Dan Check out my updated answer. – bonh Aug 4 '15 at 15:45
  • This is the only thing that worked for me. Thanks dude – ankit suhail Aug 18 '15 at 12:30
1

I had this exact issue as it would not get an IP address. After trying to remove re-adding, assigning manual IP, I googled and found this and it worked:

  1. Press the Windows Key + X together and select Command Prompt (admin).
  2. Type the following commands and hit Enter after each:

    • netsh winsock reset catalog (reset winsock entries)
    • netsh int ip reset reset.log hit (reset TCP/IP stack)
  3. Reboot the computer and check.

0

I had this same problem - no network stack after upgrading. I followed these directions, however, since I have the Juniper (now Pulse) VPN client, these registry values did not work for me.

Even after force deleting the VPN applications in Windows 10 I still had no network properties showing on my adapters.

My solution was to

  1. Downgrade using the Microsoft automated downgrade (must perform within 30 days of upgrade)
  2. All of my VPN applications reappeared
  3. Manually delete (Remove Program) VPN applications and adapters
  4. Upgrade again - this time my network remained functional!
0

On my Dell Precision T1700 I tried the netsh resets and then simply resolved downloading the latest drivers from the manufacture's website, the ones for Windows 10 (using another PC to download and an USB drive to transfer the files...).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.