5

I have just updated Windows 7 to Windows 10. My touchpad scolling (right-side) is not working anymore.

I have no idea how to fix this in Windows 10.

I have hit the start button and typed "synaptic", but have found nothing useful.

I used to have an icon on the taskbar that showed where I was touching the touchpad. I used to be able to right-click that icon to change settings, but Windows 10 has not brought that icon over.

Also, the asus website has no synaptic touchpad drivers available for Windows 10. I have tried the enaltech drivers, but upon the installation atempt I am told that my hardware is not correct.

6
  • 1
    You need to install synaptic drivers that support Windows 10. I am happy to find it, I just need to know, what sort of Synaptic device you have specifically.
    – Ramhound
    Jul 30, 2015 at 21:43
  • @Ramhound In Linux I know I could do lspci, but I don't know how to find that out in Windows. Any tips? Jul 30, 2015 at 21:44
  • 1
  • 2
    Synaptics v17 Drivers should work, any ASUS specific gestures will be lost, but none work now so there is little downside. I had no problem finding Windows 10 Synaptics drivers. Are you sure you have a Synaptic touchpad though. The product page offers Synaptics and Elantech device drivers only one is applicable to your hardware.
    – Ramhound
    Jul 30, 2015 at 21:51
  • 1
    The fact you didn't get a list tells me the device isn't going to be support Windows 10 or be given drivers by ASUS to support it at least.
    – Ramhound
    Jul 30, 2015 at 21:54

7 Answers 7

5

I had the same problem in my windows 10, 64bits. So this is what worked for me:

1.- Go here http://www.asus.com/Notebooks/X44H/HelpDesk_Download/

2.- Select Windows 8, 64 bits

3.- Download (Synaptics Touchpad driver) 145.15 MBytes. And Install it usually.

4.- When the install is complete, restart Windows.

5.- After Restart windows, on screen will appear some alert to launch the Synaptic Program. Unmark the label "always ask before opening this file" in all the alerts, and launch the programs.

6.- And that´s it. The alerts will never appear in the next restarts, and you will be able to use Scrolling in Windows 10.

enter image description here

0
  1. Go to the start > settings > mouse@touchpad > touchpad.
  2. Select no delay and click "additional mouse options"
  3. In the new window for mouse options you will see ELAN tab (maybe the name of your pad is different). If you see ELAN pad disabled, enable it and deselect the option "disable when external usb pointxxxxxxx"
  4. Click Apply and OK

The pad and mouse will work at the same time.

0

Running ASUS K55A 64bit with Windows 8.1; then upgraded to Windows 10 and ASUS smart gesture touch touchpad changed to Toshiba.

Downloaded correct synaptic driver but won't install- informs me no synaptic present.

Did a driver rollback and now have ASUS smart gesture back with the correct icon.

0

I had the same problem. I have an ASUS laptop and I upgraded from windows 8 to windows 10, but the scroll on my mousepad stopped working. I was able to fix it from my settings and now it works. Here's what to do:

  1. Go to settings, and click on the option "devices"
  2. Click on "mouse & touchpad" then go all the way down to the bottom to "related settings" and click on "additional mouse options"
  3. Another window will open up, labelled "mouse properties". Go to "hardware" from the top menu, then click "properties" near the bottom right corner
  4. Go to "driver" and then click "driver details"
  5. Another window will pop up. There will be a list of 3 driver files. (I had three files, but it may be different for other computers)
  6. Again, it may vary for certain computers but I clicked on the second driver file, pressed "okay" and my scroll started working. If this doesn't work, try selecting the last driver file and it may work.

To anyone having problems with their scroll, I hope this helped!

0

Although the selected answer is correct, I wanted to point out that the Elan driver was presented to me instead of the Synaptics driver which caused me some trouble.

This is of course assuming that your touchpad is in fact a Synaptics brand. You don't have to worry too much about identifying it as the Elan driver will tell you that it's not meant for your device and refuse to install if chosen by mistake.

To find the Synaptics driver you must click on "Show all" below the Elantech Touchpad driver:

enter image description here

enter image description here

-1

You just have to remove "Smart gesture" from your programs. then go to this link https://www.asus.com/support/FAQ/1013137/ and download the new driver.

Thant's it.

1
  • 1
    Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Jul 31, 2015 at 16:29
-2

The way I fixed my laptop was by first removing the devise and uninstalling synaptic from control panel remove programs. Restart! After going to manufacturer website and downloading the windows 8.1 driver. When I go to the pointing options in Control panel I get a few windows errors but everything works. I am guessing this will get fixed by synaptic whenever they get around to get their drivers updated! You know it is not like they had warning of a windows release :(

4
  • Microsoft sent out an RTM version of Windows 10 to manufacturers before the release. The previews have also been out for a while.
    – MC10
    Jul 31, 2015 at 1:44
  • I was trying to make it clear that it was sarcasm! The fix really did work for me --- no need to vote down the solution because of a joke :)
    – Alex Top
    Jul 31, 2015 at 3:46
  • So your answer is a joke? Why use sarcasm on a site for accurate information...
    – MC10
    Jul 31, 2015 at 4:05
  • @AlexTop - I don't see a solution in your answer just a bunch of commentary. If you want reputation for this answer provide more details.
    – Ramhound
    Aug 7, 2015 at 16:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.