14

I know what you're thinking, "Just go to the VPN connection, right click and go to properties > Networking > IPv4 > Properties > Advanced > Uncheck 'Use default gateway on remote network'"

Unfortunately I cant do this, when I click on IPv4 and click Properties...nothing happens.

Does anyone know why its not letting me go into the properties of the IPv4 protocol?

I've tried restarting the computer. Deleting and readding the connection. No matter what I cant go into the properties. Although I can go into properties for my regular LAN connection.

If this is a windows bug, does anyone know a way around this? Perhaps a registry setting?

Thanks!

1
  • 3
    Funny, the question actually answered the question for me, thanks! – Andrew Jul 18 '16 at 14:30
14

If you need to keep your Internet connection when you connect to the VPN, you can do the following:

Open "PowerShell" as an administrator, and with the following command you can fix it. Note that you should reboot the PC after this.

PS C: \> Set-VpnConnection -Name "YOURVPN" -SplitTunneling $True -PassThru 

For more support and documentation see:

https://technet.microsoft.com/en-us/library/jj554823(v=wps.630).aspx

5
  • If you get a message "System could not find the phone book entry for this connection", try adding -AllUserConnection. A VPN can be created at the logged-in user level as well as at the "all users" level. – tijmenvdk Oct 19 '15 at 8:47
  • Note that this does not route your traffic though the VPN, but actually routes though your normal connection. – Jonathan Gawrych Jan 13 '16 at 21:38
  • @tijmenvdk for me it is failing. I am using "FortiClient" and when I run above command, I get below error At line:1 char:1 + Set-VpnConnection -Name "Sigmasoft" -SplitTunneling $True -PassThru - ... + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : ObjectNotFound: (Sigmasoft:root/Microsoft/...S_VpnConnection) [Set-VpnConnection], CimEx ception + FullyQualifiedErrorId : VPN 623,Set-VpnConnection Please help! thanks! – OverrockSTAR Mar 14 '16 at 20:56
  • [Set-VpnConnection -Name "YOURVPN" -SplitTunneling $True -PassThru] This command work for me on my Windows 10 machine. Thanks a lot.... – Optimus Aug 4 '16 at 10:29
  • I had to do it like this on PowerShell 5.1: Get-VpnConnection -AllUserConnection | Where-Object { $_.Name -eq "YOURVPN" } | Set-VpnConnection -SplitTunneling $True -PassThru – intrepidis Sep 24 '18 at 9:48
1

Israel's answer put me in the right track but I still has a few issues. Here is what I did to make it work:

Open "PowerShell" as an administrator and type:

Set-VpnConnection -Name "Your VPN Name" -SplitTunneling $True 

On the "Network and Internet" settings window, click on "Change adapter options", then right click on the VPN connection => Properties => Networking => Internet Protocol version 4 => Properties => Advanced => make sure "Use default gateway" is un-ticked.

At this stage I could connect to VPN and use internet... but only for a few minutes. After that Outlook got disconnected, and I couldn't access new web pages (old one that I had opened before connecting to VPN still worked). I realised something was wrong with DNS.

What I had to do was to go back to the Internet Protocol version 4 properties (c.f. above) and select "Use the following DNS server addresses" and type 8.8.8.8 in the "Preferred DNS server" box. This IP is Google's public DNS server. Feel free to use any one you prefer.

After reconnecting to the VPN is all worked normally (what a massive pain it was).

1

Ended up using this to set split tunneling in W10 in order to PPTP to our Linksys router.

set-vpnconnection -name "PPTP VPN Connection" -splittunneling $true -passthru -alluserconnection

This steps apparently achieve the same

Network and Internel settings -> Change adapter options -> select your vpn connection -> Prperties -> Networking tab -> select IP V4 -> Properties -> Advanced -> uncheck Use default gateway on remote network

1
  • There is no checkbox there on updated windows 10s. – Overmind Aug 19 '20 at 9:23
0

I had no VPN problems with OpenVPN server running on an old XP (32-bit) file server with Windows 10 OpenVPN clients. The Open VPN software created a "bridging" network between the two sites and all was ok. I then thought I would upgrade (silly me ) using the OpenVPN firmware in Netgear R7000 to take load off the XP file server. Then this problem happened - when VPN connected, the local client internet went down. Doh! But then I remembered what the software version did - a "bridged network"....

Simple Solution for Windows 10 client:

Go to Control Panel\Network and Internet\Network and Sharing Centre

On the left click "Change adapter settings"

Select your VPN and usual local network and right click, then bridge

Now you can access both VPN and internet. Have fun!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.