8
  • OS: Just upgraded to Windows 10 from Windows 8.1
  • Software: Display Fusion v7.2 (if meaningful)
  • Adapter: NVIDIA GeForce 650 Ti

Yes, I upgraded the NVIDIA GeForce driver to Windows 10. I had to, as the only way to bring back the driver and get dual displays. The driver is fine, as are the monitor drivers.

I had the auto-hide feature working up until now. Now, just after upgrading to Win10, the primary display taskbar no longer auto-hides. The secondary display taskbar hides nicely.

If I elect to have only one taskbar, then the primary taskbar still does not hide. I can, however, auto-hide the taskbar for an instant if I uncheck the option to auto-hide the taskbar, click on apply, and click the box to auto-hide the taskbar, and then finally click on the apply button.

No other software is running, so that is not the issue. A reboot does not fix the problem. As far as missing network connections or other system tray issues needing my attention, everything is fine.

In searching articles, one person suggested the obvious: to click on the "Search the web and Windows" and then click away or click on the Start Menu and then go back to the desktop, but alas the taskbar still remains.

Did Microsoft actually test this feature with dual displays?

The problem really seems to be a dual monitor issue. Thoughts?

Update: I turned off the computer in the evening and when I turned on the computer, the primary taskbar was auto-hiding. I was floored, as I had rebooted the previous night. My joy lasted about 30 seconds. As soon as I touched the keyboard to do something, I think launch Microsoft Edge, the taskbar was back to its old ways.

I will temporarily uninstall Display Fusion to rule that out as a suspect tomorrow.

  • "The problem really seems to be a dual monitor issue."  An anonymous user (going by the name "Dave") commented that he had the same problem with a single monitor. – G-Man Aug 23 '15 at 0:25
  • Sarah, you may have it fixed but it will come, it does periodically, from XP onwards, on every version of windows. It just loses the settings. JUst uncheck Autohide, take focus away from the task bar and then recheck. – Rohit Gupta Oct 8 '15 at 1:11
6

I had this problem after upgrading from Win 7 64bit to Win 10. What I found was that Microsoft's OneDrive app was causing the issue. Once I exited OneDrive from the hidden icon area, my taskbar went back to normal. I've since uninstalled OneDrive completely.

More specifically...

  1. The Win 10 taskbar refuses to autohide if there's ANY notification "barking," and that's the way to attack it. Settings / System / Notifications and Actions. First, go to Notifications and turn off "Show app notifications." If that solves the problem, then you KNOW it's one of your "notifying" apps. Then just turn "Show App Notifications" back on, and focus on the app notifications one by one.

  2. Back to OneDrive... in my case it is OFTEN OneDrive. You should be able to click it and choose "Repair" and at least you can make it happy. Or just disable OneDrive's ability to block the taskbar autohide.

  • That might be the issue/solution. I have not had an issue since the problem went away the 3rd time or so, however I do recall that OneDrive went through an upgrade and somehow reinstalled itself, as I had to specify the the folder mapping and other settings. That was right around the time that the problem went away too. You might have stumbled on the cause. – Sarah Weinberger Aug 10 '15 at 21:50
  • @Sarah: If the problem hasn't come back, please consider accepting this answer.  (Or post your own answer (and accept that).)  That will (1) let other people who have the same problem see at a glance how your situation was resolved, and (2) make it obvious that this question has been resolved, so people know that they don't need to try to answer it. – G-Man Aug 23 '15 at 0:26
  • Independent of you asking for me to accept this answer, I did catch one other time when OneDrive wanted attention and I do suspect now that OneDrive was the cause. I agree with you, especially because OneDrive at the time tossed me a few messages wanting me to log in again. – Sarah Weinberger Aug 23 '15 at 2:24
  • Fixed for me as well.. c'mon MS. – SgtPooki Jan 19 '16 at 5:13
4

Do you have the search hidden on the taskbar? I was having this same issues that persisted through reboots, but re-enabling the search icon/box and then disabling it again allowed both taskbars to auto-hide.

  • The search box shows nicely on the taskbar. I did not make any changes, as I had literally just upgraded to Windows 10. I installed the video driver and set the resolution back to HD. Once that was done and dual displays were set up, I started to work on this auto-hiding taskbar problem. – Sarah Weinberger Jul 31 '15 at 21:14
4

In Task Manager, try to re-start the 'Windows Explorer' Windows Process.

1

I solved this by:

  1. Clicking on "show hidden icons"
  2. Clicking on "HP Printer status and alerts"
  3. Clicking outside the taskbar

It looks like an HP error message prevented the taskbar from hiding. Windows and HP users: set the icon to flash, showing that it is preventing the taskbar from hiding.

0

This worked for me to resolve the identical problem; Right click on desktop and select DISPLAY SETTINGS, highlight secondary screen, check MAKE THIS MY MAIN SCREEN box, click APPLY. Highlight your primary screen and do the same to reverse your action. Task bars should now auto hide.

  • I had tried that at the time, however now, thankfully, the problem no longer materializes, knock on pressed wood. After a day and a couple of boots, the problem went away. I do know that there was a Windows 10 update, which I presume my computer automatically installed as yesterday I saw no updates available, so possibly that resolved the issue. – Sarah Weinberger Aug 5 '15 at 20:17
  • I just had this problem after installing the Windows 10 update. In my case clicking on the "Show hidden icons" caret and right-clicking each one fixed the problem. This was suggested here. – Mark Hurd Aug 8 '15 at 16:58
0

In my case the problem was caused by an app (a utility for an external WD HD)running in the background. The solution involved closing the app by displaying it via the "show hidden icons" option that appears when one hovers over the "^" symbol in the task bar. I can imagine other apps having the same annoying impact on taskbar behavior so it may well be the case that each user plagued by a non-hiding taskbar will have to experiment as I did before finding the culprit. Good luck.

0

In my instance, the toolbar would not hide on the secondary display with Windows 10. After reading all the suggestions and trying them, I tried the following (with success): right click on primary display toolbar, click on "search", select "Show search icon". I had previously selected "Hidden"

protected by bwDraco Aug 24 '15 at 0:55

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.