I have disabled (uninstalled) Hyper-V so I can run VM-Ware and have completely lost the network. It shows the cable connected but there is no internet connection. Ive tried a different cable and have reset my switch and router with no success. If done the netsh commands to reset the ip, ipv4, ipv6, winsock and I have killed the two winsock keys in the registry. Was unable to edit the nettcpip.inf file - access was denied (even after running notepad as administrator).

I am running out of internet searches and ideas. Does anyone have an idea of what I need to do (short of re-installing windows)?

5 Answers 5


I uninstalled all my Network adapters in Device Manager and then I right-clicked and chose Scan for hardware changes and my existing/standard adapter came back and was working right-away.

  • Yup this works for me.
    – GeneCode
    Mar 14, 2018 at 4:12
  • This worked for me too. I did not check the “delete drivers” option, just uninstalled the devices and scanned for changes.
    – Lynn
    Mar 26 at 0:44

I had a similar problem after removing Hyper-V, and resolved it by reconfiguring my netowork adaptor. I had to do this because I discovered the netsh commands had left things in an invalid state.

According to, to pick one example of many, this blog, the following netsh command "Removes all user configured IPv4 (Internet Protocol version 4) settings":

netsh int ip reset

However, what I found was that while this command did clear the static IP address I'd set, it left the option selected to use a static IP address:

enter image description here

Once I re-entered my static IP settings, the yellow triangle disappeared and the network came back.

To satisfy myself that netsh had really done this, I repeated the whole exercise, adding and removing Hyper-V, and exactly the same thing happened when I gave the above netsh command. It seems netsh is somewhat buggy. Its use for TCP/IP functionality should anyway be viewed as deprecated: while looking at the netsh commands I noticed advice to this effect from Microsoft, which doesn't show up when full netsh commands are used, but only when you go to the "int" (interface") level in netsh:

In future versions of Windows, Microsoft might remove the Netsh functionality
for TCP/IP.

Microsoft recommends that you transition to Windows PowerShell if you currently
use netsh to configure and manage TCP/IP.

Type Get-Command -Module NetTCPIP at the Windows PowerShell prompt to view
a list of commands to manage TCP/IP.

Visit http://go.microsoft.com/fwlink/?LinkId=217627 for additional information
about PowerShell commands for TCP/IP.
netsh interface>ip
netsh interface ipv4>
  • So what is the proper Powershell command?
    – Ramhound
    Dec 7, 2015 at 18:32

I finally ended up restoring from a restore point. I am sure there is something else that can be done instead, unfortunately, I needed the network on that computer immediately.


When Hyper-V is enabled, only Hyper-V Extensible Virtual Switch is selected but nothing else. Uninstall Hyper-V just remove the current selection and nothing is selected. Manually selecting whatever you need there should fix the issue. You better have another working machine for reference. When Hyper-V is enable


Here are the step that finally worked for me:

  1. Rebooted into safe mode
  2. Opened the Device Manager
  3. Disabled all of the Hyper-V devices.
  4. Rebooted.
  5. Removed Hyper-V from the Add/Remove Windows Features.
  6. Rebooted.... and all was well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.