31

I just did a clean install of Windows 10 (Pro N) and installed iTunes (12.2.1.16). Now for some reason iTunes automatically starts whenever I start my PC. I've already tried to find a solution on this site and google and followed different steps to no avail. I've tried:

  • In Task Manager -> Autostart: Disable anything iTunes/Apple related. I only have "iTunesHelper" and tried disabling it, but iTunes still starts up automatically.

  • Use CCleaner: Again, only "iTunesHelper" as Startup, and disabling it doesn't change a thing.

  • In iTunes -> Settings: I've disabled automatic sync with iDevices. I also don't have any iDevices plugged into my PC on startup.

  • In msconfig: I disabled all services related to Apple. The startup tab is only a link to the task manager again.

  • In registry: I checked local and current user services, and disabled "iTunesHelper" here too, without a change.

  • (update) Autoruns: I downloaded AutoRuns for Windows and unchecked everything related to Apple and/or iTunes, but this didn't prevent iTunes from launching either.

Some more googling gave me the idea that the problem could be a different program/device than iTunes itself, namely a device with media controls or an external hard drive with media.

  • Corsair Utility Engine: I have a Corsair K70 RGB with media controls, so I disabled CUE automatic startup in task manager. Now it doesn't automatically start anymore, but iTunes still launches.

  • Logitech Gaming Framework: I have a Logitech G700 with media custom controls, so I disabled LGF automatic startup in task manager. Now it doesn't automatically start anymore, but iTunes still launches.

  • WD MyBook: I have an external hard drive with a lot of media (music/videos) on it, so I unplugged it and then restarted my PC several times. iTunes still automatically launches on every startup.

Now I'm running out of ideas why iTunes is automatically starting up on every launch. Does anyone have an idea what could be causing this issue and how to resolve it? The only thing that is actually working is uninstalling iTunes, but that is not really an option for me.

EDIT: I don't know if it may be hardware related but just in case, this issue occurs on a PC with an i5 3570 with a HD7950 on a GA-Z77X-UD3H. The system and iTunes itself are installed on a 850 EVO, and there's another SSD (Intel 520) for games and HDD (Seagate Barracuda) for media/backups built in.

  • Try uninstalling and installing the older version here. – MC10 Aug 5 '15 at 11:37
  • Have you checked to see if iTunes has any services that it starts up? Task Manager -> Services brings up a list of services, change anything Apple related to manual or disabled. Also, you say iTunes starts when your computer does, do you mean that the icon appears in the tray? or that the iTunes windows opens up? Maybe it's an issue with the icon VS the application. (I would have commented rather than answer if I had the rep) – Centimane Aug 5 '15 at 12:12
  • In Windows 7, the damn thing kept autostarting, even though I disabled it in msconfig. I found that the "Task Scheduler" was running it. 1. Click the Windows Start button in the lower-left corner and type task scheduler in the Start Search box. 2. Open the “Task Scheduler“. 3. Expand the “Task Schedule Library” section. 4. Select the “Apple” folder. 5. Right-click “AppleSoftwareUpdate” and select “Disable” or “Delete“. Source – 287352 May 8 '19 at 17:10
37
+50

EDIT: This behaviour is due to a recent change in iTunes 12.2 that apparently causes iTunes to launch whenever Plex Media Server is started:

The generation of the XML is now optional in iTunes 12.2 - check Preferences > Advanced and set the option Share iTunes Library XML with other applications.

In order to fix it, simply turn the option Share iTunes Library XML with other applications on.

Original answer: I'm having the same issue as you. Tried all the same things that you tried. I'm not sure if it is hardware related since I don't have the same hardware as you, except maybe for me also having an i5 (4460). What I'm wondering is if you had that problem ever since you had iTunes or did it happen after you installed other software. Because I know for certain that it wasn't doing this from the beginning when I installed Windows 10 and iTunes. I feel like it started on my end when I installed "Python" and "Plex Media Server". Could it be that you also have these Programs installed?

|improve this answer|||||
  • I also have Plex Media Server, and with it comes Python. I tried to reinstall pretty much all my essential software after the clean install of Windows 10, so I couldn't notice whether iTunes was launching itself automatically immediately after installation or only after Plex was installed. – Huy Aug 5 '15 at 18:03
  • Maybe give that a shot. It seems to be one of the only things that our problem has in common. – eQual Aug 5 '15 at 18:06
  • It seems like it has something to do with Plex. If I disable automatic startup of Plex Media Server (which also includes "Conhost", "Plex Media Server DLNA Service" and "Python"), iTunes no longer launches on startup. Also, as soon as I start Plex Media Server, iTunes launches too. – Huy Aug 5 '15 at 18:11
  • 1
    I have a fix. Go to your iTunes Preferences > Advanced and set the option Share iTunes Library XML with other applications. This fixed it for me. Finally! It was driving me insane!!! – eQual Aug 5 '15 at 18:18
  • 1
    I have edited your original answer to contain the important information so that everyone who stumbles upon this question will immediately see how to fix it, and also I can accept your answer. – Huy Aug 5 '15 at 18:21
2

Just an idea, but try running this from a command prompt: start shell:Startup and see if the iTunes shortcut is there. If it is, simply delete it.

UPDATE: iTunes is apparently not compatible with Windows 10, which could explain the erratic behavior. I found this out after a live chat with apple.

|improve this answer|||||
  • I already tried an equivalent approach and checked the corresponding folder directly (user/AppData/Roaming/Microsoft/Windows/Startmenu/Programs/Autostart) but unfortunately, there's no iTunes shortcut there. – Huy Aug 2 '15 at 8:39
  • @Huy is Sync with this iDevice over WiFi turned on? – td512 Aug 2 '15 at 8:43
  • No, it is turned off for all my iDevices since I didn't build WiFi into my PC. – Huy Aug 2 '15 at 8:47
  • @Huy can you try reinstalling iTunes? – td512 Aug 2 '15 at 8:48
  • As I stated in my original post, I already did uninstall iTunes at some point to see whether this causes any problems. However reinstalling iTunes resulted in the same issue. – Huy Aug 2 '15 at 8:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.