8

I posted a question recently regarding my Windows 10 upgrade which ended up with a black screen and cursor. QUESTION

I reverted back to Windows 8.1 using the "Revert to previous build" option in recovery, and all seems fine, except that Virtualisation is disabled.

I tried to open BIOS settings but it just boots into Windows. I've tried the usual F2 key and Shift F2, all the other F keys, tried pressing B and Shift+B but no luck.

I tried pressing the Lenovo key on the laptop when it is powered down, which shows a menu to either boot into BIOS, recovery, or show boot menu. I choose BIOS and it just boots into Windows.

I tried going into advanced startup options from Windows (Shift+Restart) and choosing "UEFI FIRMWARE SETTINGS" but it just reboots back into Windows.

Before the Windows 10 upgrade it was working perfectly.

Lenovo G580 laptop - Core i3 with Intel 4000 graphics. 8GB of RAM and a Crucial MX100 512GB SSD (replaced the original hard drive with this SSD).

  • 1
    Wait, does this mean the other question is no longer valid? – Dave Jul 31 '15 at 8:51
7

This is a common problem in all Lenovo laptops. I also have faced this problem so many times. For solving this please go to the link(link of official Lenovo's support site) and download latest bios setup and install it. It will update your bios and all will be all right. Download bios set for window 8.1 and install it. The manual also is given in PDF format. http://support.lenovo.com/in/hi/products/laptops-and-netbooks/lenovo-g-series-laptops/lenovo-g580-notebook

Update:

After this again the same problem happens with me but this time I already have latest BIOS version installed in my system and the Lenovo don't allow the installation of same or lower version of the BIOS in existing latest BIOS. So I stuck there and can not do anything. I also approached to the Lenovo service center but they are also helpless they suggest me to change the motherboard which cost me around 10000 INR.

  • This worked for me. I updated BIOS and it fixed everything. – djtwigg Aug 4 '15 at 10:10
0

I've heard other tales of EFIs that stop responding to their function-key (or similar) methods of entering the firmware setup utility. Typically, this seems to be related to adding too many firmware settings or otherwise hitting an "unlucky" combination of settings. Some ideas for working around the problem include:

  • There are procedures in Windows to enter the firmware setup utility, as described here (among other places; try a Web search to find more).
  • Some boot managers provide an option to enter the firmware setup utility. GRUB 2 (which ships with most Linux distributions) does, but the feature might or might not be active on any given installation. The gummiboot boot manager (which has now been folded into systemd) provides a similar feature, as does my own rEFInd. Of these, rEFInd may be the most useful, since I provide USB flash drive and CD-R images; if you can boot from an external medium, you can boot to rEFInd and use its boot-to-firmware option without touching your hard disk. The option is an icon in the form of a computer chip on the second row. Note, however, that this option will not always be present, since the necessary system calls aren't present on all EFIs. Also, to boot a standard rEFInd image, you'll need to disable Secure Boot. If Secure Boot is active, you'll need to add Shim to the image, which requires some learning.
  • You can probably force the firmware setup utility to load by unplugging all your hard disks. Of course, this may be very awkward on some modern laptops, which often have inaccessible disks.
  • Deleting all your partitions, or at least the EFI System Partition (ESP), may have a similar effect. Of course, that's a rather destructive option. You might try it if you're comfortable with partitioning tools and if you're confident you can recover the original partition, either by re-creating it exactly to restore the original filesystem or by doing a backup before you delete it.

Once you're in, you might want to reset the firmware settings to the defaults. With any luck, you'll then be able to enter the setup utility in the usual way.

protected by Community Jan 31 '16 at 7:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.