Sorry if this is a bit technical, I posted it earlier on MS support forums but they weren't helpful so I'm hoping if someone here had the same issue and was able to fix it. I got my free Windows 10 upgrade yesterday and it installed with no errors or issues. Everything works fine, all devices have their drivers installed, I did not install any additional driver or application since I upgraded yesterday. The issue is with the new Xbox app, when I try to run it it pops up for a second and crashes. I found the following error in Windows event viewer:

Log Name:      Application
Source:        Microsoft-Windows-Immersive-Shell
Date:          7/30/2015 6:07:29 PM
Event ID:      5973
Task Category: (5973)
Level:         Error
User:          ZAID-HOME-PC\Zaid
Computer:      Zaid-Home-PC
Activation of app Microsoft.XboxApp_8wekyb3d8bbwe!Microsoft.XboxApp failed with error: The app didn't start. See the Microsoft-Windows-TWinUI/Operational log for additional information.
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Microsoft-Windows-Immersive-Shell" Guid="{315A8872-923E-4EA2-9889-33CD4754BF64}" />
    <TimeCreated SystemTime="2015-07-30T15:07:29.767631500Z" />
    <Correlation />
    <Execution ProcessID="4288" ThreadID="2736" />
    <Security UserID="S-1-5-21-1677041472-2942404152-2187633501-1001" />
    <Data Name="AppId">Microsoft.XboxApp_8wekyb3d8bbwe!Microsoft.XboxApp</Data>
    <Data Name="ErrorCode">-2144927141</Data>

All other applications desktop and modern style work fine except for Xbox. I then went and opened the store to see if there is any update available for it and indeed there was an update yet it failed to install. There is a message that says (Try that again) and a see details link next to it. Viewing the details shows the following message:

Try that again
Something went wrong
The error code is 0x80073B0F, in case you need it.

MS support suggest I turn off my anti-virus (Windows Defender) and do a wsreset so I did but it did not help Can someone tell me how to fix this.

My basic device information:

Toshiba Satellite L500
Intel Core i3 M330 @ 2.13 GHz
8GB DDR3 Ram
ATI Mobility Radeon HD 4500
  • Have you ran the DISM and SFC tools?
    – Ramhound
    Jul 31, 2015 at 10:50
  • @Ramhound I ran SFC and it did not detect any issues. Did not do DISM though, what options should I use?
    – Zaid Amir
    Jul 31, 2015 at 11:54
  • dism /online /cleanup-image /restorehealth
    – Ramhound
    Jul 31, 2015 at 11:55
  • @Ramhound still the same issue after dism
    – Zaid Amir
    Jul 31, 2015 at 12:19
  • Information about your system might be helpful. You are going to have to figure out or provide more information, on the reason, you cannot update the application.
    – Ramhound
    Jul 31, 2015 at 12:35

2 Answers 2


Seems not many people are having this exact issue. I've come back to your post many times just to see if there was an update. I found the solution for this issue. You'll have to be patient while it completes. It keeps you from wiping your rig though.


The potential fix goes back to similar issues experienced during earlier Builds, which includes executing a PowerShell command at an elevated command prompt.

The PowerShell command:

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

Hopefully this also works for you!

  • WOW!!!! thank you so so much this worked for me.....
    – Zaid Amir
    Aug 6, 2015 at 12:13

Only Microsoft support is going to provide an official supported answer on such a new release and issue. I found the following resource to be the most relevant to your situation by referencing the error code(s) found within your event log transcript: http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_desktop/build-9926-most-of-modern-ui-not-working/d87e1903-661d-48b2-b2eb-41c0ab615d55

By the end of it, users reported that despite the suggested fixes, only re-installing really got them back into a working state. Inevitably the next header...

Re-installing Windows 10

  1. Open: PC Settings
  2. Select: Update and recovery
  3. Select: Recovery
  4. Click: Get started, follow prompts

Sucks, and probably isn't the answer you're looking to find. The reality is that the software has just been released, and that now-a-days it's easier to update as time goes on versus ensuring normal operation out of the gate. Alternatively, you can wait for an update that could patch this.

I upgraded to $LINUX_FLAVOR instead. :-)

  • I asked here just to see if someone else had the issue and was able to fix it. I don't see how the link you posted can help me or how it is related to this issue. Moreover I don't see how DOWNGRADING to linux can help ;)
    – Zaid Amir
    Jul 31, 2015 at 19:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.