I'm a bit embarrassed of asking this, but how to make the ^ (I can't see it in my keyboard).

I want to do this: CTRL-^

  • 3
    What keyboard layout do you use? where it is on the keyboard (if it exists at all) will depend on which country you are in and what layout the keyboard uses. – Richard Slater Jan 12 '10 at 10:49
  • 4
    Not what you're asking, but in other situations the caret is often used to indicate the Control or Ctrl key. Like Ctrl-L might be shown as ^L (or other lookalike characters, such as Unicode's U+2303 on a Mac: ⌃L). – Arjan Jan 18 '10 at 15:03

The ^ character (which looks like an inverted V) is known as caret. It's also known as a hat, control or uparrow.

It's Shift+6 on my UK keyboard, and I think it's the same for US layouts as well, so you could try Ctrl+Shift+6

If you have a different layout you could have a look at this page on Wikipedia which has pictures of many different keyboard layouts.

If you're on Windows you can get a ^ by hold down Alt and typing 094 on your numeric keypad which will work for all layouts, but unfortunately this won't work if you're holding down Ctrl

| improve this answer | |

According to Wikipedia:

Control characters are often rendered into a printable form known as caret notation by printing a caret (^) and then the ASCII character that has a value of the control character plus 64. Control characters generated using letter keys are thus displayed with the upper-case form of the letter. For example, ^G represents code 7, which is generated by pressing the G key when the control key is held down.

As "^" is ASCII 94 (decimal), "Ctrl-^" might represent ASCII 30. Hence, holding down Alt and typing 30 on the numeric keypad might do the trick to "type" Ctrl-^?

| improve this answer | |
  • Alt and typing 30 on the numeric keypad didn’t work for me (▲). Alt and typing 094 (^) did work. – xypha Aug 24 '18 at 13:37
  • 1
    @xypha, I don't think the question is about typing the ^ character, but about "typing" Ctrl+^ without actually pressing those 2 keys on the keyboard (lacking the ^ on some keyboards). – Arjan Aug 24 '18 at 14:22
  • you are right @Arjan. Unfortunately i am unable to reproduce ctrl-^ and test your solution. Every time i try, it is detected as ctrl-shift-6... Hmmm.. I would have to change my keyboard layout to try it. Maybe later. Thanks for the clarification. – xypha Aug 27 '18 at 15:45

Press Ctrl+Shift+6. The ^ usually represents the Ctrl key, [ie ^C for a Keyboard Interrupt], but in this case, I think the ^ represents a literal caret.

| improve this answer | |

The so called aschii-caret on a swedish keyboard -

hold CTRL and press the key with the caret-symbol two times

| improve this answer | |

I think that (in a terminal under linux) you can hit Ctrl+v Ctrl+^ .

Ctrl+v is by default bound to:

      Add the next character typed to the line verbatim.  This is  how
      to insert characters like C-q, for example.

In order to verify my claim I used xxd (xxd - make a hexdump or do the reverse.) which comes with vim. I typed the following keys: xxd Enter, Ctrl+v, Ctrl+^, Ctrl+d, Ctrl+d and the result looked like:

% xxd
0000000: 1e                                      .

Now the explanation is a little complicated:

  • xxdEnter launches the application xxd.

  • Ctrl+v, Ctrl+^ sends a 0x1e. In order to understand this you have to remember that Ctrl+x sends the character code of X (0x58, note: capital X) minus 0x40, that is 0x18. In case of ^ (0x5e) this results in 0x01e

  • Ctrl+d, Ctrl+d terminates the input. (I don't know why I had to type it twice though).

And finally man ascii is really helpful in remembering all those character codes.

| improve this answer | |

That thing is called Circumflex Accent AKA Circum Accent

Unicode: 005E
GID: 65

Most of the times it works by pressing Shift+6 or Ctrl+Shift+6

And of course it depends on the keyboard model and the layout that you're using.

But IF you couldn't type it you can use it by adding symbols.


| improve this answer | |

To type caret symbol on my Italian keyboard, I had to go to settings -> region and language -> input sources -> Italian (no dead keys)

The italian keyboard didn't work well, so I had to choose the "no dead keys" variant.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.