6

i upgraded to windows 10 and updated synaptics drivers to 19.0.12.95 - so now drivers are compatible with windows 10, but it forgets settings in control panel. If i disable reverse two finger scrolling and system tray icon after restart icon is back and scrolling is reversed.

Any idea how to fix it?

I found out that settings in HKEY_CURRENT_USER\SOFTWARE\Synaptics are missing after restart

What i tried: set users permission to full control on HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics and HKEY_CURRENT_USER\SOFTWARE\Synaptics

5

Instead of reinstalling drivers you can simply modify a variable in regedit.

Change the value of DeleteUserSettingOnUpgrade to 0 from \HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\Install

After restarting your settings will be kept.

| improve this answer | |
  • This worked for me. – Adam Dec 4 '15 at 4:15
  • This fix still works on Windows 10 version 2004 and Synaptics driver version 19.5.10.75 – mc510 Sep 7 at 19:11
2

Had the exact same problem. Fixed by re-installing the driver. I found the 19.0.12.95 driver on HP support website. Put 15-n207sa as computer model that will bring put the right driver.

| improve this answer | |
1

So i found out that drivers i downloaded had clickpad software, i downloaded some with touchpad software, drivers itself are probably same, but software is older synaptics one and it works and scrolls the way i like it :)

EDIT: i have used https://catalog.update.microsoft.com/v7 in internet explorer and downloaded latest synaptics drivers that had touchpad in name, also please check that you are downloading amd64 version for x64 systems.

| improve this answer | |
  • For visitors with the same problem: do you have a link to those drivers? – Arjan Aug 1 '15 at 16:08
  • 1
    i don't have the link, but i added what i did to get the drives – Evlo Aug 1 '15 at 19:30
  • Search, HP specific 1 or 2 and Generic 1 or 2 all dated 15-7-2015 – RobIII Aug 3 '15 at 18:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.