On a regular Windows Update routine I'm getting the following message:

We couldn't complete the updates, undoing changes.

The computer restarts for several more times repeating the same process, then, after system is on, checking the updates history reveals this:

Security Update for Windows 10 for x64-based Systems (KB3074683)
Failed to install on [date]

Checking the event viewer, I see this error 4 times:

Installation Failure: Windows failed to install the following update with error 0x80070003: Security Update for Windows 10 for x64-based Systems (KB3074683).

  • There should be some sort of error, or something you can click, to get that error. Without more information it will extremely tough for us to help. Have you tried to restart your system? Have you verified you don't already have the update installed?
    – Ramhound
    Jul 31, 2015 at 13:04
  • A common error number is 80240020, which indicates a corrupt/incomplete download. Search online for windows 10 error 80240020 (or whatever your error number is) for details. Jul 31, 2015 at 13:07
  • I've updated the question with the error number from the event viewer (0x80070003). Jul 31, 2015 at 13:10
  • 1
    I did a little bit of research and found this little ditty: answers.microsoft.com/en-us/insider/forum/… Do you by any chance have a nividia video card? Is there a user in your system called "UpdatusUser"?
    – Arthur
    Jul 31, 2015 at 13:14
  • 1
    Windows 10 is not really ready for release. Yet it has already been released. You can expect a lot of new updates over the coming months. But if you are taking advantage of the free upgrade offer, I recommend that you create a full system backup, then refresh Windows (in case of Windows 8) or reinstall it (Windows 7 or Windows 8), before you upgrade to Windows 10. Once upgraded and activated, you can create a bootable DVD or USB media and do a clean installation at any time. You will no longer have to install the underlying Windows version you upgraded from.
    – Samir
    Jul 31, 2015 at 15:03

5 Answers 5


I've got the same issue and following on @Arthur's suggestion, I had a look at my user SIDs in the registry under HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList and some of them belonged to users that no longer existed in the system (I had previously removed them).

I've removed the dummy entries (luckily there were only a couple) and the update worked.

PLEASE save yourself some trouble and backup the registry before trying that.

  • Thank you, this solved my problem. Maybe the problem happened to me because I have deleted a user from Computer Manager manually!
    – Salar
    Aug 1, 2015 at 5:23
  • I've done the exact same thing, removed a user in computer management, which seems to have caused the failure. AFAIK, it's normal that the registry keys are kept for posterity, it's just that the update doesn't cope with them.
    – marius-O
    Aug 1, 2015 at 16:04
  • I tried your solution and it seems to have solved the issue. The update was now solved successfully. Aug 2, 2015 at 0:18
  • Thanks! It solved mine too. When creating an IIS web application it had created a new app pool with a new user. This was not my intention so I had deleted this user and its profile folder. Yet the registry entry was still there. Removing this as well fixed the problem and allowed me to update.
    – Wouter
    Aug 2, 2015 at 8:00
  • Solved for me too - note to others, I have domain users there from a previous domain that the computer had been on - I was able to leave those in place. I just had to delete the entries for a local user that had been properly deleted from the GUI, but still remained there. YMMV on the domain users, but mine worked with them in place.
    – Nick
    Aug 6, 2015 at 18:55

Fix for Windows 10

  1. Go to Control Panel from Start Button
  2. Go to System and Security
  3. Go to Security and Maintenance
  4. Click Troubleshooting in the Maintenace section
  5. Under System and Security click the Fix problems with Windows Update
  6. Let the troubleshooter run with administrative priviledges
  7. You are done
  • I cleared unused SIDs from the registry as the Accepted Answer, but it still didn't work. With nothing left to lose, I tried this, and my update went through!
    – supersuf
    Oct 5, 2016 at 6:37

I had to do the same thing as above. Go into registry and remove a user called nx. It is something to do with Nvidia. I have an EVGA Geforce 960 SSC card(Nvidia). Once I removed the user called nx. Update went fine after trying for a week. Also other updates started downloading. Like they were waiting on that one.

  • I got this after upgrading my boot camp drivers on my macbook. Since the video hardware is Nvidia, I strongly suspect it's related.
    – Kirk Woll
    Aug 13, 2015 at 23:25

If someone is still facing this issue here is a detailed post about all the possible fixes:

Go here for the full post which is a whopping 1732 words guide: http://troubleshooter.xyz/fix-we-couldnt-complete-the-updates-undoing-changes/

Method 1: Delete Software Distribution Folder

Browse to the C:\Windows\SoftwareDistribution folder and delete all the files and folders inside.

Again try installing the updates and this time you may be successful in installing updates.

Method 2: Download Windows Update Troubleshooter

Let Windows Update Troubleshooter run and fix issues!


I discovered that this symptom was occurring for my box with a Geforce 7600GT due to the 'nVidia Update' application that comes bundled with the older 309.08 WHQL drivers. The solution was to uninstall nVidia Update because it created a 'UpdatusUser' that was causing the problem as documented in this post.

  • 1
    link-only answers are not that helpful.
    – Ramhound
    Jul 18, 2016 at 13:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .