6

I am attempting to install Windows 10 on my desktop.

I got an error in the "Reserve Windows 10" app stating that I need at least 2GB of RAM (I am installing the 64 bit version).

I downloaded the media creation tool, hoping to bypass the Reserve app. The media creation tool still says I do not have enough Ram though.

The full error message: "You need to install at least 2 GB of RAM before you can install and run Windows 10. Contact the PC manufacturer to see if you can install more RAM."

I have 12GB Ram installed. 2 x 2GB modules and 2 x 4GB modules. I swopped out modules, removed them, used one at a time, all modules are working fine and are recognized by Windows. The install simply wont work.

I have tried the following configurations for my Ram (A = 4GB same brand, B = 2GB same brand):

  • A B A B
  • B A B A
  • A _ _ _
  • A _ A _
  • B _ B _
  • B B _ _

I am currently running Windows 8.1 Pro as my OS.

EDIT 1

There was a bug with the technical preview and some VMs stating not enough physical memory. As I am open to any ideas I removed "Windows 8.1 Update KB2995388", this did not fix the problem.

EDIT 2

Some system info from dxdiag.exe:

dxdiag info

The error message:

"This PC can't run Windows 10" Error message

EDIT 3

The question is being asked on other forums as well (not by myself) with no helpful answers yet. Links I have found so far:

Link 1, Link 2, Link 3

EDIT 4

As per suggestions in the comments I tried the following:

  • Changing the page file
  • Swopping out the Ram stick in even more configurations
  • Running memtest86+ (No errors reported)
  • Installing from external media (both USB and DVD)

Some extra info, if it may help at all. A screenshot of the resource monitor's memory tab: Resource monitor memory tab

Any other solutions I can try?

  • I would rather ask by Microsoft than in this forum. – duDE Jul 31 '15 at 13:11
  • 2
    I searched a bit. It does not seem the MS forum guys know what to do: answers.microsoft.com/en-us/windows/forum/… – Morne Jul 31 '15 at 13:15
  • Are you running the x64 version of the tool? You are selected Windows 10 Professional x64 correct? – Ramhound Aug 3 '15 at 14:35
  • Seems not to be solved: answers.microsoft.com/en-us/windows/forum/… – duDE Aug 3 '15 at 14:39
  • Try removing your 2x2GB RAM chips and see if it can install with 8GB. It may be that one of the chips is bad for some reason. Try using only 4gb chip or only both 2gb chips. – Abraxas Aug 3 '15 at 14:41
5
+50

I had a similar issue like this when I attempted to install Windows 10. However, this was from a preview build. (Ironic right?)

I disabled Windows Management Instrumentation. This can be done by disabling the service via Win+R -> msconfig then selecting the tab Services and finding the Windows Management Instrumentation then unchecking it and rebooting.

If you do not wish to reboot, just start up services.msc (Win+R -> services.msc) and then stop the Windows Management Instrumentation service and it's accompanying dependent services.

The setup will now proceed as expected.

This service provides extensions to the Windows Driver Model. Disabling this most likely removes access to critical checking functions, which results in the installer getting some sort of satisfactory results on the pre-checks.

  • This answer solved it for me. Thank you very much @Jared Allard. Maybe edit your post to be a bit more explanatory for less technical users landing here after their search? – Morne Aug 5 '15 at 5:15
  • 1
    Glad it worked! @Morne. I edited it to explain a bit more about the service as well how to disable it! :) – Jared Allard Aug 5 '15 at 18:16
  • What an interesting issue. Had the same thing here with Windows 8.1 Home with 8 GB RAM. Turning off the Windows Management Instrumentation did the trick. – ylluminate Aug 24 '15 at 20:52
  • Stopping service & it's dependencies couldn't help. Disabling & rebooting it helped. – Nime Cloud Mar 2 '16 at 13:40
0

Have you tried changing your Page File to use all 12GB of your RAM?

Information on changing Page File: https://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/sysdm_advancd_perform_change_vmpagefile.mspx?mfr=true

From the information shown your Page file is using 1869MB which his less than 2GB. It might that it is checking the Page file. When I installed my 12GB I changed my Page file to speed up my machine and take full advantage of my RAM.

Give that a try and see if it allows you to install.

  • I will try this and post results. – Morne Aug 3 '15 at 16:13
  • I changed the page file to use more than 2 GB (4GB in fact) of memory. Still no change. – Morne Aug 4 '15 at 5:19
-1

Your configuration of RAM is slightly worrying. Ideally you would have all of the same type and paired configuration, which would look something like this:

A B A B

Although having differing memory amounts and even to an extent brands shouldn't cause this issue, might be worth just running it with 8GB of RAM in this configuration:

4GB (FREE) 4GB (FREE)

Also make sure you have enough Storage apparently W10 can take up to 30GB (28 on average) to install.

Hope this helps, didn't really think this fitted as a comment.

  • My Current (normal) ram config is A B A B. I tried "A (free) (free) (free)" and "A (free) A (free)". To no avail. I have 480GB hdd space left so that can be the problem. Thank you for the suggestion though. – Morne Aug 3 '15 at 16:11
  • And if the Hard drive space was a problem it wouldn't be complaining about MEMORY. It would probably throw something as generic as "not enough room on the drive to install" – JukEboX Aug 3 '15 at 16:16
  • No worries Morne. @JukEboX It was just an additional thing to consider as they might get around the memory issue to discover they don't have enough space..... – David Golding Aug 4 '15 at 8:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.