63

I just switched to Windows 10 on my ASUS N550JV and installed related drivers from the support page of ASUS. The touchpad works great, but for some reason the direction of scrolling on touchpad is inverted. I couldn't figure out how to change the direction of the scroll on touch pad, how can I do it?

68

I FINALLY figured it out! On my Asus machine, at least. Go to Control Panel, like Browning IT said, but instead of clicking on the "Mouse" option, click on "Asus Smart Gesture" instead. Under the Two Finger Column, check the box next to "Content moves reversely with your finger's direction." I hope this applies to your model. I have a Flip. That took me 2 days to figure out!

  • Excellent worked for me. – Shane Van Wyk Aug 19 '15 at 5:31
  • I dont have an Asus Smart Gesture option on my asus. Anyone else running into this? – Eric S. Sep 1 '15 at 20:06
  • 11
    @EricS. I wanted to find that in the Control Panel and got mad trying to seek for it. Didn't find anything! Finally, I realized that I had an icon in the System tray near the clock that lit at every touch, and pointing the mouse a tooltip said ASUS Smart Gesture - Double-clicked on it and found the option in the section Two Fingers - BTW: Using an ASUS K555L – Xavi Montero Sep 17 '15 at 20:57
  • @XaviMontero Thank you very much, that's finally worked for me. – Eric S. Sep 18 '15 at 15:16
  • Man - this was driving me mad :) - thanks very much! – Sebastian Sulinski Nov 18 '15 at 15:07
31

If you have a touchpad:

In Windows 10, if you have a touchpad, you will probably have one of the options mentioned in the other answers:

  1. Start Menu -> Settings -> Mouse & touchpad -> Reverse scrolling direction

  2. Something manufacturer- or device-specific, probably accessible through Control Panel -> Mouse or something similar, as noted in other answers.

If you don't have a touchpad:

(and you want inverse scrolling because, say, like me, you got addicted to it on Mac OS and now find it more natural):

(I don't see why they don't just put a control panel toggle for this, but at least we have a couple of options to make it work):

Registry Setting

There's a registry setting called "FlipFlopWheel" that does this -- (thanks to https://superuser.com/a/364353/153895 by @Richard). This also works as far back as Windows 7, at least (maybe further, I don't know).

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\HID\VID_???\VID_???\Device Parameters.

There might be multiple mouse entries. The default value for FlipFlopWheel should already be 0. Change it to 1 to invert scrolling. Reboot or replug mouse for changes to take effect.

To get the VID_??? and complete the process you have two options:

1: Manually

Go to the mouse control panel, click the Hardware tab, then click Properties (or, just find the mouse in Device Manager and double-click or right-click Properties)

Either go to the Events tab and look for the VID in the "information" area at bottom, or the Details tab and choose Device instance path in the Property dropdown.

Then you can use Regedit (be careful in there!) to find and change this property:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\HID\VID_???\VID_???\Device Parameters

2: Powershell commands

Run this in PowerShell (from Start » All Programs » Accessories » Windows PowerShell):

    # View registry settings
    Get-ItemProperty HKLM:\SYSTEM\CurrentControlSet\Enum\HID\*\*\Device` Parameters FlipFlopWheel -EA 0

    # Change registry settings
    # Reverse mouse wheel scroll FlipFlopWheel = 1 
    # Normal mouse wheel scroll FlipFlopWheel = 0 
    Get-ItemProperty HKLM:\SYSTEM\CurrentControlSet\Enum\HID\*\*\Device` Parameters FlipFlopWheel -EA 0 | ForEach-Object { Set-ItemProperty $_.PSPath FlipFlopWheel 1 }

The command for normal (non-inverted) scrolling has the `0` and `1` swapped:

    # Restore default scroll direction
    Get-ItemProperty HKLM:\SYSTEM\CurrentControlSet\Enum\HID\*\*\Device` Parameters FlipFlopWheel -EA 1 | ForEach-Object { Set-ItemProperty $_.PSPath FlipFlopWheel 0 }

Either way, then just reboot or replug mouse for settings to take effect.

Note: You may find, like I did, that upon unplugging and replugging back into a different USB port, or KVM switch, or something, that it's stopped working, even though the original registry setting is still set.

What happened for me, is that my mouse got a new string/subtree entry in the registry; the beginning (VID_XXXX&PID_XXXX\) are still the same, but the string at the end was different. I had to go into that subtree and set it again for the new instance.

AutoHotkey Script

You can use the following AutoHotkey script:

WheelUp::
Send {WheelDown}
Return

WheelDown::
Send {WheelUp}
Return

(If you have autohotkey installed, simply save the above as an .ahk file, and then double click in Windows Explorer to run it. Your Mileage May Vary. It worked great for me in Windows 8, but am having trouble in Windows 10. Not sure if this is an AutoHotkey/Win 10 issue, or something else.)

  • This is excellent. The registry method worked for me on my Trekstor tablet. – Owen Sep 16 '17 at 15:35
  • The AHK script is the thing that finally did it, no way to get the the registry trick to work. I would add #MaxHotkeysPerInterval, 1000 to the script though ;) Thanks a lot! – brisssou Sep 4 '18 at 6:37
13

Settings > Devices > Mouse & Touchpad > Additional Mouse Options > Devices Settings > Settings > Multi Finger.

Check or uncheck 'Reverse Scrolling Direction' .

This works on Lenovo Y410P

  • This works on Lenovo Yoga 710 – Trismegistos Jan 24 '17 at 11:31
8

For Synaptics Touchpad v1.5 on SMB Port, go to Control Panel, Mouse & Touchpad, then click Additional Mouse Options at the bottom of the panel on the right.

Select the Device Settings tab and click the Settings button.

You'll get a screen similar to this:

Screenshot

Click the gear next to Two-Finger Scrolling. The option you want to toggle is Enable reverse scrolling direction.

  • 1
    It's more or less the same for the Synaptics trackpad on my ThinkPad w550s, but you go to Mouse Properties (search the start menu/Cortana/whatever it is)->ThinkPad tab->click 'Settings...'->Scroll tab->Two Finger Scrolling->Switch Direction (unchecked in my case). – hajamie Nov 6 '15 at 10:47
  • Just a heads up, this option doesn't show up if your Synaptics Control Panel is "Evaluation Version". I needed to update Win10, which kicked Synaptics out of Eval Mode and had it display this option. – R.D. May 3 '17 at 6:19
3

While I can't help with your specific set up - I can give you a hint of a few places to look.

1) Check out the touchpad software settings (for my machines, that's usually the synaptics touchpad software). You can bring up Windows 10 context menu's regarding the touchpad by right clicking on the start button on the bottom left of the screen. From there, choose "Control panel". In there, click on the mouse settings. There are usually several tabs here, you will have to hunt for which one will be relevant for your touchpad. I found mind as "switch direction" in a synaptics tab.

2)Click on the Start button again. Click on "Settings". From here, there is the "ease of access". There is the "mouse" field here (which offers different buttons than the control panel route). There is also an 'other options' that may show different data for you than it does for me since you set up is different.

GLHF

2

On a Lenovo ThinkPad, it's Control Panel > Change Mouse Settings > Settings button on the UltraNav tab > expand Scrolling, click on Two-Finger Scrolling > uncheck Enable reverse scrolling direction

protected by Community Aug 18 '15 at 13:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.