2

I just updated my Windows 8.1 Pro to Windows 10 in my laptop. Everything is working fine except for the WiFi adapter. It doesn't scan for any available WiFi networks. When I hover it, it says "No connections are available"

http://i.stack.imgur.com/rTaGL.png

I can only connect to the internet via Ethernet. I have tried to update my wireless network adapter. I also tried to use other network adapter(Update Driver Software > Browse for software driver in your computer > Let me pick from a list of device drivers in my computer). The result is still the same - no connections available.

The driver doesn't show a exclamation mark. The device status shows "This device is working properly.".

In the events tab, it shows this

http://prntscr.com/7z8yuq.

I guess it might be the problem.

Please help me ASAP. I don't wanna bring my laptop, my laptop charger and a chair and sit beside the wifi modem...

  • Your screenshot shows you are looking at a Commview monitoring adapter and NOT a real wireless adapter. You either have the wrong driver, or no driver at all. – qasdfdsaq Aug 7 '15 at 12:58
2

If you did an upgrade, the driver for the Atheros AR5B97 was taken from your previous Windows installation. This driver sometimes does not work in Windows 10, showing exactly the symptoms you described ("device working properly" and no WiFi connections).

Here is what I did to remedy this problem:

(not sure if really necessary but it was a hint from the net):

Delete all keys below [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network{4D36E972-E325-11CE-BFC1-08002BE10318}] in the registry (after backup, of course). Reboot. Windows will restore those entries with default values.

I uninstalled the AR5B97 driver in Device Manager, ticking the checkbox "Delete driver software". After that, I let Device Manager search for new hardware. The AR5B97 was detected again. I uninstalled this driver as well and also checked "Delete driver software". I repeated these steps until "Delete driver software" was not offered any more.

Now, I had driver version 3.0.2.181 from 2009 installed. This driver worked! WiFi connections appeared, and I was able to connect to my WLAN. From now on, it is possible to update the driver to e.g. 10.0.0.308 (the Windows 8.1 driver) without problems.

There is now even a driver said to be for Windows 10 (64 bit) at http://support.lenovo.com/de/de/downloads/ds103777 This archive contains the latest drivers for Atheros, Broadcom and Realtek chipsets. I extracted the Atheros driver (version 10.0.0.318) and put it on http://home.arcor.de/dac324/downloads/10.0.0.318.ZIP

UPDATE: This driver works as well.

BTW: Thank you very much qasdfdsaq for your comment to the initial posting. Seems that CommView somehow was surviving the upgrade to Windows 10 although the setup denied preserving any apps. Uninstalling all remnants of the CommView driver as described above seems to be the cure for that problem.

  • I had the same problem as Jeremy described, and it was due to a driver which got corrupted during the upgrade. My posting describes how to fix this broken driver. – Gerd Aug 7 '15 at 12:51
  • The Lenovo driver doesn't install :\ – Jeremy Aug 19 '15 at 9:56
0

Atheros has not released Windows 10 drivers for the AR5B97 yet. Their driver download page will be updated with a link when those drivers are written and tested. Until then, try downloading the Windows 8 drivers from that page and installing them with Device Manager.

If you have a spare identical machine, it might also be worth trying a fresh (not in-place upgrade) installation of Windows 10. In-place upgrades have a habit of breaking device drivers.

  • @Jeremy Did you try the Windows 8 drivers? You could also try uninstalling (not disabling) the device in Device Manager and rebooting, which will cause it to be automatically installed again. – Ben N Aug 1 '15 at 13:52
  • Yes I did. It doesn't work. – Jeremy Aug 19 '15 at 9:56
0

I had the exact same problem, after upgrading from Windows 7 to 10. All that was the problem I think was an out of date WiFi adapter, nothing complicated. In Device Manager the WiFi adapter's entry had an exclamation mark next to it. All I had to do was update it and it was a matter of seconds before I was connected again to the Internet (no messing around in the registry or anything).

Andrew

  • I don't have an exclamation mark next to the adapter. – Jeremy Aug 19 '15 at 9:56
  • Is this in the Network adapters section of Device Manager? If there is no exclamation mark then your problem is probably different from mine so I won't be able to help :( – Andrew Wang Aug 20 '15 at 20:14
  • Yes. There is no driver updates available too. – Jeremy Aug 22 '15 at 6:20

Not the answer you're looking for? Browse other questions tagged or ask your own question.