I have tried to "Restore Defaults" my network settings many times on VMware Workstation 10.0.3 on my Windows 10 install many times now but it always pauses at installing the adapters and waits for about 30 mins and then exits without installing them (I cannot see them in the network and sharing centre).

I see that VMware opens the installer for the adapters but it is like the installer just halts and exits. It has no interface so I cannot see what it is halting or breaking for.

Anyone know a work around for this problem?

Maybe others are not getting this problem and there is something wrong with my installation?

8 Answers 8


I fixed my virtual network adapters by running the VMware Workstation install again and selecting repair. Afterwards it required restart. Once it booted up my VMs all had their network adapters working and connected.

Perhaps the repair install will clear up the old pre-upgrade virtual adapters and they are the problem with creating new network adapters.

I'm on old Workstation 8 and it still works fine under Win 10 after repair install.

  • 1
    Proves it should work. I have been on the phone to MS many times about it now but no closer to a solution. PnPDriverInstall always fails for me. I will prolly downgrade back to Windows 8.1 now...
    – Sammaye
    Jul 31, 2015 at 20:14
  • Turns out it was a driver issue from when I installed Asus AISuite, thanks
    – Sammaye
    Aug 1, 2015 at 13:19

I got it working today, so I’ve made this post to help you too. I posted the solution to the VMware forums as well (the solution).

Scenario: Windows 10 + VMware Workstation Pro 12 Issue: While installing the application, the installer wizard stops while "installing virtual network drivers".


  1. Please have in mind the following:
    a. VMWare needs to be removed totally from the system.
    b. The installed Virtual Network device driver for VMware needs to be removed as well.

  2. Disable UAC in Windows (type Start -> UAC -> set on minimum).

  3. Disable your antivirus/firewall (i.e. Kaspersky/Symantec).
  4. Try to install VMware as Administrator (Right-click -> Run as Administrator). When the application hangs at "Installing Virtual Network Drivers" go to:
  5. Start -> type Virtual Network Editor (this should have been installed by now by the VMware Install Wizard)-
  6. In the Editor click right below on Change settings.
  7. Open Task Manager and right-click and kill two applications: the VMware installation wizard and the VMware Network drivers install tool (I cannot remember the name exactly, but it should be right below the VMware wizard process).
  8. After killing the processes, go to Virtual Editor and delete/remove all the networks that appear in the top list (should be listed as VMNet#, etc.).
  9. Click Apply and wait for them to be removed.
  10. Once removed, exit the Editor and go to Control Panel -> Device Manager.
  11. In Device Manager -> Network adapters- > look for other devices other than your PHYSICAL Network cards. If you see something like "VMware Virtual Ethernet Adapter for VMNet 8", right-click on it and uninstall.
  12. Go to Add/Remove programs and check if VMware Workstation appears in the list. If it does, click on it -> Change -> Uninstall. Wait for the uninstall process to finish.
  13. Reboot the computer.
  14. Start -> type Virtual Network Editor (no results should appear, this indicates that VMware was uninstalled correctly. Check also the Add/Remove Programs to be sure).
  15. Go again to Device Manager -> Network adapters and see if the VMware Virtual adapter is still there. If it is, remove it again, then click on Action -> Scan for hardware changes to be sure it does not appear again. If it reappeared after removal, you'll have to reboot again.
  16. Once VMware and the Adapter are uninstalled, run the VMware Install Wizard again, as administrator.
  17. When it stops again at the "Installing virtual network drives", in the taskbar you should see an app highlighted, but if you click on it, no window will appear on the screen. This is the VMware virtual adapter installer window, which is hidden. While stuck on installation, simply right-click on that window in the taskbar and click Close. Wait a few moments, the installer should now jump to the following steps, finishing the installation.
  18. At the end, in the Device Manager the new adapter should appear, and all the entries in the Editor should have been recreated. Now it works.

Notes: Don't try to repair VMware. If it keeps getting stuck, uninstall it several times, and delete the VM adapters several times, to get it working. For me it worked from the first time.


VMware Workstation 10 does not specifically support Windows 10 by way of the "Supported host operating systems for VMware Workstation" (KB2088579) document provided by VMware.

VMWare Workstation 11 is expected to support Windows 10 as a host OS (citation needed). Stay tuned as Workstation 10 may be updated to "officially certify" operation. It is also worthy to note that your build is over a year old - consider updating.

  • I think there is something more wrong here. No program which requires to install network adapters works for me. NBot only that but when I try and add a vpn connection in the windows settings that too just freezes and dies on me. There is something very wrong here
    – Sammaye
    Jul 31, 2015 at 16:23

Upgrading to VMware Workstation 12 solved it on my Windows 10 box. Version 12 has some good new features too.


After a hell lot of effort, I found that Antivirus is the issue. The setup should not give any error while installing. Please run as administrator when you run the setup and turn off antivirus if any.

Turning vmci0 value to false is not at all a good approach


Please keep your VMware Workstation installation file, don't uninstall current VMware, click on installation file, click repair. I was like you and successfully overcome. Goodluck to you ! <3


Try enabling Device Install service in services.msc.

Type this in the run (Windows + R) and keep pressing D until you find it listed there, start it and then do your basic task which is installing the vmnets you wanted to.


Hey guys I had the same issue. Running a Windows 10 laptop and VMware workstation 15.5 would not create virtual network adapters. I tried the solution mentioned here plus many more things and nothing worked. Also I noticed that not only EVE would not work, but GNS3 could not integrate with a VM.

After some troubleshooting I came to the conclusion that it was not Vmware the problem or Gns3, but windows somewhere where my knowledge was not deep enough. Long story short. I had to reinstall windows setting keeping my documents. That did the trick, Vmware was able to create virtual adapters and I could connect EVE and gns3 VM.

I was stuck with this problem for a while so it was somewhere in windows. Hopefully this helps someone.



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .