10

I just upgraded to Windows 10 from 7. Cool so far, but when I try to go to any of my applications the app pool crashes and I get a 503. I can restart the app pool but it continues to crash. So I checked the event log to see what was happening. I then got the error "The Module DLL C:\WINDOWS\system32\inetsrv\rewrite.dll failed to load". The problem most people had was that the dll was not there. However that is not my problem. Because it is there. After some googling I have not been able to find a solution. Can anyone please help me out? Accoding to my registry I am running IIS 10.0?

I have rewrite 2.0 installed. I was going to attempt this, http://forums.iis.net/t/1171695.aspx?How+do+I+determine+which+version+of+IIS+is+running (Change bit on Majorversion in registry and install rewrite 2.0)

2 Answers 2

20

I ended up having to uninstall IIS Url Rewrite Module 2.0, then reinstalling. After the reinstall everything worked. I did not need to use the link in the question to reinstall.

3
  • 1
    This also worked after upgrading from Windows 8.1 to Windows 10.
    – RedFilter
    Oct 7, 2015 at 2:19
  • 2
    Repair IIS URL rewrite + restart iis worked for me :)
    – eflles
    Nov 14, 2016 at 18:28
  • Got the error "The Module DLL C:\WINDOWS\system32\inetsrv\rewrite.dll failed to load" after upgrading Windows Server 2012 to 2016. Uninstalling "IIS Url Rewrite Module 2.0" from Programs and Features and reinstall from Microsoft website iis.net/downloads/microsoft/url-rewrite + IISReset fixed the issue
    – Ahmad Zia
    Mar 25 at 21:30
2

I had the same issue and reinstalling was not enough. Turns out my VM was way behind on windows update (probably a vanilla install without any updates...) and getting it up to then then reinstalling IIS URL Rewrite Module 2.0 fixed the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .