I had dualboot of Windows 7 + Ubuntu 12 on an ASUS laptop.
Yesterday I triggered reset to factory settings through Windows, without realizing that I need to get rid of Ubuntu and grub first.

Now the computer is stuck with the following message:

error: no such partition
grub rescue >

The problem is that I cannot boot the computer with boot repair disk on a USB, nor from backup DVDs from this laptop.

I already set the "Boot device priority" to "Removable device" first, and then "CD/DVD" but it's still the same. It does not read either of those.

Is there any other way to force boot-loading the live USB / recovery DVD?


  • What BIOS make and version does your machine have? – Ben N Jul 31 '15 at 16:00
  • Thanks for quick message. BIOS make is AMIBIOS (American Megatrends) I guess, and the version is 203. – Aram Boyajyan Jul 31 '15 at 16:05
  • 1
    I can't tell if you have grub or grub2 but aside from this : askubuntu.com/questions/311568/boot-from-cd-drive-in-grub2 your other option is to unplug the hard drive. – qasdfdsaq Jul 31 '15 at 16:10

I had to trick my computer It wasnt booting from flashdrive, over and over, so what I did was insert my windows 7 ultimate usb into my computer, as well as insert my windows 7 OEM upgrade cd into my cd drive then made the computer boot from cd drive first. Somehow this tricked the computer into thinking the cd was actually the windows 7 ultimate. So my computer was thinking that the usb was actually a cd.took me 8 hours but I finally got it!

  • 1
    You did not fool the computer. The reason it worked is due to the fact that upgrade disks can be used for clean install and you would have no problem as long as you have a qualifying product key. more about it – pun Jul 31 '15 at 16:43
  • Thanks for the reply. I tried this, but it didn't work. I managed to solve the issue by connecting the HDD to another computer, and then fixing the MBR issues there. I'll post it as an answer shortly. – Aram Boyajyan Aug 1 '15 at 11:51

The solution was to use the Ease US Partition Master free edition. You have to download the free edition from the comparison page, otherwise they want to make you download the free trial to the pro version.

I connected the HDD to another computer, ran the Partition Tool from there, and then selected "Drive -> Rebuild MBR". After that I had to click on "Apply", plug the HDD back into my computer and everything was OK.

Here's the link to the page where they explain how to do this, together with screenshots and additional info.

I'm not associated with them in any way. Hope this doesn't break any rules, I'm posting this only because it solved my issue, and might help others as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.