0

I successfully upgraded yesterday from 8.1 and this morning I was looking at the new "desktop switcher." I was looking for an OSX style touchpad gesture to switch between them. I followed the instructions on the second part of Get Mac-Like Scrolling and Gestures on a Windows Laptop to try and get a custom synaptics driver working. In the course of this, I uninstalled the factory synaptics drivers using "Programs and Features" in the control panel. When trying to install the new custom drivers, I got the error:

A newer version of the Synaptics Pointing Device Driver is installed. If you want to install the older version of the Driver, please uninstall the current Synaptics driver by selecting "Synaptics Pointing device" from the "Add/Remove Programs" Control Panel, then run Setup again.

At this point, my touchpad no longer works at all. So I tried to restore the driver to what it was originally.

My first thought was to get windows update to update it for me. I got "Lenovo synaptics touchpad driver" to appear in the list of updates. When trying to update, it threw the error:

Synaptics driver update for Lenovo Pointing Device - Error 0x8007000

After rebooting and attempting again with no success, I turned to Lenovo's website. I found the support page for my device (Lenovo Y510P). Seeing no Windows 10 driver, I tried to download the 8.1 driver. It appears to run, even copying files into Program Files, but when I hit "Finish" in the msi style installer, a windows 10 notification appears saying

This app can't run on this PC Realtek bluetooth suite doesn't work on this version of windows

that links to a generic Windows page telling me that the program I was trying to run is incompatible with Windows 10.

In a final attempt to get the touchpad working, I went to the Synaptics website to download a generic driver. I once again downloaded the one listed for windows 8. Attempting to run this, I ran into the same error as the custom synaptics driver I started with ("A newer version of the Synaptics Pointing Device...").

I then pulled up the trusty device manager, and seeing the Touchpad listed under Pointing devices, I uninstalled it thinking that I could maybe get the generic driver to work with it uninstalled. I later realized this was a mistake, because the lenovo drivers no longer appear in Windows Update. Needless to say, I didn't get any change out of the generic driver, or the custom one for that matter.

Using the Device manager, was able to select the new "Unknown device" and use windows update to find drivers, but during the installation of those drivers, the error: "This device cannot start. (Code 10)" occurred. Now, the device status is listed as

This device cannot start. (Code 10) The specified request is not a valid operation for the target device.

All I want at this point is to be able to use my touchpad.

Thanks in advance.

Edit: I have the evtx file for the device, but I cannot link to dropbox because of spam protections.

0

Try uninstalling Synaptic driver using RevoUninstaller: http://www.revouninstaller.com/revo_uninstaller_free_download.html

Do the advanced uninstall. It will create a System Restore Point if something goes bad then run the native uninstaller. After that is done it will remove everything Synaptic related including driver and registry entries. It may ask to restart.

Once it is clean go to the Synaptic website and try installing the latest driver.

I have also found that Windows 7 and Windows Vista drivers work as they are based off of the same architecture.

  • I don't see anything synaptics related under "Uninstaller". I have enabled advanced mode. Is there anything else I need to do? – Andrew D Aug 3 '15 at 23:03
  • If it isn't under there you can do an normal uninstall and then Download a different driver. If it has a newer version installed it should warn you about over riding it with an older version – JukEboX Aug 4 '15 at 2:07
0

The problem resolved itself recently. Very strange. I now can use my TouchPad and the synaptics configuration screen showed up again. Maybe Windows Update picked it up?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.