26

I have Lenovo Ideapad Z510 with Intel(R) HD Graphics 4600 and NVIDIA GeForce 840M and I cannot adjust the screen brightness, I think now it is 100%.

Yesterday there was no problems and it wasn't 100% bright. Might be due to an update. Normally I was adjusting the brightness with F11 and F12, they don't work now. Other keys suchs as F7 and F9 work without problem. When I search for "adjust screen brightness" I can see that there is a menu for that but when I click it shows me search results page with all settings, and there is no "adjust screen brightness".

Also I have tried to adjust screen brightness from power options but "screen brightness" doesn't exit there anymore. And I have reinstalled Intel drivers for graphics, it didn't help. What else I can do?

35
  1. Search for Device Manager in Start Menu
  2. Expand the Monitors section
  3. Right click on Generic PnP Monitor and
  4. Click on Enable and you are good!

Source

  • 2
    Wow, this fixed it for me on a totally different computer. – San Diago Aug 7 '15 at 3:32
  • 4
    @Joao : PnP monitor is already enabled. I use lenovo idea pad z400. But still my screen brighness does not change – Ashwin Aug 20 '15 at 6:19
  • 1
    The Generic PnP monitor is not listed. Instead Generic Non PnP monitor option is displayed and its already enabled. Disabling it also doesn't help. Lenovo G500 – Lucky Aug 24 '15 at 14:35
  • 1
    Helped me with HP Pavilion G6. Thanks a lot. – h0ch5tr4355 Sep 25 '15 at 19:13
  • 2
    Device Manager > Monitors > Right click on PnP Monitor > Update Drivers... > Browse My computer for driver software > Let me pick... > Select Generic PnP Monitor > Next. Now you can adjust brightness of the monitor – o0omycomputero0o Jul 3 '17 at 11:44
12

This problem might appear with any graphics card on any laptop brand if you have installed the TeamViewer monitor driver to speed up change tracking on the screen.

To uninstall it, right click the Windows Start icon, choose Device Manager, expand Monitors, double click the Generic PnP Monitor and press Uninstall on the Driver tab. Now you have brightness controls again :)

There is an Uninstall button in TeamViewer next to the Extras->Options->Advanced->Advanced Network Options->Install monitor driver label if you have installed this driver, but that did not work for me.

  • 4
    If that still doesn't help, try this: reddit.com/r/Windows10/comments/3fa2ph/… In short: change the Monitor device driver to "Generic PnP Monitor". – vadipp Apr 18 '16 at 18:05
  • @vadipp: Thanks. TeamViewer failed to uninstall its driver on my computer. Forcing Windows to reinstall the Generic PnP driver as it said in that reddit post worked. In case the link goes down: Device Manager -> Monitors -> Right-click on Generic PnP -> Update -> From my computer -> Let me choose from a list -> Generic PnP -> Update. – f.ardelian Apr 21 '16 at 17:50
  • 2
    @wigy Man you are great! Thanks. That did the trick. Uninstalling monitor driver in team viewer didn't work for me either. I had to uninstall PnP Monitor. – Ashkan May 25 '16 at 21:01
2

In my Lenovo G500 laptop after installing Windows 10 I couldn't adjust the screen brightness. And I couldn't see the Generic PnP Monitor option under the Monitor section of my device manager list. I had installed the Intel HD 4000 Graphics and AMD Radeon Graphics drivers. Enabling and disabling it doesn't help either.

But the thing is I haven't installed the Intel Chipset Driver software. After installing the motherboard driver software I was able to adjust the screen brightness after a system restart. And now under Display settings Windows has the Screen brightness slider added. Also the shortcut to increase and decrease using F11 and F12 also works. You can also click the battery icon near the tray and change the battery percentages to 0%, 25%, 75% & 100%. These options were not enabled before installing the motherboard(Chipset) drivers.

1

If all else fails, most laptops (especially newer ones) allow you to change the main monitor's brightness in the BIOS. Of course this isn't ideal, but if nothing else works, it's better than nothing.

protected by Community Aug 5 '15 at 2:05

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.