0

Background

This is a problem I have been having for quite a while now. When streaming videos over the network via Wifi or Ethernet I was getting artifacts and blocky pixels that were green and so forth. This was happening a few years ago on a Boxee Box (first gen). I noticed the same issue on my Macbook Air (Late 2010 model) as well. Both of these systems were having the files served from the current computer I am using today. I thought this was an issue with both the Macbook Air and Boxee Box.

After streaming local files from my PC to my Samsung Smart TV I had the same issues in Plex. This also happened when streaming from my new Synology 2415+. These files that were being streaming were transferred from the same computer. I thought it was an issue with the TV.

So I tried using my Chromecast rather than my TV but the problem did not go away. Even when using Plex on my iPhone to watch the videos this problem still happened. I have zero issues with streaming files on all of the devices listed above when it is YouTube, Netflix, etc. I have never had any of the video artifacts that I am seeing when playing local files on YouTube, Netflix or any other internet streaming service. Only local files.

I noticed the same artifacts were occurring every time on a particular file. This file had been transferred to my NAS. After transferring the file to play locally through VLC the same artifact in the same spot was occurring. I redownloaded the video from the source and saw the issue go away which lead me to believe there was some sort of issue with my network and file transferring.

I recently purchased my modem to remove the lease fee from my ISP (Motorola SURFboard SBG6580). This is my modem and router. I removed the old Linksys router I had because it was not 1gbps. The same problem exists. This did not make any difference. I was using the exact same Model modem a few years ago as well.

I was pretty confident the video streaming issues I was having were due to files not being transferred properly. The exact same artifacts were appearing when played locally. The artifacts did not happen until after the network transfer. After using Teracopy and having the files tested after being copied I noticed a large majority of the files were CRC mismatches.

After more searching I decided to buy a new NIC (Intel Gigabit CT PCI-E Network Adapter EXPI9301CTBLK). This has not stopped the problem.

Here is a list of things I have noted:

  • CRC mismatches are always random. The same file(s) don't always get CRC mismatched.
  • This only happens when I am copying from my host computer to another system such as the NAS. If I were to transfer a file from the NAS or another computer in the network there are no CRC mismathces. I have tried testing this with a large amount of files at different file sizes. It only seems to be when copying from my host computer to another system on my network. I can even transfer files from my NAS to the same computer with the issue and get no CRC mismatches. Its only an issue when transferring from this particular computer. No issues when transferring to it though.
  • This happens on any HDD or SSD that I use. I currently have a SSD and 9 other HDDs attached to my Mobo. Unless all of my HDDs and SSD are going bad this seems to rule out the drives have gone bad.
  • I have also used RapidCRC to verify that Teracopy is not giving bad information.
  • I did a file transfer of about 20 files (10gbs total) and when I transferred them to another system on the network none of the files had any issue. Then I tried it again doing the exact same thing and nearly all of the files were CRC mistmatches according to Teracopy. The issue is random but happens 95% of the the time. When this happens it can be one file, some of the files, most of the files or all. It is very random.
  • I copied a large amount of music over to my NAS. Out of the 129,000 files 558 had CRC mismatches. I also did notice music skipping in these files especially when it was a FLAC encode.
  • This network is very very rarely ever used by anyone but myself. I have transferred files to my NAS when I am doing nothing else on the network and this still happens.
  • I am in the country. I do not believe I have any Wifi issues due to apartments or being in an urban area. My ethernet is simply 5ft and 10ft cables. Everything is rather close. No ethernet in my walls or anything.

Here is what I have done to try to fix the problem:

  • In Teracopy, Enable "Use system write cache". This seemed to make it worse. Unchecked this option after seeing the results.
  • New Router and Modem. No difference.
  • When getting my new modem recently I decided to also try using new cat6 cables. I believe some cables are still cat5 as well. This has made no difference.
  • New NIC. No difference.
  • Enabled NetBios. No differences.
  • Ensured new NIC is running at 1gbps full duplex. The NAS I am trying to copy files to is also at 1gbps full duplex. No difference.
  • I have tested copying files locally from one hard drive to another and never had any CRC mismatches.

Here is my computer & network specs:

  • Modem & Router: Motorola SURFboard SBG6580
  • Network Cable: Cat5e and Cat6
  • OS: Windows 7 SP1 Home Premium
  • NIC: Intel Gigabit CT PCI-E Network Adapter EXPI9301CTBLK
  • CPU: Intel i5 2500k 3.3ghz
  • RAM: 16gb DDR @ 800mhz 11-11-11-28 (according to Speccy, i thought i purchased 1600mhz and lower CAS ram though, I am not sure if this an issue)
  • Motherboard: ASRock Z68 Extreme7 Gen3
  • GPU: ATI Radeon 6700 (XFX 1gb)
  • SSD: 120gb OCZ Vertex 3
  • HDDs: Various Hitachi, Samsung, Western Digital and Seagate Drives

If you have any ideas of what the problem could be. I may be completely wrong about what I am saying. Please feel free to correct me. I believe it is a network issue but I am not sure at all. It could be software or hardware. Could it be my memory? I would have thought my memory was okay if it is able to transfer files to hard drives on the same system without these issues.

Ultimately I want to be able transfer files and stream files over my network through Wifi and Ethernet without files becoming corrupt. It seems to be a networking issue and I am not as knowledge on networking issues, but this may just be an issue with my PC. If anyone has an idea why this happening (also as pointed out does not ever happen with YouTube, Netflix, etc.) I would appreciate it.

  • Based on gut feeling, I would check the computer CPU and Memory using Prime95 and Memtest86+ before doing anything else. Try that. – Christian Isaksson Aug 1 '15 at 12:03
  • What file transfer protocol(s) are we talking about here? SMB? Does the corruption happen when you use a different file transfer protocol when sending the file off the main host computer, such as [S]FTP, scp, rsync's own protocol, etc.? – Spiff Aug 1 '15 at 15:49
1

I've just been researching this issue. People have had problems copying large files through Windows Vista/7 since Vista came out years ago. Different people with different specs, copying via USB3, internally, and via network all leaves the same issue. And other people are fine.

Some people claim teracopy fixes their issue as long as you are not using the system cache. The most interesting workaround I have seen was somebody removing a stick of RAM from their PC, even though all of their sticks passed memtest and were fine. Somebody answered this with

"It's FSB stability. You see, the more sticks of RAM you have installed and the greater the addressable banks, the greater the load on the memory controller. With greater load, timing can become an issue with some motherboards. There's only so much time to poll all that memory across all those banks and sticks. Yours certainly wouldn't be the first motherboard I've seen that has issues with all it's slots filled!"

To further support this, another person updated their BIOS and claims that that fixed their issue.

I'm still playing around with my system, though it looks like Teracopy without system cache does it for me, or at least has done it for the moment. Try the RAM, I'm interested to see what works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.