I recently updated from my Windows 8.1 to Windows 10.

Upon right-clicking the Windows icon in the lower left corner, a quick start menu pops up.

enter image description here

Unfortunately, I can click any option, but it won't open the asked tool. The menu closes (well, because it has been clicked), no error messages, nothing.

I can right-click it right away again and select another option. Nothing.

How can I get this WIN+X menu to work again properly?

(This has been since Windows 10. On Windows 8.1 it had been perfect.)

up vote 4 down vote accepted

Luke, use the Language Packs!

Ok, this is a solution which I came on testing something completely different. I just wanted to download the English language pack for Windows 10 (I'm a German user), just to see what exactly changes and how good Windows 10 can switch.

After I switches my language pack, I've got another language on my UI (wow!) and also my WIN+X menu worked again!

So after that I switched back to German, which made the UI and the menu German again - but not broken. It works now.

TL;DR Switch to another language pack, reboot, switch back again, reboot. Done.

  • Nice. So AirDroid is still working for you? – Arjan Aug 8 '15 at 14:25
  • The DLL was hooked when I first changed to English. I then uninstalled AirDroid and switched back to German. I guess AirDroid could be working, but I can't check it for now. – Trollwut Aug 9 '15 at 14:43

Try the Win+X Menu Editor and see what it says about the existing entries.

Also boot in Safe mode to see if an existing application blocks the menu (for example the airdroid windows client is reported to do just that). If that's the case, you would need to identify that application.

  • Well it showed as it all was normal. I resetted it to Defaults, which changed them (and removed the new Win10 ones), but they're also not working. :/ – Trollwut Aug 6 '15 at 17:42

I've seen this happen in upgrades from Windows 7 to 8, which was then caused by shell extensions that were not supported by Windows 8. However, that did then not affect all options in the Win+X menu, and also affected some right-clicks in Windows Explorer and all, which you don't mention.

For Windows 10, such failing context menus are known to cause problems with AirDroid. (And then also do not affect all options in that menu.)

I don't know if one can easily disable such extensions in Windows 10, but for Windows 8 the third-party freeware Shell Extensions Manager was the solution:

[...] there are also many other applications that install additional shell extension components. For example: If you install WinZip on your computer, you'll see a special WinZip menu when you right-click on a Zip file. This menu is created by adding a shell extension to the system.

The ShellExView utility displays the details of shell extensions installed on your computer, and allows you to easily disable and enable each shell extension.

According to their website, this utility runs on Windows 10 too. So: just disable all extensions and if things then work fine, enable them one by one to find the culprit.

  • This may be possible, as I'm an AirDroid user. I will check it out this evening! – Trollwut Aug 7 '15 at 8:59
  • The linked other question also has details about some manual work needed after uninstalling AirdDroid, but I guess just disabling their context menu (until they fixed it) would do the trick too, @Trollwut. – Arjan Aug 7 '15 at 10:29

I experienced this issue after upgrade from Win 7 to Win 10. Nothing on the WIN-X menu worked .

I have found the solution elsewhere. There may be a program that blocks the "CONTEXT" menu function in WIN-X. Download ShellExView. This program does not install and may be run from a USB drive. The ShellExView utility displays the details of shell extensions installed on your computer, and allows you to easily disable and enable each shell extension.

Shell Extensions are in-process COM objects which extend the abilities of Windows operating system. Most shell extensions are automatically installed by the operating system, but there are also many other applications that install additional shell extension components. For example: If you install 7-Zip on your computer, you'll see a special 7-Zip menu when you right-click on a Zip file. This menu is created by adding a shell extension to the system.

ShellExView can be used for solving context-menu problems in Explorer environment.

I also used Restart Explorer to restart explorer after each enable/disable of a Shell Extension.

How to proceed:

  1. Start both ShellExView and RestartExplorer from USB or Windows.
  2. Sort the shell extensions by type to view by context menu.
  3. Disable any extension and restart file explorer. Check WIN-X menu.
  4. Continue with all shell extensions within context menu.

My interfering shell extension was "Memeo Life Explorer extension" from a long ago uninstalled program.

I have been looking for a solution to this problem for days. Win+X doesn't work on my Windows 8.1 Pro computer. All the other Win+ keys work just fine. Right-clicking on the Start Button does nothing - no context menu appears. This happens when logged in as any user, including a new, clean profile. It happens in Safe Mode. It happens with a Clean Boot. The %appdata%...\WinX folder is present and correct. I tried every fix suggested on every website I could find and none of them worked until I hit on this forum.

http://www.tenforums.com/general-support/15591-win-x-doesnt-work-anymore.html

I had previously removed the shortcut arrow from desktop icons. I have been doing this for 20 years, ever since Windows 98 came out. I found a tip for Windows 98 years ago that said you could remove the shortcut icon arrows by editing these two keys:

[HKEY_CLASSES_ROOT\lnkfile] "IsShortcut"=""

[HKEY_CLASSES_ROOT\piffile] "IsShortcut"=""

All you had to do was rename the two values "ShortcutIs" and restart or logout and log in, and the arrows would be gone. Been doing that for 20 years with no problem, from Win98 to Win7.

However, it seems that when you do this in Windows 8.1 Pro, it disables the Win+X key. As soon as I set both values back to the default (IsShortcut) and restarted, the Win+X key worked, and right-clicking on the Start button gave me back the Start context menu.

I don't actually like the Win+X menu, I always install Classic Start Menu and give myself back a Windows 7-style Start menu. But it annoyed me that the Win+X menu was missing, even though I don't use it. I knew this meant something was wrong, which bugged me.

I had NO intention of reinstalling Windows 8.1, which many sites (including Microsoft) had suggested - that is too drastic a solution and it wasn't worth the time and trouble, and I would simply have hidden the shortcut arrows again and been back where I started.

This may not work for everyone who has the Win+X problem, but it worked for me.

I have also been looking for a solution to this Win+X shortcut menu problem for weeks where many of the shortcuts don't work, and I finally found the source of the issue on my Windows 10 Pro x64 PC. Using ShellExView v1.97, I was able to disable all non-Microsoft Shell Extensions, restarted Explorer (using Ctrl-E in ShellExView), and my menu was fixed!

I then re-enabled the disabled items a few at a time and restarted Explorer each time until I found the culprit. In my case, the culprit was a shell extension for Express Zip File Compression utility from NCH Software. This program was installed as a companion program to some other NCH software that I have purchased, but I don't have a need for it, so I uninstalled it.

With all other shell extensions re-enabled, the Win+X menu items all work, and my system is back in order.

I hope this helps someone else with the same issue.

First I am going to suggest that you check for any updates via Windows Update and install them all. Something could have gone a bit wonky when upgrading. All problems that I have had with Windows 10 this far have been fixed either with a restart or installing updates :)

  • Checked both and unfortunatelly it hasn't repaired itself. :C – Trollwut Aug 2 '15 at 13:37
  • 1
    BTW shouldn't you rename yourself for that to Answer Giver? – Trollwut Aug 2 '15 at 13:37
  • @trollwut I generally ask more than I answer ;) – Question Asker Aug 2 '15 at 13:42

I had a similar problem with middle click.

I recommend disable windows 10 driver updates: link here

Then install all drivers for your touchpad/mouse/whatever input manually.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.