I had remove the Microsoft Store application. Yes, totally remove the app. Do not ask how and what for. :)

Is there a convenient way to set it up again or restore it? Anything except "system restore"...

Upd. I used this method to remove everything. And it works so good that nothing can be found again. :) or :(.

[Get-AppxPackage Microsoft.WindowsStore] returns nothing.

Search for [Microsoft.WindowsStore] returns only:

  • C:\Documents and Settings\All Users\Microsoft\Windows\AppRepository\Packages\Microsoft.WindowsStore_2015.7.1.0_neutral_split.scale-200_8wekyb3d8bbwe [Folder is empty]
  • C:\Documents and Settings\All Users\Microsoft\Windows\RetailDemo\OfflineContent\Microsoft\Content\en-gb\AppData\Microsoft.WindowsStore_8wekyb3d8bbwe [Folder contains only 3 jpg]
  • C:\Documents and Settings\All Users\Microsoft\Windows\RetailDemo\OfflineContent\Microsoft\Content\Neutral\AppData\Microsoft.WindowsStore_8wekyb3d8bbwe [Folder contains only 3 jpg]
  • C:\Documents and Settings\All Users\Microsoft\Windows\AppRepository\Microsoft.WindowsStore_2015.7.1.0_neutral_split.scale-200_8wekyb3d8bbwe.xml
  • C:\Documents and Settings\All Users\Microsoft\Windows\AppRepository\Microsoft.WindowsStore_2015.701.14.0_neutral_~_8wekyb3d8bbwe.xml
  • reinstall it from the microsoft store this is for W8 but should work the same, scroll down to "Reinstall the app"
    – Moab
    Aug 2, 2015 at 2:02
  • Thanks, but I tried this. It really works from W8 only. AppDiag works only in W8 and "reinstall app" starts from words "Tap or click Store to open the Windows Store" and this is problematic without Store. :(
    – Badiboy
    Aug 2, 2015 at 9:20
  • 1
    Try re-registering the Store app: tenforums.com/tutorials/…
    – MC10
    Aug 2, 2015 at 21:24
  • MC10, thanks, but "Get-AppxPackage Microsoft.WindowsStore" returns nothing for me, thus the method doesn't work...
    – Badiboy
    Aug 3, 2015 at 6:57
  • 1
    I think I'm having the same issue: It looks like Remove-AppxPackage + Remove-AppxProvisionedPackage removes all traces of metro apps from the system - including the Windows Store App - which makes Get-AppxPackage fail. Correct me if I'm wrong, but the question is how do you restore the Store App at that point?
    – WernerCD
    Aug 3, 2015 at 17:20

12 Answers 12


So, the Windows Store is now back with me. As far as there was no complete solution in any single answer, here is my solution. Thanks for all who participated.

What you'll need

The installed Windows 10 with apps (further it will be references as "good windows"). You may use "friends computer". I used the VirtualBox virtual machine and an appropriate setup image. There is no need for license key for this: Win10 can be setup without key and activation, it'll be enough for this solution.


Take the ownership of "C:\Program Files\WindowsApps" folder as adviced here.


Open WindowsApps folder. Check, if there are next folders:

  • Microsoft.VCLibs.140.00_14.0.22810.0_x64__8wekyb3d8bbwe
  • Microsoft.VCLibs.140.00_14.0.22810.0_x86__8wekyb3d8bbwe
  • Microsoft.NET.Native.Runtime.1.0_1.0.22929.0_x64__8wekyb3d8bbwe
  • Microsoft.NET.Native.Runtime.1.0_1.0.22929.0_x86__8wekyb3d8bbwe
  • Microsoft.WindowsStore_2015.7.1.0_x64__8wekyb3d8bbwe
  • Microsoft.WindowsStore_2015.701.14.0_neutral_~_8wekyb3d8bbwe

If some of them are not presented there - copy missing ones from good windows and copy here.

Note1. For those who are in italic: I'm not sure that they are required, I processed all of them, may be they are not required.

Note2. For WindowsStore folders there may be another version, as it can be seen in @Fase answer.

Step 3

Open Windows Powershell.

Register every folder (one by one, except the last one!) in the order they are presented in above list with the next command:

Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\*FOLDER*\AppxManifest.xml"


Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.7.1.0_x64__8wekyb3d8bbwe\AppxManifest.xml"

You'll be close to success if the command with WindowsStore will give no errors. Others may return errors if they were allready registered.

Step 4

If Step 3 was successfull, you'll be able to find (Press WindowsKey then type Store) the Store application in the Start Menu.

Try to start it. If it will work - congratulations. If it will be shown for a while and then closed - see Step 5.

Step 5

Grant permissions for "ALL APPLICATION PACKAGES" account to WindowsApps folder as adviced here.

That's all Folks!

enter image description here

  • 6
    Step 3 (better) Open Windows Powershell. Register every folder in the order they are presented in above list with the next macro command: foreach ($folder in get-childitem){Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\$folder\AppxManifest.xml"}
    – user484609
    Aug 17, 2015 at 1:27
  • 1
    Thanks. I find this awful, how come there is no way to restore just these bits in some safe mode command? They seem to get screwed every month, just by themselves. At the moment, I can't start even Windows Update, Edge, Calculator, Microsoft Store...
    – Ciantic
    Nov 24, 2015 at 17:04
  • Have to downvote this. On any current build of Windows 10, this process irreparably damages the built-in apps.
    – EKW
    Jan 29, 2016 at 16:16
  • Also, see this article if the apps won't open: support.microsoft.com/en-us/kb/2798317
    – James T
    Mar 21, 2016 at 19:58
  • This absolutely does work with one caveat: Step 3 should run & {$manifest = (Get-AppxPackage Microsoft.WindowsStore).InstallLocation + '\AppxManifest.xml' ; Add-AppxPackage -DisableDevelopmentMode -Register $manifest} in Powershell as per Microsoft's blog: blogs.technet.microsoft.com/ouc1too/2015/08/17/…
    – Thomas
    Jun 15, 2016 at 4:42

I was finally able to fix this. It's actually quite funny. I upgraded Windows 10 to Windows 10.

  • Insert the disc or create and mount the iso
    • You can download it here
    • I was able to upgrade to Windows 10 from other OS's using this tool directly, but that did not work from 10 to 10
  • Chose "Download and install updates (recommended)"
  • Accepted agreement
  • Chose "Keep Windows settings, personal files, and apps"

After the "upgrade" you'll have the Store and all other default apps back

It reverted the two windows updates I had received but then they downloaded and installed again just fine. I imagine this would get more risky as more updates come out in the future.

After all of that was done, I ran these commands in an admin PowerShell to strip off everything but the Store and Calculator:

Get-AppxPackage -AllUsers | where-object {$_.name -notlike "*Microsoft.WindowsStore*"} | where-object {$_.name -notlike "*Microsoft.WindowsCalculator*"} | Remove-AppxPackage

Get-AppxProvisionedPackage -online | where-object {$_.packagename -notlike "*Microsoft.WindowsStore*"} | where-object {$_.packagename -notlike "*Microsoft.WindowsCalculator*"} | Remove-AppxProvisionedPackage -online
  • you do not want to remove the provisioned packages.
    – kinokijuf
    Aug 16, 2015 at 20:52

Actually it's super easy, just open Windows PowerShell (Admin) and execute:

Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

Based on this cool tutorial.
Be aware that this restores all default metro apps.

  • This did the trick for me. I'd followed someone's advice to disable services related to Microsoft Store and all that, but executing this from an administrator-level PowerShell worked. Got myself a Ring Pro doorbell camera recently and the app is the only way to interface with the camera from a PC. Dec 29, 2016 at 2:09
  • 1
    Doesn't work if you removed the provisioned packages.
    – Mark
    Sep 6, 2017 at 20:58

I managed to get the Windows Store back with the following command in Powershell:

Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.Window sStore_2015.722.24.0_neutral_~_8wekyb3d8bbwe\AppxMetadata\AppxBundleManifest.xml "

If the command above doesn't work, you may need to take ownership of the WindowsApps folder and explore and find your App Manifest file for Windows Store.

How to get access to C:\Program Files\WindowsApps?

To re-add all default apps, take a look at this: https://thomas.vanhoutte.be/miniblog/reinstall-default-build-in-windows-10-apps/

  • 1
    Thanks, but not working for me: nothing about WindowsStore neither at this path nor at any other path (see post update)...
    – Badiboy
    Aug 3, 2015 at 7:05
  • Fase, could you please provide me the content of the "C:\Program Files\WindowsApps\Microsoft.WindowsStore..." folder (I hope there is no confidential information?) so I'll try to reinstall it with your solution? Email: [email protected]
    – Badiboy
    Aug 3, 2015 at 12:40
  • Likewise. Get-AppXPackage | Remove-AppxPackage seems to remove all traces of the appllication - including Windows Store. All of the folders I've seen listed lack the files listed. I'm working on copying the files from a computer with a working WindowsStore to see if it works.
    – WernerCD
    Aug 4, 2015 at 3:12
  • Get-AppxPackage -allusers windowsstore | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
    – Xdg
    Apr 16, 2016 at 19:45

For Windows 10, although the above did not work, this was very helpful in getting to following solution for me to restore WindowsStore which just blinked and did not open since Windows 10 was installed as upgrade to Windows 8.1 Pro.

First I logged on as Administrator and checked the hidden folder under C:\Program Files\WindowsApps\ to see that the file had a new updated version of Windows Store. As of August 29th, I had "Microsoft.WindowsStore_2015.8.25.0_x64__8wekyb3d8bbwe" as latest version and still had the separate earlier version with name "...2015.8.3.0._x64"

Then I right click Start icon select Command Prompt (Admin) at prompt type "powershell" without quotes and hit enter then did following: Step 1 change directory PS C:\Windows\system32>cd c:\ Step 2 enter command with new file path PS C:>Add-AppxPackage -register "C:\Program Files\WindowsApps\Microsoft.WindowsStore_2015.8.25.0_x64__8wekyb3d8bbwe\AppxManifest.xml" -DisableDevelopmentMode

If file path not recognized then here are some tips (and where I went wrong) first check that you have a space between "Program" and "Files" in the command line, second check that you have two underscores before "8wekyb3...." and one underscore between "WindowsStore" and "2015" and space before and after "-register". Good luck, this was two weeks of effort but now Windows Store fully functional.

  • This fixed the Store for my Windows 10 Insider Preview. Aug 22, 2018 at 22:22

Reinstall Microsoft Store; simple solution:

  • Download GitHub - LTSB-Add-MicrosoftStore
  • Extract
  • Run Add-Store.cmd as admin
  • Store is now working, now update apps inc Microsoft Store.
  • Tested on Windows 10 Pro

See the below list for what is installed. You can edit before hand to limit the apps; though as this is a premade pacakage, I have left as is. To uninstall anything such as the xbox afterwards; for a single user run elevated powershell:

Get-AppxPackage | Out-GridView -Passthru | Remove-AppXPackage

or for all users see here

Contents of Download:

  • Add-Store.cmd
  • Microsoft.DesktopAppInstaller_1.8.4001.0_neutral_- 8wekyb3d8bbwe.appxbundle
  • Microsoft.DesktopAppInstaller_8wekyb3d8bbwe.xml
  • Microsoft.NET.Native.Framework.x64.1.3.appx
  • Microsoft.NET.Native.Framework.x64.1.6.appx
  • Microsoft.NET.Native.Framework.x86.1.3.appx
  • Microsoft.NET.Native.Framework.x86.1.6.appx
  • Microsoft.NET.Native.Runtime.x64.1.3.appx
  • Microsoft.NET.Native.Runtime.x64.1.4.appx
  • Microsoft.NET.Native.Runtime.x64.1.6.appx
  • Microsoft.NET.Native.Runtime.x86.1.3.appx
  • Microsoft.NET.Native.Runtime.x86.1.4.appx
  • Microsoft.NET.Native.Runtime.x86.1.6.appx
  • Microsoft.StorePurchaseApp_11706.1707.7104.0_neutral_-_8wekyb3d8bbwe.appxbundle
  • Microsoft.StorePurchaseApp_8wekyb3d8bbwe.xml
  • Microsoft.VCLibs.x64.14.00.Appx
  • Microsoft.VCLibs.x86.14.00.Appx
  • Microsoft.WindowsStore_11804.1001.813.0_neutral_~_8wekyb3d8bbwe.AppxBundle
  • Microsoft.WindowsStore_8wekyb3d8bbwe.xml
  • Microsoft.XboxIdentityProvider_2017.605.1240.0_neutral_-_8wekyb3d8bbwe.appxbundle
  • Microsoft.XboxIdentityProvider_8wekyb3d8bbwe.xml
  • README.md

I would say a BIG THANKS you to @Badiboy for this answer that I'd like to upgrade a little bit:

Note: After spending 2 days and many hours for digging, especially on M**Soft forums, including useless upgrading Windows 10 :((( seems that:

Microsoft native applications like

  • etc

Get's easily corrupted when you try to block them from UAC policy, disable relevant services, uninstall them, etc. When does, the phenomenon is like APP is starting for a fraction of a second, then crashes.

If you don't have WindowsStore anymore, you cannot do anything (my case)!

What's happens?

Somehow, this folder get's trashed, wrong ownership, etc.

C:\Program Files\WindowsApps

Solution that 100% works

Go to a Windows 10 machine (the same version as you have) that could be a VBOX one.
Take ownership of this folder

C:\Program Files\WindowsApps

Get relevant folders and ZIP them together ! <-- this is important
This way you will not loose permissions or any file that cannot be copied. Now go to your machine, unzip somewhere and COPY & OVERWRITE into your

C:\Program Files\WindowsApps

Of course, you have to be OWNER of this folder too.

Finally, re-register them as usually with a elevated PowerShell. In case of errors, read them and install dependencies

Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.WindowsCamera_2018.826.98.0_x64__8wekyb3d8bbwe\AppxManifest.xml"
Add-AppxPackage : Deployment failed with HRESULT: 0x80073CF3, Package failed updates, dependency or conflict
Windows cannot install package Microsoft.WindowsCamera_2018.826.98.0_x64__8wekyb3d8bbwe because this package depends
on a framework that could not be found. Provide the framework "Microsoft.NET.Native.Runtime.1.7" published by
"CN=Microsoft Corporation, O=Microsoft Corporation, L=Redmond, S=Washington, C=US", with neutral or x64 processor
architecture and minimum version 1.7.25531.0, along with this package to install. The frameworks with name
"Microsoft.NET.Native.Runtime.1.7" currently installed are: {}
NOTE: For additional information, look for [ActivityId] 89a20470-2867-0003-d225-a2896728d701 in the Event Log or use
the command line Get-AppPackageLog -ActivityID 89a20470-2867-0003-d225-a2896728d701
At line:1 char:1
+ Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\W ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : WriteError: (C:\Program File...ppxManifest.xml:String) [Add-AppxPackage], IOException
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

PS C:\Windows\system32> Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.NET.Native.Runtime.1.7_1.7.25531.0_x64__8wekyb3d8bbwe\AppxManifest.xml"
PS C:\Windows\system32> Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.WindowsCamera_2018.826.98.0_x64__8wekyb3d8bbwe\AppxManifest.xml"
PS C:\Windows\system32> Add-AppxPackage -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.WindowsCalculator_10.1906.55.0_x64__8wekyb3d8bbwe\AppxManifest.xml"
PS C:\Windows\system32>

Now all relevant APPS should work instantly.

Finally, you can safely delete/uninstall/block WindowsStore as usual.


Something to try after you do the above. Open Command Prompt and copy and paste this in to start the store,

start "" "ms-windows-store:"  

I would like to share my experience. Maybe it will help someone... I had very bad issues with Store that does not want to open as well as some apps. I literally tried everything that I could find on internet, all suggestions. Nothings happens, I was very disappointed. Then I just found option to turn on developer mode (Start->Settings->Update and securities->for developers->choose developer mode over there). And I wouldn’t believe… Store is working. Then I chose “Downloads and updates” in the store -> it shows store update, I click on it and store update itself. Then I disable ‘developer mode’ And store still keep working ;) YAY!

  • Not sure how it resolves the problem but it exposes you to uncertified apps too.
    – clhy
    Nov 25, 2015 at 15:12
  • I love how this one answer with a -1 is the only one that actually worked.... Dec 20, 2020 at 4:54

After multiple attempts, I managed to get Store open by enabling Developer mode (as suggested by one of the posters here) and running the command "Get-AppxPackage -AllUsers| Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}" in Powershell. Not sure if is exactly the solution since I've tried different steps suggested by different users in different forums (including uninstalling Store separately) but hey, I am not complaining!


The answer of @Badiboy helps my problem. I removed a lot of metro apps but kept ms-store with MSMG toolkit before I install windows 10 x86 on a very old laptop. Unfortunately, MS Store does not work after installation.
I fixed it by following @Badiboy guideline.

  1. Run command add-AppxPackage ...Store..., error information shows my system missed Microsoft.NET.Native.Runtime.1.4.
  2. I copied Microsoft.NET.Native.Runtime.1.4 from another windows 10 and register it with -DisableDevelopmentMode -Register "C:\Program Files\WindowsApps\Microsoft.NET.Native.Runtime.\AppxManifest.xml"
  3. following step 5 to grant access permissions for "ALL APPLICATION PACKAGES" account to WindowsApps folder.
  4. Run 'Store' and it works!


Download as ZIP

Run the Microsoft.WindowsStore_11804.1001.813.0_neutral_~_8wekyb3d8bbwe.appxbundle

It might say already installed (I did run all the powershell commands on this page but it all came up error and the Windows Store folder was not in the AppData Packages)

Once the window is up, just reinstall and launch.

  • 1
    This is the same GitHub link provided by an answer from 2019.
    – Ramhound
    Oct 6, 2021 at 20:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .