20

I just installed Windows 10 and I want to join my domain through my windows VPN. But when I want to change the properties of the IPv4 protocol, nothing happens.

The button is NOT greyed out. (I mention this because I find many people having troubles with this.)

21

I had the same issue you might need to find how to do what you need in powershell. For example I used this to change the use default gateway setting:

Set-VpnConnection "VPN Name" -SplitTunneling $True 
  • 2
    This doesn't solve the specific question, but this was exactly the solution I needed! If anyone else needs a workaround, the full list of Set-VpnConnection options are here: technet.microsoft.com/en-us/library/… – Stefan Mohr Aug 11 '15 at 20:35
15

Update 2015-11-16: Fixed in TH2.

I just installed Cumulative update for Windows 10 version 1511: November 10, 2015. (Codename Threshold 2). The bug is gone. Clicking Properties now works and brings up the expected menu.

I made a point of checking before the reboot: Bug was still there.
And after the reboot/half-hour-install: Bug is now gone.

Original post preserved below.


Bug.

Seems to be a bug. Reproducible and everything.

Supposedly fixed in preview build: Windows 10 Build 10547 Insider Preview (fast ring) released September 18, 2015. Regular release date is not known.

Workarounds

Edit rasphone.pbk

All of a user's VPNs are saved in %appdata%\Microsoft\Network\Connections\Pbk\rasphone.pbk. This is a plain old ini-file and can be edited.

There you can copy entries from a known-good config. (Or if you have lots of time on your hands, then you can also read the Microsoft Documentation for the PBK file format: [MS-RRASM]: Routing and Remote Access Server (RRAS) Management Protocol: 2.2.2 File Format for Phonebook.)

Use PowerShell-cmdlets

Namely Set-VpnConnection.

4

I'm just pasting from the original article. Credits to his author. This worked for me.

Got some good news. We found a workaround. A colleague pointed me to the right direction (thanks Philippe! :-)). The properties of VPN connections are stored in PBK-files. There seems to be one file per user which contains all connections. The file is located here:

"C:\Users\[YOURUSER]\AppData\Roaming\Microsoft\Network\Connections\Pbk\rasphone.pbk"

You can open and edit it with an editor of your choice as it is a "good old" ini-like file. The property to be edited in this case is "IpPrioritizeRemote",wich is the same as "Use default gateway on the remote network". Just set it from "1" (true) to "0" and save. Afterwards it worked immediately for me as desired. There are plenty more properties if one has to change something else. I would strongly recommend to copy the file to a save place before starting to fiddle around with it This is surely not the preferred way to change those properties but a nice workaround for now. Be careful with it.

  • 2
    Hi Diego Mayán. While it's great that you are trying to contribute, this really should be an edit to Wesley's answer since it looks like that's where the content is from, and not an entirely new answer. As a separate answer, this is basically plagiarising the Microsoft Answers content with no attribution. – a CVn Aug 5 '15 at 13:47
  • 1
    Diego: Thanks for pointing out that this is another's work - however please include a link/name for attribution purposes, as @MichaelKjörling suggests. Consider proposing an edit to Wesley's answer and deleting this. Thanks Michael for the constructive comment! – studiohack Aug 5 '15 at 14:28
3

Maybe this link can help you: "http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_web/network-connection-vpn-ipv4-properties-not-working/a60edf99-4b06-4219-bb75-b7c08de4ff9e"

  • 6
    Link only answers are not appretiated here, if you instead extract the useful information from what you were pointing to, or paraphrase what was discussed, then provide a link, the answer will be complete and may bring you upvotes, and will live a long happy life , even when the link pointed to is dead or changed. – Psycogeek Aug 2 '15 at 11:06
2

In rasphone.pbk:

Found in: C:\Users\[YOURUSER]\AppData\Roaming\Microsoft\Network\Connections\Pbk\

As well as setting IpProritizeRemote=0, I found it necessary to set IPInterfaceMetric=1. This is the same as ticking the box "automatic metric" in the original properties form (I think).

0

Changing the information In rasphone.pbk:

Found in: C:\Users[YOURUSER]\AppData\Roaming\Microsoft\Network\Connections\Pbk\

As well as setting IpProritizeRemote=0, I found it necessary to set IPInterfaceMetric=1. This is the same as ticking the box "automatic metric" in the original properties form.

I also Manually added my networks DNS servers at IpDnsAddress and IpDns2Address

This has solved my routing issues currently.

It is not the most elegant fix but it will do for now.

0

I faced this problem for a couple of months. I tried every advice posted here and sadly nothing worked for my FortiClient SSL VPN connection.

Finally the solution came out with the latest Windows 10 update (build 1511).

Now I can change my IPv4 settings for my VPN connections as it should have been from the beginning.

Give it a try.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.