3

My question is very similar to this one; I followed traintes' answer, but had limited success.

My issue is that the user folder Win10 created for me is "C:\Users\tyler" with a lower-case "t", which is quite frustrating to me, especially since it's a proper noun.

In short, the steps given in the other answer involved changing a registry key that specified the user folder path, then changing my Microsoft account's name in User Accounts. At this time, both the key in the registry and the name shown under my account are now "Tyler" with a capital "T", so those steps worked, but the actual user folder is still lower-case.

I know this may not seem like a big deal, but it is to me; I just finished clean installing Win10, so I'd like to fix this before I start installing too many things.

Note: I haven't used superuser before, so I was unable to leave a comment about this on the linked question, sorry!

4

Try the following:

  • Create a second admin user unless you already have one.

  • Reboot your machine and login as the second administrator user, do not log in as tyler.

  • Press Windows+X and click Command Prompt (Admin)

Now type:

rename "c:\users\tyler" "Tyler"

You don't have to change anything in the registry or elsewhere.

  • Sign out and sign in as tyler

This works because tyler and Tyler are considered the same and works in all currently supported versions of Windows.

  • It worked perfectly, thank you! The only caveat was that I had to put the path/folder in quotes, or else it gave me a syntax error, i.e.: rename "C:\Users\tyler" "Tyler" – Tyler Vezina Aug 3 '15 at 23:32
  • I get "access denied" (yes, it's Administrator command prompt) – Can Poyrazoğlu Mar 22 '17 at 4:49
2

In my installation of Windows 10 (version 1511, OS build 10586.36) the currently marked correct answer doesn't work, you still continue to get an error telling you that "Access is denied".

An alternative solution is to run lusrmgr.msc, double click on "Users", right click on the name you want to recapitalise and then select "Rename":

enter image description here

(I really wouldn't recommend changing anything more here than just the capitalisation)

After a reboot, you'll find that you have the correct capitalisation for your login, folder on the desktop and probably a couple of other places.

You won't, however, have the right capitalisation for the homegroup user, the username within the network, the folder in c:\users and probably a number of other places.

  • lusrmgr.msc doesn't work in Windows 10 Home Edition. – NBlizz Nov 10 at 4:13
0

Have you followed every step of my guide? Because you mentioned that you have changed the path in the registry and in the user accounts settings, but you haven't changed that path in the Explorer too (or at least you did not mention it in your question!).

After you have changed the values in the registry and the user account settings, you have to reboot the machine. When you login to Windows the next time, you will be logged in with a temporary profile (because there are obviously missing references at that time!). However, you can now just open the Explorer, go to the Users directory and change the name the folder from tyler to Tyler. Then you have to restart the machine again and everything should work as expected!

PS: You have to change more references in the registry. I have updated my step by step guide a few minutes ago!

  • I did follow the guide, yes, and I had changed the name in Explorer too. I just meant that when I was done, the values in the registry and user account settings remained capitalized after rebooting Windows, but the folder name in Explorer did not. Anyway, I was able to get it working as per Peter Hahndorf's answer, by changing the folder name via command line while logged in as another admin. Thanks for the update though, I'll check out your changes! – Tyler Vezina Aug 18 '15 at 18:43
0

Change User Folder name in Windows:

  1. Open command prompt with Admin Rights (Win+X -> A)
  2. Type net users Administrator /active:yes and hit Enter
  3. Reboot your computer. Select Administrator account to login
  4. Open Registry Editor (Win+R -> Type regedit and hit Enter)
  5. Go to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
  6. You will find several folders here like S-1-5-. Search through them till you find a ProfileImagePath pointing to your old username. Double-click on it and replace your old username with your new username
  7. Go to C:\Users\ and changed the folder name to what you specified in the registry
  8. Open command prompt with Admin Rights (Win+X -> A)
  9. Type net users Administrator /active:no and hit Enter
  10. Reboot and login to your account

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.