I've updated to Windows 10 and having the following issues:

  • Can't find things like Windows Update, Disk Management, Device Manager, Power Options etc.

  • Whatever I search, even if it does find it, it permanently displays "We're getting search ready"

I've rebuilt indexes, restarted, left it over the weekend in case it hasn't finished indexing.

Using an SSD if that matters

How can I fix these two Win10 search issues?

  • 2
    Seems like just about everyone is having this issue, and any "fixes" appear to be only temporary. Hopefully Microsoft releases a patch for this soon.
    – NateR
    Aug 3, 2015 at 3:37
  • What's the reasoning in someone downvoting me? Seems like a valid question to me. Accurate description of my issue. Spent a couple of hours researching and trying fixes before asking this question. And it's a question I'm sure others would like info on. Not sure what I did wrong
    – mejobloggs
    Aug 3, 2015 at 3:44
  • 2
    I didn't downvote, so can't be 100% certain, but likely because it's similar to/a duplicate of: superuser.com/questions/947392/… and superuser.com/questions/947295/…
    – NateR
    Aug 3, 2015 at 4:11
  • Ah thanks for that. Yeah I've looked over a few of those but they don't seem the same search behavior. I can still search for 95% of stuff as normal, just can't search for a lot of the 'system' things that I mentioned. Very frustrating. Already deleted my old windows folder so can't check the old startmenu folder to see if they contain what I need
    – mejobloggs
    Aug 3, 2015 at 4:18
  • Since I am having a lot of trouble with Windows 10 search, I posted this feature suggestion. If you end up here, you might want to vote on it. Aug 11, 2015 at 10:28

4 Answers 4


The Cause

For me, the problem was that I had optimized my search index by removing everything in the Included Locations from my Indexing Options except Start Menu. I did this because I use a different desktop search which I find far superior to WDS ('Everything' from http://www.voidtools.com/). So I wanted to avoid the redundant indexing and keep Start search limited to just Start related things.

This gave me the exact same symptoms as in the poster's question - installed apps show up fine with a Start text search, but all the control panel and system settings applets are missing, plus the constant "We're getting search ready".

I actually had this problem in Windows 8 and 8.1 and hadn't looked into it because I was using Start8 and it only manifested for me using the search charm, which I rarely used. Plus I figured Windows 10 would fix the issue. Obviously it didn't. Upgrading to 10 preserves the WDS configuration. Being a pre-10 issue also rules out Cortana being involved in this particular problem - a ton of the "fixes" I've seen online involve doing various things with Cortana.

The Fix

I resolved the issue by adding my user folder to the Included Locations set and waiting for indexing to complete.

If I rebuilt the index with and without my user folder included, I could see the bad Start search behavior go away and then come back. Verified 100% that this was the cause for me.

If anyone from Microsoft is listening: it would be nice to have the special "Start Menu" entry also include whatever magic bits Control Panel etc requires that including my user root picks up.

Also a quick note: if you want to completely reset your WDS folder configuration, you can go to HKLM\SOFTWARE\Microsoft\Windows Saerch, set SetupCompletedSuccessfully to 0, and restart the Windows Search service. Checking and unchecking boxes can end up with annoying overrides of inclusion-inheritance that are apparently impossible to remove otherwise.

Further Investigation

I spent some time trying to isolate which folder it really wants, so that I can exclude my user folder, but then include just what it needs. (I don't really like including my user folder then excluding all the folders in it, because then I'll have to go exclude new folders as they're added to my user root for whatever reason.) But I wasn't able to figure it out.

It's either a hidden folder or possibly one of the junction points in the user root. The default setup excludes AppData, and all the junction points in my user root point into AppData, so it would seem that none of those would be visible to WDS, yet something is being indexed.. And the UI doesn't permit selecting any of that stuff in or out so it's hard to experiment with.

So I gave up. I now have my user folder included and then unchecked every folder in it. It's not "pure" but it is a ~2600 item index, and the problem as reported by @mejobloggs is completely fixed for me. Good enough for government work.

  • Brilliant, thanks. My user folder was missing in search indexing. Added it back in and everything works fine! Annoying, as I don't want to search my user folder, but search just doesn't function properly without it. I also couldn't find the SetupCompletedSuccessfully reg key. Was hoping to reset to defaults
    – mejobloggs
    Aug 27, 2015 at 3:56

Follow these steps:

  • Open the Task Manager (e.g., Ctrl+Alt+Del, cursor down to "Start Task Manager", and press space or Enter)
  • Go to the Details tab
  • Click on the Name column to sort it by name
  • Look for the SearchUI process
  • Right Click on it and Finish it

After a few seconds the process is respawned by Windows 10 and search should be working again.

If you really want to improve the search response time and be able to tweak many of the options and keep a more know look and feel I recommend that you also install Classic Shell http://classicshell.net it has fixed many of my search issues with Windows 10 and has given me back the control.

  • Nope, no luck here unfortunately
    – mejobloggs
    Aug 6, 2015 at 20:56
  • @mejobloggs if this did not solve your problem, post a new question and provide here the link so we can help you Aug 7, 2015 at 13:47
  • 1
    Isn't that the point of the "Click to accept answer because it solved your problem" button? Originally I got downvoted because of supposed duplicate questions, and now you're asking me to create a new duplicate question just because his answer didn't fix my issue, even though I haven't marked it as correct? Confused
    – mejobloggs
    Aug 9, 2015 at 21:39
  • @mejobloggs you are right, for some reason I thought that you were someone different than the person that posted originally the question. And sure that is the whole reason for the accept as answer Aug 11, 2015 at 16:13
  • Oh right no worries, I understand now :)
    – mejobloggs
    Aug 11, 2015 at 21:32

Apart from all the usual suggestions, which it sounds like you've tried, try the suggestion from this answer:

Reinstall Cortana using the following procedure:

  1. Open an elevated CMD window (press win + X, and then press A)
  2. Type 'start powershell' (without quotes) and press enter
  3. Run the command below

PowerShell command:

Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

Some SSD optimization tools disable the Windows Indexing Service altogether, and that is likely to increase the SSD's life span. But I also experienced that the Windows search function becomes unusable after that.

  1. open the Control Panel
  2. type "indexing options" in the search box in the upper right
  3. select 'Indexing Options'
  4. if the 'Users' folder is not included click 'Modify' and select it

This is just complementing scobi's answer (which is the correct one) with the concrete steps to fix it.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .