11

I had to rub my eyes. But Word will not accept copy pasted images from the web. I've scoured the internet and done everything here: http://wordfaqs.mvps.org/InvisibleGraphics.htm

Naturally nothing worked.

What am I missing?

Sure, you can individually copy images into Paint and then copy them to Word but what if you want text and images? Madness.

My Cut, copy and paste settings:

enter image description here

15
  • some seem to think this is impossible: techrepublic.com/forums/questions/… I'm skeptical this is possible in 2015. Or if it is the case then there must be better option for Word processing. – Veta Aug 3 '15 at 0:42
  • Do you see the "invisible" boxes or nothing at all gets pasted? – MC10 Aug 3 '15 at 0:44
  • Nothing gets pasted, I found this thread: superuser.com/questions/91450/… but there was no solution. One lead I'm following is that it has to do with IE's security settings. This makes sense since it turns out I can paste from some websites (e.g. superuser.com) but not others. – Veta Aug 3 '15 at 0:48
  • 1
    What I've found is it's happening on certain sites (incidentally the ones that matter to me). cdn.cs50.net/2014/fall/lectures/9/m/notes9m/notes9m.html Looking at DevTools, it looks like these images were generated somehow since they don't use conventional image extensions. I'm guessing JavaScript? In any case, it will not let you copy paste this. Let me know if it does for you! – Veta Aug 3 '15 at 1:39
  • 1
    @Veta Works for me. In firefox. right click on image > copy image, paste into libreoffice. I would imagine Word will work as well ... – DavidPostill Aug 3 '15 at 11:08
9

After copying the image in the web browser, go to Word and click the down arrow on the Paste icon (Home tab), select Paste Special, then select Device Independent Bitmap.

1
  • I don't have "Paste Special", I have "Keep source format", "Combine format" and "Set default paste" (Word 2016). What to do in such case? – Jose Manuel Abarca Rodríguez Mar 30 '20 at 15:38
4

This happens with images that are produced from binary data, in the "data:image/ext;encode,binary" format. enter image description here

There's nothing that can be done for Microsoft Word but you can use LibreOffice and then past from LibreOffice into Word.

2
  • 1
    This did not work for me. I first wasn't able to directly paste the text and including image from yahoo mail into Libre Writer, and second after I manually pasted the image into Libre, I was not able to copy-paste the document content from Libre to OneNote or Word. The image was skipped. – Alan Baljeu Jul 26 '17 at 18:51
  • This works for whole documents/multiple images, but some of the formatting gets mangled when pasting in Word or saving as a .docx (though not as much as if you open an .odt with Word, which then won't even recognize headers and such). – Chema Nov 9 '20 at 22:53
1

What worked for me after I’ve tried all instructions and recommendations without success was to restore advanced settings in the internet properties. To do so open internet properties in Control Panel -> Tab Advanced -> Click on Restore Advanced Settings button.

In my case some websites with hyperlinks from others sources didn’t show the images, however if the images were in the same domain they’re displayed properly.

1
  • This fixed it for my MS Word. Before this I could not even copy/paste from Chrome. – StBlade Mar 22 '18 at 8:25
0

Once I solved it by reseting security settings in Internet Options dialog (Control Panel -> Internet Options -> Security -> Custom Level -> Reset). In Medium Low level I could paste pictures but in Medium High level I could not paste pictures. So, I decided to reset Medium High. I copied this from another forum, sorry to the poster but I can't remember your name, This worked for me!!! I reset mine to medium and it worked I can now copy and paste Yippee!!

0

You can simply copy individual images from any web site and use "paste special" in word as bitmap. Unfortunately you must do it for each image. I couldn't find a way to copy multiple images from a web page in one go.

0

I reset Advanced Internet Setting to and it worked.

I then looked into what changed and it looks like "Do not save encrypted pages to disk" under Security was ticked.

Unticked, works like a charm, ticked and it stops working on many pages.

0

I managed to hit a triple jackpot, myself:

  1. While copying a web page, the images, hosted on the server, would not appear on Word.
  2. Tried embedding them in data URIs, but that didn't work either (and never will, it seems).
  3. Put them on a directory and switched to relative URLs. That didn't work either. I noticed a garbled path in a tool tip while clicking on the broken images. Turns out Word would wrongly encode the full local path as Unicode instead of UTF-8 or some such, so it garbled non-ASCII characters.
  4. I moved everything to a root directory with an ASCII name, and finally it worked.
  5. Then it dawned on me: I had denied Word access to the network, out of sheer annoyance, after installing NOD32, so no wonder it couldn't download the images in the first place. Unblocking it on the firewall fixed #1.

To recap, Word doesn't likes embedded images, it might mess up non-ASCII paths, and my firewall works as it should (though I wish Word would show an error instead of silently failing at life).

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.