25

Just updated to Windows 10. The expected change language shortcut stopped working.

In the settings it shows that "Alt + Shift" is supposed to work, just like before the upgrade, but it does not. The tool tip window that is shown when I float over the language bar says that the shortcut is "Windows key + Space", which works, but I prefer "Alt + Shift" like it used to be.

How can I make it use "Alt + Shift" again?

  • I've re-read this a couple of times... What is the question? Are you wanting to remap the shortcut to what it used to be? – NateR Aug 3 '15 at 6:06
  • The shortcut doesn't work. – RCB Aug 3 '15 at 6:06
  • 1
    But you said that Windows key + space does work... Does that not work as well? – NateR Aug 3 '15 at 6:08
  • In the settings it shows that "alt + shift" supposed to work; but it doesn't. "win key + space" does work - can't change the shortcut – RCB Aug 3 '15 at 6:10
  • 1
    So back to my first question... WinKey + space works (as intended, it looks like), but you want it to be changed to Alt + shift? I'm having a hard time finding out what you are wanting to do. – NateR Aug 3 '15 at 6:15
26

Go to Control Panel\Clock, Language, and Region\Language\Advanced settings, in a section called Switching input methods click on Change language bar hotkeys, continue with Advanced key settings tab, then click on button Change Key Sequence... and then choose from a list called Switch Keyboard Layout your desired LEFT ALT + SHIFT hotkey.

  • as I said this option already selected – RCB Aug 25 '15 at 22:16
  • In a language settings, there should be one Windows display language, which has two keyboard layouts added, for example US and DE. Go again to in Change Key Sequence... menu a make sure you've chosen the option Not Assigned in a column Switch Input Language and your Left Alt + Shift in the Switch Keyboard Layout column. Then it should work. At least it works for me. – quaken Aug 25 '15 at 22:39
  • 1
    I could not make it work on my Lenovo S21e-20 notebook. The only setting that allows me to iterate through keyboards (languages) is when I have the "Use the desktop language bar when it's available" unchecked and the following language bar hotkeys set: Switch Input Language: Ctrl + Shift; Switch Keyboard Layout: Left Alt + Shift. Actually, the Left Alt + Shift does not seem to do anything, but at least, I can switch languages using a hotkey combination (not the one I normally used, but it's better than nothing). – Alek Davis Sep 8 '15 at 5:58
  • 1
    The weird thing is that it works fine on all other systems I upgraded. Just Lenovo has this issue. – Alek Davis Sep 15 '15 at 19:56
  • There is a problem with lenevo and windows 10 and the numlock key. actually I don't why but the problem is solved when I opened the numlock and the alt button worked! check this link for more info worldstart.com/alt-keys-not-working-in-windows-10 – shady sherif Jul 2 '17 at 14:41
0

I had the same problem when adding a 2nd keyboard layout. I deleted the 2nd layout, installed a complete 2nd displaylangue containing the 2nd keyboard layout and the problem is solved.

Shift+tab only seems to work when switching between keyboard lay-outs in different display language on my machine. Perhaps you have the sake issue.

protected by Community Sep 21 '15 at 16:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.