50

Recently upgraded to Windows 10. When I attempt to grab the title bar of a window and drag it to another monitor - I have two side-by-side monitors - Windows frequently prevents it. It appears like Windows thinks that I want to "snap" the window to the side of the origin monitor and won't let my mouse cursor cross the boundary to the destination monitor.

It appears like this: Here's how it appears

Figure 1: Google Chrome is being dragged left across Screen 2 onto Screen 1. When the mouse pointer hits the edge of the screens, a blue circle appears, showing the "snap to screen" effect.

2
  • Are the 2 screens the same resolution? I assume you can move the mouse between the 2 screens as expected?
    – Dave
    Aug 3, 2015 at 8:14
  • Video Example of issue for more context
    – KyleMit
    Sep 12, 2020 at 12:48

7 Answers 7

46

It is a question of speed of your cursor.

If you move a window slowly towards (or do a brief stop close to) the edge between your two screens, your chances that Windows will think that you want to snap that window are high. Then it will block your cursor "to help you".

If you move your window more quickly you won't have this behaviour and you'll barely notice the small circle that is displayed when snapping.

If you move really fast, Windows won't even display that circle.

Thus, avoid stopping close to that edge or increase your cursor speed. Hope it helps.

10
  • 6
    Use WIN + arrow keys for easy window placement.
    – Tomblarom
    Aug 3, 2015 at 9:19
  • 20
    What an awful "feature". I hate it. Surely to goodness there has to be a way to turn this off. I have a 4000 dpi mouse and can barely make enough momentum to cross the monitor boundary.
    – Kivin
    Aug 3, 2015 at 10:21
  • 7
    Usability fail in an otherwise excellent UI experience by MS. I've been a power user since Win 3.11 and completely didn't think that I had to drag it quickly. I was actually half dragging it into the other monitor and then picking it up again on the other monitor! LOL! Thank goodness for SuperUser! Jeff Atwood - I genuflect in your general direction! Oct 6, 2015 at 4:48
  • 2
    The speed setting for the snap should be much lower than it is.
    – zrooda
    Jun 26, 2017 at 9:02
  • 1
    Win+Shift+Arrow moves a window between monitors instantly, might help some.
    – samjudson
    Jan 19, 2020 at 19:05
21

The block is caused by the Windows 10 Aero Snap feature. It if you drag a window slowly, it will think you want to snap to the side/top border. You have 3 options that i know of:

  1. disable snapping in Display Settings / Multi-tasking. This disables ALL snapping, including the Windows 7 style snap-to-top-of-screen which you are probably use to. I tried this but I miss snapping to the top of the screen too much.

  2. move the mouse fast. This is your main option that actually works but is as annoying as hell, coz you'll often have to try again a couple of times when you forget to move the mouse fast.

  3. don't drag. use the WINDOWS ARROW key combination to snap windows around, or WINDOWS SHIFT ARROW to move between monitors. Some people seem to like this. I find this as annoying as acid on my face.

The fourth option is to whine to Microsoft about it until they give us an option to turn off snap-to-edges that are inside the extended desktop area.

Also worth mentioning, and even more annoying is there is a few pixels at the top of the screen that you can't drag through even if you move the mouse fast.

How to disable sticky corners in Windows 10

There seems to be a third party app/hack on that page to get around that problem, but no official solution from Microsoft yet...

5
  • 1
    +1 for the WIN + SHIFT keys combination. Didn't know that one. The top-right pixel of the screen is blocking our cursors to help us to not miss the red cross of the window.
    – Mik
    Nov 15, 2016 at 9:53
  • erratum: if you move REALLY fast the top left / top right pixels won't block you :-)
    – Mik
    Nov 24, 2016 at 14:26
  • I've tried as fast as my hand can move the mouse and it always blocks me in the top corner. Not sure if "REALLY" is taking on some extra meaning here? :) Jul 11, 2017 at 12:42
  • You are right. I don't what I did that day.
    – Mik
    Jul 17, 2017 at 9:36
  • I am now going for option 1. Yes, I loved the maximize function when dragging it to the top (especially as a combination of dragging it from monitor 1 to monitor 2, as I want to have it maxed there), but I just will use the double click maximize feature and should be fine... Would love to see that they bring in an extra feature to recognize "inner" edges to disable the snapping there ... maybe in Win 17 or so ^^
    – BAERUS
    Apr 13, 2019 at 19:45
6

This is due to the "Snap" feature, if you don't like it you can simply turn it off.

  1. Right Click on Desktop
  2. Select Display Settings
  3. Go to Multi-tasking
  4. Turn off the Snap Windows toggle switch

Snap Windows Settings Screenshot

No more snapping.

4

This is one of the top search results for this issue. I'm going to add another situation where this problem occurs as I recently ran into this.

If you have or use a mouse that is capable of very high polling rates, you will run into this issue. For example, I recently switched to a Razer 8K and noticed this issue. The commonly mentioned workarounds of "moving the mouse really fast" was not acceptable, and my workflow doesn't really accommodate the windows key / arrow keys. Disabling snapping was not an acceptable workaround either.

Ideally you'll have the ability to reduce the polling rate of your mouse. With Razer Synapse I am able to. Once you've changed it, you should be able to just exit the application so it doesn't need to run in the background. When you bring it below about 500 Hz, you can expect this issue to go away. Understandably this may not be ideal for gaming, so you could create profiles for productivity / gaming where the productivity profile utilizes the lower polling rate.

I was "polling" my hair out as to why this was happening because my laptop trackpad does not have this issue regardless of speed, and my previous mouse didn't have this issue. If you have a high polling mouse, expect to see this issue.

System OS: Windows 10 Pro
Version: 10.0.19043 Build 19043.2251 (21H1)

Polling Rate - Razer Synapse - Lists Available Polling Rates of Viper 8K

2
  • I ran into the exact same issue today and guess what, yesterday I had plugged in a new Razer Viper 8Khz with it's polling rate set to 8Khz. The bottom line is that Microsoft's speed calculation isn't taking the mouse pointer position update rate/frequency into account and thus it's a BUG they need to fix. Has anyone reported the issue to them and is there a KB or bug report link regarding this issue? Dec 3, 2022 at 13:08
  • Yep, I have recently upped by polling rate to 4k with the hyperpolling wireless dongle and I started having this issue. I have to move my mouse as fast as humanly possible to drag it to the next monitor. Lowering the polling rate to 125hz to test, and it does allow me to drag between monitors with minimal speed Oct 2, 2023 at 14:57
2

As @Mik has said, it is all about the speed of your cursor when dragging the window.

The reason you are being "blocked" is because Windows now has "Aero Snap" which, allows any [native] window to be snapped to an edge of the screen. The Aero Snap feature cannot work properly if there is no blocking.

So to circumvent this problem, Microsoft decided that it would be best to block the blocking only if the cursor was exceeding a certain "speed".

Solution: Drag windows quickly.


Also, could you please clarify something for me. In your screenshot, to the left of it, there is an open window which appears to be snapped. That window is on your left monitor right? Is it snapped to the right side of your left monitor? If so, and if you are not dragging the window very slowly, this might actually be a bug.

2

I am using Actual Windows Manager with Windows 10 and it has settings to replace the standard Windows 10 snapping with your own custom windows snapping features. After enabling AWMs snapping features this is not an issue any more and my UI elements only snap how an where I want them to.

1

Note: Taken from my own question/answer here

From a post by Matt Breedlove, the setting "DockTargetMouseWidth" removes the Monitor border stickiness.

It can be added via command line, as show belown, or via registry edit program (win+r: regedit)

reg add "HKCU\Control Panel\Mouse" /v DockTargetMouseWidth /t REG_DWORD /d 0

With this registry entry set, the border of monitors no longer stick and the shortcut win+arrow_key continues to work for shortkey window snapping. It would be great if Microsoft added an option to disable this feature, as they've done for snap settings.

Multitasking Snap Menu

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .