2

When I'm playing/working on my laptop the keyboard sometimes key-in randomly, so I ask:

How can I disable its on-board keyboard?

System: Laptop Acer v3 772g
OS: Windows 8

3
  • I am confused. What do you use instead of keyboard? Are some of keys or all keys interfere? – wolfrevo Aug 3 '15 at 9:58
  • @jacob only some of the keys not all of it – ken Aug 3 '15 at 10:10
  • What are you going to use for an alternate keyboard? Solutions that disable the keyboard driver may not be the answer. – fixer1234 Aug 4 '15 at 4:53
-1

Open control panel > device manager > keyboard (assuming you are using an external USB keyboard) and remove the built in one.

Now that is HOW:

So now WHY?

If Key in randomly means you press a key and random keys are displayed, you have these options;

  1. Have a dirty keyboard. Clean it. OR

  2. Are pressing way to hard.

If you are just using the mouse and random characters are displayed, (not likely the issue) but usually this would indicate a faulty mouse or corrupted driver. I only mention this because although unlikely, it could happen.

3
  • actually the c is most likely. it isnt a because even tho i dont press any key , something is being keyed in. additional info. some of the keys doesn't also work. – ken Aug 3 '15 at 10:30
  • @key That is because you put your usb keyboard over you laptop keyboard. Stay away from that. – wolfrevo Aug 3 '15 at 10:31
  • @jacob i dont think so. the keys that will be pressed by the keyboard are the keys escape and end. but the keys that are being keyed in are number 7, the shift key and the most deadly, the delete key. – ken Aug 17 '15 at 10:55

Not the answer you're looking for? Browse other questions tagged or ask your own question.