For the past several versions (since Windows Vista, I think), if you hit the Windows key and start typing, Windows will search for applications.

Since upgrading to Windows 10 with Cortana, she is only hit or miss at finding applications. And she doesn't do partial searches, either.

Some examples:

  • WinKey + type "Paint" does not find "mspaint". Instead it suggests some applications from the store.
  • WinKey + type "Excel" does not find Excel. Nor does typing "Word" find Word. However, typing OneNote finds OneNote.

What is the reason for this behavior and how I can get Cortana to find the applications installed on my machine again? Is there a setting I am missing?

If I browse to "C:\ProgramData\Microsoft\Windows\Start Menu\Programs" I can see that the shortcuts for these applications all still exist. But Cortana is not finding them. Everything from the Microsoft Office applications to IIS to Beyond Compare to hundreds of other applications I have installed.

Where can I set which folders Cortana indexes?

As you can see in the screen shot below, this Start Menu folder is, indeed, indexed:

Enter image description here

However, none of these applications are coming back as search results from the "start" menu.

It may be related to this issue as well.

I did a brand new install of Skype (for desktop), and it shows up nowhere in the start menu. And typing in "Skype" to search for the application does not find it. But the shortcut to Skype is definitely in this location:

C:\Users\Patrick\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Skype


The latest Windows 10 update (Threshold 2) has solved this issue for me. Cortana now finds all my files with no issues. Previously my only solution was to use Classic Shell, I've been able to uninstall that now and use the standard Windows Start menu.

  • When I search for paint, it finds "Paint, Desktop app". You don't see the Paint app at all? Did you change Cortana or Search settings?
    – MC10
    Aug 3, 2015 at 16:32
  • Nope. If I type "mspaint" it finds "Paint, Run Command". Let me see if i can find the search settings and see if something isn't checked correctly. (edit: there doesn't seem to be an option for this) Aug 3, 2015 at 16:34
  • 1
    I'm experiencing the same issue and I did a fresh install of windows 10 yesterday. This is so annoying. Aug 11, 2015 at 14:41
  • 4
    I found that if you go to C:\ProgramData\Microsoft\Windows\Start Menu\Programs and open the shortcut "Search", it opens the "Search Everywhere" feature from Win 8, and there all the apps appear, so it has to be a bug in the new search UI of win 10, and not in the indexing options. I just wish that "win + s" could open "Search Everywhere" instead of Cortana. Aug 11, 2015 at 17:39
  • Cause Cortana is a dumb creature!
    – Sypress
    Aug 18, 2015 at 19:48

17 Answers 17


Found a solution here: Cortana not finding Desktop apps when searching for them

Here is the relevant part:

I reinstalled Cortana using the following procedure:

  1. Open an elevated Command Prompt window (press win + X, and then press A)
  2. Type start powershell and press enter
  3. Run the command (in one line):

Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

After 30 seconds the problem was solved on my machine. Incredible.

  • 5
    Great find! I really wanted this to work for me. But it didn't. I'm happy this solved it for you, hopefully this helps other people, too. Aug 12, 2015 at 13:46
  • 3
    Yeah, exactly. I still am having issues with this. At this point I think this is a bug in Windows 10 and will hopefully be fixed as a patch. I may as well mark this as the fix, even though it is not 100% Aug 17, 2015 at 21:01
  • I've got this to work, steam was instantly findable. I'm running W10 Pro. Other than windows version, the only other thing that comes to mind would be to double check that your powershell prompt is elevated (it would say Administrator in front of it.)
    – Melikoth
    Aug 19, 2015 at 23:06
  • 3
    Afterwards search for 'Windows Feedback', launch the app and tell Microsoft about this issue so they resolve whatever causes it in the first place. Nov 5, 2015 at 13:51
  • Awesome. The only problem is that the problem happens again and I have to do this again and again and again
    – user4951
    May 18, 2016 at 9:47

If you're seeing some but not all of your Desktop apps in the start menu search and "All Apps", there appears to be a bug where Windows 10 will only register up to 512 start menu entries, which may be the cause.

You can see how many start menu entries you currently have by running the following from within powershell

Get-StartApps | measure

You should get a count that reflects all your Modern/Metro apps plus all of the shortcuts in your start menu (one for each .lnk file). If your count is greater than 512, then a workaround is to delete unnecessary start menu entries by either uninstalling unused apps or deleting the unnecessary .lnk files from the start menu directories:

C:\ProgramData\Microsoft\Windows\Start Menu\Programs

%APPDATA%\Microsoft\Windows\Start Menu\Programs

As you delete .lnk files from those folders, Windows 10 will automatically register Start Menu links that it had previously skipped over due to the bug without you having to do anything. If you run the powershell command again it should reflect the updated count. Once you get your count down to 512, your Start Menu search and "All Apps" should no longer be missing items.

NOTE: An easy way to remove a whole bunch of unnecessary .lnk files is to delete all the links to uninstallers, since you almost always already have access to them via "Add/Remove Programs". If that is not enough, you can run WinDirStat against the two start menu folders above and sort by "items" in order to see which apps have added the most links. Lots of apps also add links to their website or documentation which you often do not need since they're just a google search away.

For me, deleting the low hanging fruit was not enough so I ended up having to move a bunch of start menu folders for rarely-used apps to a temporary (non-indexed) directory. I'm planning on moving them back once the bug is resolved. In particular, Visual Studio, SQL Server, and Microsoft's various SDKs add a TON of start menu entries.

  • Seraching those start menu directories for "Help", "Uninstall", "Readme", and "Homepage" helped me get rid of quite a few entries (about 200!)
    – justinsg
    Oct 23, 2015 at 13:05
  • @ivanatpr do i need to have programs add start menu shortcuts whenever i install a program? i dont have my programs do that, so they dont end up indexing it seems.
    – n00b
    Sep 14, 2016 at 19:13
  • Got a count of 315, won't change after removing links/folders from both locations, any idea what could be wrong?
    – Dan
    Dec 25, 2017 at 0:43
  • Great tips. I had 639 links. After removing various junk, I was down at 483 and everything seems to work properly.
    – matli
    May 7, 2019 at 11:57
  • The Get-Startapps cmdlet does not exist in Windows 10 version 1809. Is there an alternative?
    – Fopedush
    Dec 10, 2019 at 2:05

It's hard to believe that something so fundamental to Windows and central from a user perspective can be this buggy. I had pretty much the same problem. I solved it by removing everything from the index except for the Start Menu. This might not be an option for you, as it appears that you like to be able to search across many folders.

Before Windows 7, I used to use a tool called "Find and Run Robot" heavily, much better than launchy in my opinion, to find programs and files in addition to the start menu. It leaves your start menu alone, unlike the Start Menu replacements and works completely independently.


One thing worth trying is Control Panel -> Troubleshooter -> View All -> Search and Indexing. On my Windows 10 (just upgraded from Windows 8.1), it found & fixed some permissions issues on search-related folders.

Of course it hasn't fixed my search problems of not finding most Start Menu applications and settings (neither did reinstalling Cortana, messing with Index folder variations like just using Start Menu, rebuilding the index over and over, etc). Search worked mostly fine before the Windows 10 upgrade - sigh.

  • I stuck with this problem as well. Im able to use the search but he does not find any .exe files. I create a txt file he will find that 5 secs later, i rename that file into .exe and he does not find that file. It drives me nuts. Nov 23, 2015 at 22:11

My investigation has found that programs in the user start menu

C:\Users\<username>\AppData\Roaming\Microsoft\Windows\Start Menu

Is automatically excluded from indexing the users (exclude appData).

I've manually added that folder and am waiting for the index to build.

  • @surfasb It was probably just reindexing that did it. The Start Menu folder is an Included Location with no exclusions by default.
    – 1j01
    Dec 3, 2016 at 21:30
  • On Windows Server 2016, AppData is excluded by default for all users. When I remove the exlusion, Start Menu under AppData is indexed, but even after forcing a rebuild, most shortcuts are missing.
    – SebiF
    Jan 11, 2017 at 16:47

Ok, doing a reindex of the search from the "Advanced Options" screen under Index Options (see screenshot) seems to be fixing the issue. It's going to take awhile to run, but already 7-Zip and Beyond Compare are coming up where they didn't previously (and those are alphabetically closest to the start, I suppose).

enter image description here

EDIT Ultimately this only worked partially. It found some of the missing apps, but 90% of them are still missing.

Plus there seems to be no way to add them back in.

  • 3
    I have the same problem and re-indexing didn't work for me. Aug 6, 2015 at 15:54
  • Re-indexing ultimately didn't work for me, either. It found some of the missing apps. But most of them are still gone (like all the office apps) Aug 7, 2015 at 14:25

Actually it seems to be a larger problem:

On my account, Microsoft or local, that existed before the upgrade Cortana does not find Apps or settings. It now finds my documents after rebuilding the index.

It doesn't search in "Settings" either. And even worse, outside Cortana, the search in the "Settings" panel search box finds nothing, even if the searched text is in the current search page!

On a newly created local administrator account, just for test, it works like a charm.

It might be an access-right issue somewhere.

  • Did you find a solution for this version of the problem? I'm having this exact issue.
    – NickG
    Dec 14, 2015 at 16:12
  • Just my 2 cents, I created a local admin account, removed my Microsoft account, and then created my Microsoft account from scratch. After logon all the apps can be found. Certainly looks to be a profile issue.
    – basvo
    Feb 23, 2017 at 20:20

I think you're actually indexing too many files and that's stopping the search from returning useful results. Your Indexing Options screen shows around 1.9 million items indexed.

I had about 1.5 million files in my index as well, with all of my development files under my C:\Users\<username>\ directory. My start menu search was really slow and was wasn't returning useful results (wouldn't find built in apps like Internet Explorer or Edge).

I was able to fix it by resetting my "Indexed Locations" to the Windows defaults (Right-click start button -> Control Panel -> Indexing Options -> Modify).

Include only:

  • Offline Files
  • Start Menu (C:\ProgramData\Microsoft\Windows\Start Menu\)
  • Users (C:\Users\ but excluding C:\Users\<username>\AppData)
  • I also excluded my large development directories under my user directory (C:\Users\<username>\dev, etc.).

This is how my indexing settings look now (Note I now only have ~36K files indexed):

My updated Indexed Locations

Finally I triggered a rebuild of the index (Right-click start button -> Control Panel -> Indexing Options -> Advanced -> Rebuild).

My updated Indexed Locations

After waiting a little while for things to re-index the start menu is returning correct results as quickly as I can type!

This FAQ on how to Improve Windows searches using the index is what tipped me off to the issue.

Can I index my entire computer so all searches are fast?

You shouldn't do this. If you make the index too large, or if you include system file locations (such as the Program Files folder), your routine searches will slow down. For best results, we recommend that you only add folders that you search frequently.

The default set of indexed folders was based on the defaults from my media PC which had a clean install of Windows 10 (wasn't upgraded from Windows 7 -> Windows 8 -> Windows 8.1 -> Windows 10 like my main machine)


This answer is my own discovery on Windows 10 Pro 1703 x64. (That's Creators Update, folks.) I had to resort to it because, to my surprise, the answer by Augusto Barreto did not work for me. Without further ado:

  1. Do either of the following:
    • Create a new temporary user account with Administrative privileges, log out of your current account (very important) and log into the temporary account
    • Start your computer in Windows Recovery Environment
  2. Delete, rename or move the following folder:

    C:\Users\[Your username]\AppData\Local\Packages\Microsoft.Windows.Cortana_cw5n1h2txyewy

    Note: In Windows Recovery Environment, C: can sometimes become D:, E: or even F:, depending on your computer's configuration.

  3. Log back into your original account.

Cortana will not work immediately. (It is busy recreating the folder you just deleted.) But when it does, everything will be alright. Don't forget to delete the temporary user account.

Important notice: By the time I reached the conclusion to do this, I had ascertained that Windows Search Indexer was working okay and it was Cortana's problem that didn't show the result well. My evidence was that Cortana could find literally everything else (including my music) and searches from File Explorer worked well.

  • Resetting Cortana as this answer superuser.com/a/1349887/322261 suggest has the same effect I think: (the folder's date is now today date) and it quickly solved this ugly issue for me.
    – GLM
    Dec 16, 2018 at 19:30

The more radical (and effective) solution to any of the indexing problems is to reset the Indexing Options to defaults.

Since there is no official method to do this, one can use unofficial method, editing Windows Registry. The steps to perform are described here: https://superuser.com/a/963621/210811.

But hey, here is the copypaste:

  1. Stop Windows Search service:

    Win + R, services.msc, Enter

    Find the Windows Search entry, click on it, and choose Stop from the left column.

  2. Remove the following registry branch in its entirety:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\CrawlScopeManager\Windows\SystemIndex

    You can use the free home edition of Registrar Registry Manager for this.

  3. Follow the step #1, but click Start instead of Stop this time.

  • Even with the service stopped, I get an error trying to delete it. Turns out I had to take ownership first.
    – jpmc26
    Feb 16, 2019 at 3:48
  • Correct, that's why I mentioned Registrar Registry Manager. Regular regedit.exe cannot delete this branch due to this ownership issue. Feb 18, 2019 at 13:41

This bug apparently existed since the Technical Preview.

One proposed solution is to ensure that Program Files and Program Files (x86) are checked in the Indexed Locations window.

Other people seem to have found that the bug only hits when the number of items in the menu exceeds 512. To verify this theory, I suggest to minimize the Indexed Location to the bare minimum and rebuild the index. Once the essential items are indexed and available, you may add more locations.

A final solution is to install an alternative Start menu, such as the free Classic Shell. The Windows Start menu and Classic Shell can both be used in parallel.


I fixed this problem by Enabling the Windows Search service in services.msc. Not sure if I disabled it during tweaking by accident or if it came like that after Win 8.1 upgrade. After re-enabling and starting the Windows Search service I could search my apps again.

  • If your domain services disables this 'for performance reasons' in the past, it will bite you with windows 10!
    – CarComp
    Nov 9, 2015 at 18:29

I had the same issue, the following solved it for me:

I first of all reinstalled Cortana as explained in a previous post. This did not solve the issue, and I just want to include it for completeness (maybe not doing so makes a difference ;)

Then I opened up the indexing options and removed the user folder and the start menu folder (which can be found under C:\ProgramData\Microsoft\Windows\Start Menu). To do so, hidden files must be displayed. I clicked OK and closed the indexing options.

Then I reopend the indexing options, added the two folders again, clicked on advanced and enabled "Index encrypted files" and I clicked on Rebuild.

This solved the issue for me. Now Word, Excel and all programs can be found with the search. Maybe not all of my steps are necessary.

  • I had high hopes for this fix! Unfortunately, for me it did not work. In fact, now I have a permanent "We're getting search ready..." notification at the top of the search area. I will try and reboot later and see if it makes a different. Aug 13, 2015 at 19:14

After upgrading to Windows 10, Cortana search was not finding applications for me because the Samsung Magician software I installed for my SSD drive was configured to Maximum Reliability mode, which disabled indexing service/search. In order get Cortana to find applications installed on my machine again, I needed to change to Maximum Reliability mode in the Samsung Magician software. This answer will be helpful for anyone with Samsung SSD and Samsung Magician software.

enter image description here


This worked for me and didn't involve changing search index settings or reinstalling Cortana.

Start > Find Cortana app in alphabetical app list > Right click > More > App Settings > Scroll down and click 'Reset'

  • Next time I had to solve some issue I'll check latest shown solution first. Thanks for sharing
    – GLM
    Dec 16, 2018 at 19:26

If I browse to "C:\ProgramData\Microsoft\Windows\Start Menu\Programs" I can see that the shortcuts for these applications all still exist. But Cortana is not finding them. Everything from the Microsoft Office applications to IIS to Beyond Compare to hundreds of other applications I have installed.

I could fix this by recreating my profile.

  1. Create a new user
  2. Restart the pc and witch to that new user
  3. Rename the user direcory under C:\Users\ to _old
  4. Open regedit and look for the key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList
  5. There a serveral sub folders. You should remove the folder where the "profileImagePath" key matches you . Be carefull deleting the wrong folders here.
  6. Restart the pc and log in with you
  7. Your PC should now create a new profile

If you do skip the step 4 windows will create on every restart a new temporary user folder with will be removed with a reboot.

Be aware some test showed me the there seems to be no difference copying files to "C:\ProgramData\Microsoft\Windows\Start Menu\Programs" OR "C:\Users\John\AppData\Roaming\Microsoft\Windows\Start Menu\Programs".

As well i read on some topics that you should NOT exclude the default library folders (e.g. dokuments, pictures etc) from the indexed folders because this will cause massive problems with the search.

  • Please add a comment if you downvote answers why this is a bad/worng answer. Dec 2, 2015 at 11:39

We had the same problem, but the cause was having UAC disabled.

To fix, re-enable UAC and then rebuild the index.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .