In Windows 7 and 8, if I click the Start menu then start typing, the search results I see include Control Panels -- I could type "Mouse" or "Network" and see icons for the relevant control panels. In Windows 10, this isn't working. I've gone into Indexing Options and looked all around, but can't find anything to index that would make these show up. Do I have to figure out where the relevant .msc launchers reside?

  • 1
    If I type Mouse it shows Mouse & touchpad settings, System settings. What do you see? Try rebuilding the index: winbeta.org/news/how-rebuilding-your-search-index-windows-10
    – MC10
    Aug 3, 2015 at 19:42
  • Index the system 32 folder, or the entire windows folder to get all of them. These are excluded by default.
    – Moab
    Aug 3, 2015 at 22:40
  • 1
    I get one folder that has "mouse" in the name, then "Store" results, then "Web" results. No control panel / settings. It does now say "We're getting search ready..." but the Indexing Options control panel says "Indexing Complete". Is my search hosed?
    – James B
    Aug 6, 2015 at 19:35
  • 1
    Aaaand this is a massive known issue. I'll update here if I find something that reliably fixes :-/
    – James B
    Aug 6, 2015 at 19:50

3 Answers 3


A lot of people are reporting this issue in various forms.

In most cases it involves multi-lingual installations, but not necessarily. Even in mono-lingual installations this can happen, but the cause stills seems to be related to the multi-inequality feature.

The best analysis of the problem has been reported here, by DavidCRobinson. Below I have edited his solution to the essence:

The Issue
Windows saves the entries of the Control pannel settings in the user profile - the location is:


Under the above should be your default language directory (e.g "en-GB" or "en-US") and within this a list of ALL the available 'Settings' to be searched.

Problem 1
For some users this language pack and list of settings is NOT getting created for new users, ONLY the very first user profile created in Windows 10. The result is that you've got no settings indexed to even search for.

Problem 2
For some users, the folder exists, but there is something wrong with the Indexing properties of the directory. (skip to Solution Part 2)

Problem 3
For some other users, this folder exists, and the Indexing properties work, but the folder is not being indexed. (skip to Solution Part 3)

Problem 4
You have done all of the above, but the Index needs to be rebuilt. (skip to Solution Part 4)

Solution - Part 1

  • Find a computer or user on your own computer where the search function can find Control Panel items.
  • On this system go to C:\Users\workinguserprofilename\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState\
    and copy the Indexed folder.
  • Copy this folder to your own LocalState folder

Solution - Part 2

  • Go to %LOCALAPPDATA%\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState
  • Right click on the Indexed folder -> Properties ->Advanced
  • Deselect Allow files in the folder to have contents indexed...
  • Click ok and select apply to subfolders and files
  • Right click on the Indexed folder -> Properties ->Advanced
  • Select Allow files in the folder to have contents indexed...
  • Click ok and select apply to subfolders and files

Solution - Part 3

  • Go to Control Panel -> Indexing Options (obviously not through search ;) )
  • Click Modify -> Show all locations
  • Make sure your username is listed in the Summary of selected locations, and the AppData folder is not mentioned in the Exclude list.
  • If The AppData folder is excluded, or your user is not listed, first change your File explorer setting to show hidden folders.
  • re-open the Indexed Locations menu
  • Navigate to your user folder and select it, making sure the AppData folder is also selected.

Solution - Part 4

  • Go to Control Panel -> Indexing Options -> Advanced
  • Click Rebuild and wait until the Indexing Options menu sais Indexing complete (this can take a while).

Sidenote People experiencing this issue also report that when searching the message These results may be incomplete is constantly being shown. After applying these fixes, this issue should also be gone.

  • FWIW this somehow fixed itself at some point between when I originally asked and now -- I didn't notice exactly what fixed it. Thanks for following up though!
    – James B
    Feb 25, 2017 at 20:13
  • I created another local user, and search works fine for him. But he has nothing in %LOCALAPPDATA%\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState. There's no "indexed" folder in there. And yet search is working correctly for him. So I don't know what to think.
    – COOLak
    Nov 10, 2023 at 23:38

I fixed this problem with downloading a new language, change the computer's settings to this new language, close the session and switch back to my nativ language and it worked !

  • 1
    As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Nov 3, 2022 at 15:21

It's usually do to the AppData and other folders being unselected by default for most users. It's excluded by default. You just have to enable AppData for all users, apply/ok, and then rebuild.

  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Apr 18, 2023 at 20:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .