7

Ok so this is a relatively new one for me, I recently upgraded my computer, both to Yosemite and installing a USB3 Card from Sonnet. I have downloaded the drivers for the Sonnet card, and everything works great with it. However when my computer goes to sleep and then wakes back up, I am left with the alert that a drive was not ejected properly. It will list any and all USB 3 drives only that were connected and mounted. However when waking back up those drives will still be mounted on the computer.

So I am not sure what is causing the message, or if the drives are actually being disconnected, but something seems to be amiss.

Any help would be appreciated.

Computer system is 2012 Mac Pro 3.47 12 Core

6
+50

The likely answer is that your external drives also have a hibernate feature on them, and when they hibernate, Yosemite sees it as the drive disconnecting without it being ejected.

This exception is likely picked up by OS X even though the system is asleep. When you wake the Mac again, you will still see the warning, but the drives are also woken up and reestablish their connection to the Mac, so you can access them and see them as mounted.

Check the documentation for the drives that you have to see if they have a hibernate feature and whether it can be turned off. If it can, then turn it off, let the computer go to sleep and see if the warning comes back.

You can also test by setting the Energy Saver>Computer Sleep in System Preferences to 1 minute let the computer go to sleep, then wait about 5 to 10 minutes and wake it again. Unless the external drives are taking their cue from the USB card and hibernating the drives, they likely should not have entered hibernation, which means when you wake the Mac, you shouldn't see the Disk Not Ejected Properly warning.

Though less likely check the documentation for the USB 3.0 card and see how it behaves when your computer goes to sleep. Maybe it enters into low power mode that causes it to loses its connections, sort of like how your phone won't charge from a USB on a shutdown computer.

UPDATE

I thought of another thing that you can check for. Take a look at *Energy Saver>Computer Sleep** in System Preferences and see if the "Put hard disks to sleep when possible" is checked. This really should only effect internal HDDs, but maybe that could have a knock on effect to your external HDDs as well.

Also, if you have not filled these drives up yet and have the room to back them up, I would recommend going into Disk Utility and formatting them as Mac OS Extended (Journaled), or even better as they are externals, Mac OS Extended (Journaled, Encrypted), if you have not already done so. While most manufactures say that they are Mac compatible, what it usually means that they are ExFat formatted. If you are using the drives exclusively with Mac, it is always best to freshly format them to the native OS X format. It also has the added benefits of wiping away all of the OEM "utilities" that generally do nothing but make performance worse.

  • All good theories, let me do some digging and see if I can find any info on that – Chris James Champeau Aug 8 '15 at 20:26
  • 2
    Ok it seems that you are correct, It is an issue with my USB 3 card. It shuts down essentially when the computer goes to sleep. My solution for now is an application called Jettison for Mac. It safely unmounts drives when the computer goes to sleep. I cant say if it is the best option but I stopped getting the notification, so we will see. – Chris James Champeau Aug 12 '15 at 18:35
  • The other alternative is to set Computer Sleep in Energy Saver all the way to the right, which is Never, Check Put Hard Disks to Sleep When Possible, so that it will save some energy on spinning Hard Drives (assuming you don't have SSDs), and then just have Display Sleep set to the interval that you want. If you pair that with the Require Password setting in Security & Privacy and set a screen saver with the same interval as Display Sleep (though probably unnecessary), then you get for the most part the same effect as system sleep. – AMR Aug 13 '15 at 1:20
1

in energy saver settings in system preferences disable or uncheck "put hard disks to sleep when possible" That stops the HDs from ejecting when MAC goes to sleep.

  • This directly contradicts the accepted answer. Could you give some explanation about why the other answer is wrong on this point and you're right? – David Richerby Mar 20 '16 at 17:36
  • Have the same problem here. This solution does not work. Unchecking "Put hard disks to sleep when possible" in Energy Saver has no effect. – John Scipione Sep 5 '17 at 0:48
0

Turn off Spotlight for your external drivers in System Preferences -> Spotlight -> Privacy, and they will not be ejected when the computer is sleeping. I found this solution here.

  • Tried adding drives to spotlight blacklist but did not fix “Disk Not Ejected Properly” on sleep – John Scipione Sep 5 '17 at 0:56
0

Finally figured this out. My issue was my surge protecter. I had my drive plugged into a secondary slot that would power down when not in use (computer in master plug and when computer would sleep all other outlets power down).

I switched to and "unswitched" outlet on surge protector and now all is good.

0

I have a 27" IMAC 14.2 late 2013 using Sierra 10.12.5 and in Energy Saver of system preferences have checked only the first box-prevent computer from sleeping automatically when display is off. This seems to work and am not getting the disk not ejected properly so far. Will see if this continues to work.

0

My Mac pro does the same thing. Any drive, SD card or USB jump drive will show the "not ejected properly" warning every-time my Mac pro 5,1 comes out of deep sleep. This only happens on my USB3 PCI card. I have 2 Datatale removable drive enclosures on eSata with no ejection problems. Recently bought a OWC USB3 Dual Drive dock, since I can't get the Datatale enclosures anymore. Was hoping they wouldn't act like my USB 3 desktop hub, but unfortunately, I get the warning now on the Seagate drives in it. I plugged the dock into the Mac pro USB 2 port in the rear and the warnings have completely gone away. While I've lost USB 3 speed in dock's hard drives, I'm only using them as a archive back-up system, so once I copied over the vast amount of info on USB3, USB2 is fine for incremental backups using smart update with SuperDuper. Others tell you to uncheck "put the drives or computer to sleep when ever possible" in the OS System Energy saver preferences, but that defeats the deep sleep feature of shutting down the drives and computer when not in use. Perhaps someone makes a USB3 PCI that won't eject the disks, but for now, the USB2 solution works fine and no more annoying and possibly digit damaging eject drive warnings :-)

Not the answer you're looking for? Browse other questions tagged or ask your own question.