78

I have my Taskbar moved to the left side of the screen. How do I show the date below the clock on the system tray?

Windows 10 is quite new, so there isn't much on the internet about it.

  • Can you show us a screenshot of what it looks like currently? By date do you mean day of the week? – MC10 Aug 3 '15 at 23:22
  • The date isn't showing. – user114447 Aug 3 '15 at 23:47
  • So no 8/3/2015 or whatever format it is in, just the time? – MC10 Aug 3 '15 at 23:49
  • 3
    Yes, I worked it out: My taskbar is too small to show the date, if I drag it to increase the size it pops up. – user114447 Aug 3 '15 at 23:50
  • That's interesting, I can't even shrink mine enough to cut off the date. – MC10 Aug 3 '15 at 23:51
66

I found out the same problem in my horizontal Taskbar. It turns out that when "Use small taskbar buttons" is checked, the taskbar height is not enough to house the time and the date strings, so the date string is dropped.

Unchecking "Use small taskbar buttons" or doubling the taskbar height are the two solutions I found... but they neutralize my initial intention of a smaller taskbar taking up less space.

[EDIT] After reading Why you should use a vertical taskbar I tried it and also realized that you get the full time and date already from the smallest size of the vertical taskbar, even with small taskbar buttons. So it might have changed since the time the question was asked. Now, this might be your solution if you like the side bar, or you are willing to try and reap some of the benefits that article claims.

  • This is exactly what I was looking for. Increasing the vertical size suggested by Dianne works too but consumes a lot more space. – thanos.a Jun 1 '16 at 8:19
  • But then you can't have the date/time in the top-right corner (which helps with Mac/PC crossover adjustment). – yeliabsalohcin Jul 16 '18 at 10:40
  • 1
    @yeliabsalohcin I briefly looked around and it seems you can't have it all. But if "time in the top-right corner" is important to you, you may try with the toolbar at the top of the screen, or some gadget-like app that display the time anywhere you want it.There has to be the counterpart of the xclock from Linux. A look at alternativeto.net reveals "DS clock" and "Floating-clock" among others. – manuelvigarcia Jul 17 '18 at 7:17
28

I worked it out: My taskbar is too small to show the date, if I drag it to increase the size it pops up. My screen is HiDPI, so the text is relatively large, and the Date gets cut off if the taskbar is made smaller.

  • 8
    There is also a solution without increasing the size of the taskbar, which is to uncheck "use small taskbar buttons", as noted in another solution here. – Xonatron Sep 11 '16 at 16:58
  • 2
    But, Xonatron, that literally increases the size of the task-bar. – yeliabsalohcin Jul 16 '18 at 10:38
24

T-Clock is a little tool which solves this: http://github.com/White-Tiger/T-Clock

  • 9
    This is the best answer if you want to keep small taskbar buttons. – rubynorails Apr 19 '17 at 13:56
  • 3
    I don't think adding another application to system bloat is a good solution to what should be a standard option of showing the time AND date on a single line taskbar with small icons. Microsoft's usual half assed and short sighted development style. – Paul Gorbas Sep 15 '17 at 0:05
  • 2
    you are right, but currently there is no other solution than a 3rd party tool – cyptus Sep 15 '17 at 6:22
  • 3
    This is perfect. Exactly what I wanted. Customize the clock any way you want. Format, position, width, date, etc. Thank you! – Matthew Sep 26 '17 at 19:46
  • 1
    With this, Cmder, Choco & Classic Shell (subtract Cortana!) Windows 10 is marvellous! – greg_data Nov 22 '17 at 10:23
7

There are 2 ways Windows shows day of week on the taskbar.

1) Separate Day of week (DoW) is showed in 3rd row after time and date. You won't see it unless the taskbar height is big enough. On Windows 7 it was enough to enable 2 rows taskbar and the DoW would fit. But not always on Windows 10. If you have enables small icons, there won't be enough room. If you disable small icons in the taskbar settings, it will fit (at least on my 24" with full hd resolution and default dpi).

2) Another option is to change the Short Date format in Regional settings to include also the DoW name. Windows 10 shows the date in taskbar using the Short Date format. You can include the DoW name in it (by specifying ddd modifier), so in taskbar you will have "Thu, 21.01.2016" as date and don't need 3rd row just for the day of week.

  • 1
    Actually this the best answer I have seen here. I have a small monitor and change icons to big size is not enough for me. I have to add "day of week" to the short date. This should be the correct answer. – WesternGun Aug 29 '16 at 7:19
  • 1
    Why are you talking about DOW, noone asked anything about wanting to display the day of the week. The question was how to display the DATE on a single line taskbar while small icons are selected. The item displayed is short time, not short date. The stupid/shortsighted window 10 developers blocked putting date characters like dMMMyy in the time format boxes. – Paul Gorbas Sep 15 '17 at 0:02
  • This is the most comprehensive answer so far, but the instructions are (as typical) short on the procedural context. The features @Marki55 is referring to exist in the 'Adjust Date and Time' edit boxes that are available when you right-click on the time display in the taskbar. Unfortunately, he does not explain how to accomplish the actual editing of the 'short date' template. What's actually missing is the entire sequence of steps: 1. right click the date in the taskbar and click the 'adjust date and time' menu item. – Stato Machino Jan 4 '18 at 21:09
  • Going into Control Panel>Clock,Language, and Region -> Change date,time, or number formats->Additional Settings->Date tab allows you to customize the date format. I use yyMMdd to get the shortest Short date possible. This allows me to use small icons and a pretty narrow vertical taskbar. – 8DH May 9 '18 at 6:29
6

Try this:

  1. Right-click the Taskbar
  2. Choose Properties
  3. Uncheck Use Smaller Taskbar Buttons

After unchecking this option, you will be able to see the date and time.

  • 5
    This solution is actually a cause of why you might not see the date. Do not select use smaller taskbar buttons if you want to still see the date. It will only work if you're willing to make the taskbar have more height by unlocking it, placing your cursor at the edge and dragging it upwards. – Blisk Sep 21 '15 at 3:20
  • The first comment, I think, is before the edition by @oldmud0. It might be "check" and now it's "uncheck". – WesternGun Aug 29 '16 at 7:21
  • 1
    How does this answer differ from the top one? superuser.com/a/957140/156577 – jpmc26 Apr 28 '18 at 0:03
3

You can widen the task bar by going to the edge and dragging the little arrow. I did this and the date then appeared.

2

I had both the time and date displaying fine when using large taskbar buttons. Then this morning suddenly it was back to time-only. The remedy turned out to be to right click on the time display on bottom right and choose "Adjust Date/Time". Then it is important that you CHANGE a setting. Never mind that it seems that you have it all set correctly. Once you change the Short Date you will see it mirrored in the bottom right corner.

-1

When I dragged my vertical taskbar to be 5 inches wide, it overlapped a white window and I was able to see that the clock was enabled, but in black text on a black background. You can't change the text color, but I solved this by going in Personalization > Colors and setting a custom accent color for the background.

  • My coworker encountered this same issue. I believe this answer is going to help people. – Noumenon Aug 23 '18 at 0:25

protected by Community Dec 10 '15 at 21:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?