13

I have some services that are always using the CPU and writing to my disk. Eventually they eat up all physical RAM, which causes the noticeable performance hit.

I can't find them in Services.msc, so tried doing sc config "UserDataSvc" start=disabled in an Administrator's prompt, but get the error:

[SC] OpenService FAILED 5: Access is denied.

They write non-stop, always, and restart themselves after being stopped. They probably write hundreds of GB to my SSD each day so I'd like to disable the services until the bugs are fixed.

I think the main culprit is UserDataSvc.

enter image description here

Here's a GIF showing how tough it is on my SSD after just 19 minutes:

enter image description here

1
  • Sorry, @Userpassword, I flagged your comment not realizing an answer was in there, because after clicking I immediately saw some special effects followed by a big anti-semitic cartoon. Could you write the answer here instead? Dec 6, 2016 at 3:08

3 Answers 3

6

I solved the problem by setting in the Registry the start value for these two fields from 3 (manual) to 4 (disable):

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UnistoreSvc
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UserDataSvc
4

The Unistore Services belong to the Windows store. Looks like the store installs App-Updates. In the store option you can turn off the automatic update.

1
  • Thanks for the tip. The problem went away with one of the updates to Windows that came along since then. It wasn't that it was updating Store apps though. It's good to know where in the system the problem was though, so +1 I guess :) Sep 28, 2015 at 22:27
0

After months of research I was able to permanently disable the entire UniStackSvc group, since Regedit would not allow and change its name! In the Regedit editor, browse to HKEY_LOCAL_MACHINE \ SYSTEM \ ControlSet001 \ Services For example CDPUserSvc - the renaming will be with a numeric extension such as CDPUserSvc_26474 Go to the Start key and change it to 4 (do not load) Do this with all entries (+/- 14) Serve for other services that you. Does not want it to be loaded into memory. Only for professionals who know what they are doing! The Windows-10 was loading 120 services, now it runs fine with 80!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.