5

Prior to having Windows 10, I had Windows 8.1 where sleeping would work fine. Pressing the power button or just letting it sleep on it's own would both work fine.

Now, if I press the power button, after about a minute the device wakes back up.

When it's not plugged in, this means the battery will drain throughout the night as the device is waking up constantly.

I believe the issue is with the "Realtek High Definition Audio" driver because when I do:

powercfg -requests

It reports under [SYSTEM] that this driver is in use and says "An audio stream is currently in use"

I've tried disabling the request with

powercfg -REQUESTSOVERRIDE DRIVER "Realtek High Definition Audio" SYSTEM

or

powercfg -REQUESTSOVERRIDE DRIVER Realtek High Definition Audio SYSTEM

But none of these have helped. I've tried removing the devices from the Device Manager but this still has no effect.

There are no other wake timers running.

Does anyone have any other ideas I could try?

  • 1
    You have installed the current firmware updates that were released to address issues like this with Windows 10? – Ramhound Aug 4 '15 at 19:08
  • Could you provide a link to the firmware update? – TheStoneFox Aug 5 '15 at 22:42
  • I checked, I have the System Firmware Update 23/07/2015 – TheStoneFox Aug 5 '15 at 22:50
  • Since you have the current firmware for the SP2 my only other suggest, uninstall the audio driver for the time being, and report the issue to Microsoft. – Ramhound Aug 5 '15 at 22:53
1

seems to be a common issue

https://social.technet.microsoft.com/Forums/en-US/b88260fb-6f0d-4941-b63f-6cf298ea2f4d/surface-pro-2-wont-stay-in-sleepstandby-with-windows-10?forum=win10itprohardware

temporary solution is to disable wake on all keyboards and mice in the device manager.

1

Do you have Cortana's "Hey Cortana" listening enabled? On my SP2 powercfg reported an audio stream running even when I had no programs playing sound; this turned out to be from having Hey Cortana enabled. Disabling listening fixed the problem.

  • I had this showing up in my powercfg to but I had disabled the "Hey Cortana" feature and the sleep issue was still present. It was only after I disabled the keyboard/mouse wake functions in the device manager was when the problem went away. – TheStoneFox Aug 15 '15 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.