59

I had recently upgraded my laptop from Windows 8.1 to 10. Since the upgrade, I am unable to connect my Android devices as MTP (or Portable Media Player) devices on Windows.

The devices that I am using are Nexus 4, Samsung Grand 2 and Kindle Fire HD 7". Prior to the upgrade I was able to view these as Portable Devices.

All of these are displaying as Android ADB devices. I have tried the usual procedure of deleting that from Device Manager, and choosing Windows to choose an appropriate driver.

Windows 10 doesn't even display an option to add these as MTP USB devices or USB Composite Devices.

I have attempted to connect these devices to another Windows 8 machine that I have and they work pretty fine.

Can someone help me with a solution?

  • Do the devices give you the option of choosing PTP when they are connected? If so, try selecting PTP then reverting to MTP and see if that fixes things. – JMB Aug 4 '15 at 9:37
  • No. Even the PTP option is not displayed. It just detects the phone as an Unknown Device. – Shyam Aug 5 '15 at 6:53
  • Since it works for me (also an upgraded installation), there’s probably something wrong with your installation. If you have to the time, you should do a clean reinstall. – Daniel B Aug 26 '15 at 16:28
48

MTP is a protocol associated to Windows Media Player but Windows 10 does not include the WMP. The Media Feature Pack for N and KN versions of Windows 10 will install Media Player and related technologies on a computer running Windows 10 N or Windows 10 KN editions. For further information, please see http://support.microsoft.com and query the Knowledge Base for the article number KB3010081. So, download "Windows10-KB3010081-x86.msu" or "Windows10-KB3010081-x64.msu" from "http://www.microsoft.com/en-US/download/details.aspx?id=48231" and install it. The problem will be solved!

The new package to download is: https://support.microsoft.com/en-us/kb/3099229
As in the documentation:

This update supersedes update 3010081 in Windows 10 build 1511.

New version for Windows anniversary update 1607 KB3133719 https://support.microsoft.com/en-us/kb/3133719

New version for Windows 1709 and above: https://www.microsoft.com/en-us/software-download/mediafeaturepack
Other versions: https://support.microsoft.com/en-us/help/3145500/media-feature-pack-list-for-windows-n-editions#section-1

  • 2
    So, where to start. First off: Windows 10 does contain WMP. As with previous versions of Windows, only K and KN editions do not. And even then, a quick read on Wikipedia yields this: “Windows Vista and later have MTP support built in.” – Daniel B Aug 26 '15 at 16:26
  • 1
    @DanielB The answer is correct for Windows N: I installed the software (nothing else) and now MTP works. I have Windows 10 Pro N. – steffen Sep 26 '15 at 14:13
  • The approved edit of this post was very useful (although I don't know why this hasn't been posted separately), installing the Media Feature Pack for N and KN versions of Windows 10 solved the same problem for me: before installing this pack, the driver was missing for an Android tablet (Asus Transformer Pad TF303K - K01B) and the storage could not be used on Windows 10 Pro N. After installing it, everything worked as expected. – Sk8erPeter Oct 26 '15 at 21:06
  • 8
    Just a point: I had the same problem and I downloaded KB3010081 as stated here and in other sites, but it didn't work. After searching for more info, I found that KB3099229 is also needed (e.g. answers.microsoft.com/en-us/windows/forum/… ) – machlas Dec 23 '15 at 17:16
  • Here's the updated link for Creators Update: support.microsoft.com/en-us/help/4016817/… – DaleyKD Jul 6 '17 at 18:29
4

After Windows 10 Creators (15063) update to get it working I had to navigate to the C:\Windows\INF folder then find a file called wpdmtp.inf and install it by right clicking on it.
enter image description here

  • 1
    This set me on the right path. For me, I didn't have the .inf (just a .PNF). I had to download support.microsoft.com/en-us/help/4016817/… first. After that, it worked. – DaleyKD Jul 6 '17 at 18:28
  • Thanks @DaleyKD ... after hours of trying possible solutions, this one worked – Maarty Aug 26 '17 at 18:26
  • I had to ensure windows media player was installed on windows 10. Then once this was working, if i installed the wpdmtp.inf my motorola phone would then display and i could transfer files. Note, i also had to disable usb debugging. – David Feb 11 '18 at 22:43
2

I remedied this with my HTC by updating to the latest USB driver. I'd recommend looking on your manufacturer's website for updated drivers. Failing that, trying choosing one of the generic Windows MTP drivers.

2

The download of the Media Package may solve this, however I don't have Media Player at home on my Windows 10 Pro N Machine & can connect my removable devices perfectly fine.

You may need to download the Android drivers from Google's page here: http://developer.android.com/sdk/win-usb.html

This is part of the Android SDK, so when you download it, select the USB Driver Package and install that. I had some issues with Windows 7 and Android Drivers, Windows 8 seemed to fix it hence why 10 is fine for me.

Give that a try though and let us know how you get on :)

HTH

protected by Community Aug 7 '15 at 10:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.