30

I have recently upgraded my Windows 7 Pro to Windows 10 and basically everything seems to be working fine. Except for the fact that Win10 won't get Firefox as the default browser in the system... It started when I noticed that nothing happens when I click on links in email messages on Outlook. After I checked a few things, I also got to change the defualt browser to Chrome and the links worked. That's when I realized that the issue is with the definition of the default browser on Win10. I should mention that I have used all possible ways to set FF as the default browser in the system - from FF itself of couse, from the settings of the system, from file associations, program association and so on. Nothing changed when I did it for FF. Once I do it for Chrome (in ANY of the mentioned ways), it works exactly like it should. Is it a Win10 issue? Is it an FF issue? What can I do more about this?

UPDATE: I have tried everything that has to do with settings Firefox as the default browser in the system, including going through the Settings of Windows, going from the Settings of Firefox, setting default files and protocols, but nothing helps except for re-installing Firefox. If doing that would have closed the issue once and for all, I would have settled for that, but that's the "solution" after every reboot of the OS! This is very frustrating and I don't know what more I can do about it.

  • 1
    I had no problem switching the default browser on Windows 10. This sounds like a Firefox issue. – Ramhound Aug 4 '15 at 10:40
  • 1
    Does this help? support.mozilla.org/en-US/kb/… If not, there may be something wrong. – MC10 Aug 4 '15 at 10:41
  • 1
    @Ramhound: winkey; search for "Choose a default web browser"; Last option is "Web browser" with a grey plus - click that; pick any browser, nothing happens. Curiously, Reset appears to select Edge, but that choice is not persisted - reopening the settings screen reverts to the grey plus. @Tigger's answer works. Frankly: it's a little presumptuous to assume that works-on-my-machine implies there's no bug. – Eamon Nerbonne Oct 7 '16 at 17:11
  • 1
    @Ramhound: the behaviour I'm seeing is clearly a bug, regardless of whatever Firefox and Chrome are doing (and it sounds similar to this questioners experience, although I obviously can't tell that for sure). And you're misreading (or at least misleadingly representing) why Tigger's suggestion works - the OP did try the default, modern windows settings screen, in addition to the Firefox-initiated change. Tigger's suggestion ends up in a classic (looks Vista-era) settings screen - yet another different path to that same setting. – Eamon Nerbonne Oct 7 '16 at 17:27
  • 1
    Yes, it still happens now, even after all the updates Firefox went through since I've posted my question here, and yes, I have also tried @Tigger's solution here, but for me after a while (haven't figured it out how much time/uses exactly yet), Firefox still "loses" its default settings. I find this out when I click on a link in an email message in Outlook and nothing happens. Then, I close Firefox and click the link in the message again. Then, Firefox opens up and continues to be the default browser. After a while, this happens all over again... – TheCuBeMan Mar 7 '17 at 6:46

12 Answers 12

47

I fixed it by this method: Start -> Settings -> System -> Default Apps -> Set Defaults by App, click on Firefox, then click "Set this program as default".

After that Windows 10 remembered my setting and used Firefox as the default browser.

  • Firefox does not appear in that list for me. – JiK Jun 28 at 14:58
16

My current Windows 10 setup (Windows 10 Home, Version 1511, Build 10586.218) does also not allow to switch the default to Firefox via the new Settings App. The option is shown but not persisted.

Instead, I used the old Control Panel, which is still around and does the job:

Control Panel\All Control Panel Items\Default Programs

After select Default Programs, select Set your Default Programs. Pick your web browser of choice (e.g. Chrome or Firefox), and click on "Set this program as Default".

  • @Sun: Ah, right. Thanks for your edit! In the German version it is called "Systemsteuerung\Alle Systemsteuerungselemente\Standardprogramme > Standardprogramme festlegen > [..] > Dieses Programm als Standard festlegen". :) – Jens Piegsa Mar 9 '17 at 7:25
  • Thank you very much, this pointed me in the right direction. Seems the standard W10 method only associated Pale Moon with 1 of the 8 items it could be associated with, whereas the old Control Panel method allowed them all to be set. – Bonus Jul 4 '17 at 20:02
4

It's so annoying that Windows 10>Default Browser won't accept Firefox as the default browser, so this is what I did:

  1. Go to Settings -> System -> Default Apps, scroll down to near the bottom.
  2. Click to choose Set default by app.
  3. Click to choose 'Firefox', then click Choose defaults for this program.
  4. Click Select all, assuming you are a diehard fan of Firefox like I am.
  5. Save, and you're done!
2

Try to set it from Start/Settings/System/Default apps/Web browser.

Checked recently with FF 34.0.5.

2

Mozilla published a blog entry about how to do that here. This is the "official" way. If this doesn't work you may have a broken setup. If other browsers work fine i don't think this is Windows problem

  1. When you open Firefox for the first time, you will be asked if you’d like to make it your default browser. To do so, click the “Use Firefox as my default browser” button.

enter image description here

  1. The Windows Settings app will open with the Choose default apps screen. Scroll down and click the entry under Web browser. The Web browser icon will say either “Microsoft Edge” or “Choose your default browser”. It may not be intuitive, but you need to click on the Microsoft Edge logo to open the window that will let you choose another Web browser as your default.

enter image description here

  1. This will open the Choose an app screen. Click Firefox in the list to set it as the default browser.

enter image description here

  1. Firefox is now listed as your default browser. Close the window to save your changes.

Firefox for Windows 10: How to Restore or Choose Firefox as Your Default Browser

2

New solution (7/19/17)

If FireFox is not even listed as a browser option (like in the picture below). Click on the link to "Choose default app by protocol" Default Browser Options

Once that is open, find every protocol where your current default browser is listed (in this case Chrome), and change it to FireFox.(see below)

setting default protocol

  • Thanks, that's the problem I had... Any idea why Firefox wouldn't show up in the "Choose an app" list, and is there a way to get it into that list? – ajb Sep 6 '17 at 6:11
1

Eventually, the solution in this case was just to re-instsall Firefox. Thanks to all the commenters and replyers!

  • Actually, right now the best "solution" that I've found is that when I see that the link from the email doesn't open up in Firefox, I just close FF and when clicking on the link it opens up in Firefox, while starting it. From there on, the links will work fine until the next time... FYI – TheCuBeMan Sep 23 '15 at 9:42
  • 1
    No, it doesn't work. I'm having same problem as OP and setting it to default simply just doesn't work... reinstall must be the answer – Joe Phillips May 1 '16 at 4:39
1

Had the same issue a couple times now on multiple PC's and finally, accidentally, found a solution that solved this for all of my PC's!:

Just stop spam-clicking Firefox and set the default to Internet Explorer or either Edge first, now change it to Firefox.

0

I had this issue, too, setting Chrome as the default browser in Settings -> Default Apps. Whenever I set Chrome as the default browser, changes were discarded.

Wordaround:

For me, the solution was to set the default browser to Firefox first and then changing it to Chrome. After that, the setting was accepted.

(Using Windows 10 version 1607)

-2

I had the same problem with Chrome. In Settings - System - Default Apps, click to reset to Microsoft defaults, and then try choosing your program(s) again. That worked for me.

  • Firefox is not in the list – Joe Phillips May 1 '16 at 4:39
-2

in the default app settings, click on reset button and then assign a new browser as default browser. It worked for me.

  • 1
    This doesn't answer the original question as the OP has stated they have done this lots of times. – Burgi Jun 20 '16 at 0:23
-2

I had this same problem, I found the solution, it's a GUI problem. Instead of going to system/default apps, paste this in control pannels

Control Panel\All Control Panel Items\Default Programs\Set Default Programs

Click on the web browser you want to use and click "Set this program as default"

  • Based on the question contents, this appears to already have been tried. – Julie Pelletier Aug 1 '16 at 2:34

protected by Community Nov 10 '17 at 7:19

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.