1

I recently built a machine running Ubuntu 14.04 using a TP-Link TL-WDN4800 PCI wireless network adapter. When I click on the wireless connection icon on the Ubuntu taskbar, it almost always tells me that my connection speed is 54 Mb/s or thereabouts. In actuality, my download speed occasionally dips below 1 Mb/s, and certainly never surpasses 2 Mb/s. I have a NETGEAR WNDR3400 router. I want to improve my connection speed, as right now some online games are unplayable and Firefox has crashed multiple times. Help would be much appreciated. Thank you.

  • What are you getting the tested speeds from? – El Turner Aug 4 '15 at 15:09
  • Browsers don't generally crash because of slow connection speeds. Unless you're confusing stalled-out page loads for crashes. – Spiff Aug 4 '15 at 15:13
  • elevate the router to a high location in the room if you can, you did not mention where both devices were in relation to each other or how far. – Moab Aug 5 '15 at 1:13
  • The router is on the ground floor of my house, but my computer is on the second story. – evandewey Aug 5 '15 at 2:08
  • Also, does the position of the antennae affect anything? – evandewey Aug 5 '15 at 2:09
1
  • Pick a cleaner channel.
  • Clean up whatever channel you pick, by disabling or moving other devices that use that frequency band.
  • Move closer to the router. But not too close. Less than 1m is probably too close.
  • Make sure your card's antennas are connected well and positioned well, away from interference (PC, display, display cable) and obstructions.
  • Keep the case on your PC. Part of the case's job is to reduce electromagnetic interference from your PCs boards from interfering with your radios.
  • Make sure to use only WPA2 (AES-CCMP) security. No WEP or WPA (TKIP). Only WPA2 is fast enough for 802.11n data rates. Clients will only connect in up-to-54Mbps 802.11a/g speeds if only WEP or only WPA (TKIP) is available.
  • Make sure WMM (wireless QoS) is enabled. 802.11n requires WMM. Disabling it disables 802.11n.
  • Make sure you've enabled 20/40MHz channel mode. 20MHz-only mode cuts your bandwidth in half, and 40MHz-only mode is nonstandard.
  • Contrary to a popular myth, you should NOT use 802.11n-only mode. Go ahead and leave the a/b/g rates enabled alongside the N rates. 802.11n devices need the ability to use those legacy rates at times. Just make sure to get rid of any old a/b/g devices you still use, or upgrade them to N.
  • Consider upgrading your AP. Your AP only supports 2 spatial streams, so its maximum signaling rate is 300Mbps. Your card supports 3 spatial streams, so it could do 450Mbps signaling if it had a 3-stream-capable AP to talk to.
  • On Ubuntu, where would I go to change channel, etc? – evandewey Aug 4 '15 at 23:52
  • The channel is set by the AP. As are most of the settings I mentioned. – Spiff Aug 4 '15 at 23:55
  • Why Ubuntu is providing much slower speed than windows? – Sachith Muhandiram Aug 6 '15 at 20:12
  • @Sachith OP didn't say anything about Windows. If you have a question about Ubuntu being slower than Windows, post your own Question and document your own situation. – Spiff Aug 7 '15 at 2:25
  • In my AP, there is a "mode" option, and the settings I can choose from are "Up to 54 Mb/s" "Up to 145 Mb/s" and "Up to 300 Mb/s". Would there be any drawback to changing this from the first option to the third? – evandewey Aug 9 '15 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.