54

I've been running the released version of Windows 10 (x64) for a week now. Every other day or so, I get the following Security and Maintenance notification regarding "disable apps to help improve performance":

Windows 10 Action Center

My machine has 12 cores and 32GB of RAM--I really am not experiencing any slowdown. Note: when you click the notification, it shows Task Manager on the Startup tab where you can disable items in the startup--I don't want or need this.

The apps that display as having a High Startup impact are apps that I want to load at startup.

In previous Windows versions, if the Action Center had a message about Anti-Virus protection or Windows Update or Backups, you could go into the Action Center and tell it to not bother you with any more messages about it.

How can I tell windows not to bug me about this non-issue?

Edit: A couple of suggestions that didn't work:

  • Right-click the notification and then choose never to receive that type of notification any more. NOPE
  • Control Panel -> System and Security -> Security and Maintenance -> Change Security and Maintenance Settings -> Startup Apps. Unfortunately Startup apps is disabled (and checked)
4
  • What is your question exactly. Have you determine if you actually want those 3 application to automatically start?
    – Ramhound
    Aug 4, 2015 at 18:57
  • 4
    @Ramhound: The question is how do I keep this B.S. notification from popping up again. The apps that show as high impact are apps that I would never want to disable--they're in startup because I want them there. Aug 4, 2015 at 20:13
  • @C-PoundGuru I have a feeling this is local GPO related. I'm domain joined on my home PCs (Yes, that kind of dork) so I'll have to play around with it to see if I can find if there's any policies preventing that from being disabled. Aug 12, 2015 at 17:03
  • @C-PoundGuru, quoting is better.
    – kokbira
    Sep 1, 2015 at 13:27

1 Answer 1

68

It was driving me crazy, too. I found the answer in a comment from Troy Dallas on thurrott.com:

Once you get the Disable apps to help improve performance notification:

Go to Control Panel -> Security and Maintenance (right click on the Start Button and Left click on Control Panel to jump straight there).

Once opened under Maintenance (middle of the window) you will see the notification box with a Blue link at the bottom of the notification. Click that link Turn off messages about startup apps.

Important Note: The notification has to be in the Notifications Window before it will appear in the Security and Maintenance section.

2
  • 1
    I was able to follow this after dismissing the message. The link still appeared in the Security and Maintenance panel.
    – isherwood
    Jun 13, 2016 at 14:06
  • To get to that menu and remove the annoyance: Hit start menu and start typing "maintenance"
    – dashesy
    Jul 15, 2016 at 21:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.