35

Everything in Windows 10 worked perfectly for just 3 or 4 days after upgrading from 8.1. Yesterday I wanted to use the search feature, so I press win+s and get the error "Critical Error: Your Start menu isn't working. We'll try to fix it the next time you sign in."

(I also can't open the settings app since that's also a 'metro' app)

I have tried everything I could find and nothing worked for me.

Things I've tried include:

  • In powershell:

     Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
    
  • The answer here.

And things like that.

"Did you modify the registry?"

Yes:

  • Adding Sublime Text 3 to the "Open with" list (It can't be because of this can it?)

  • Back in Windows 8; Adding a few things to the RMB menu of some files (no trouble at all)

So what can I do to fix these problems?

  • Post the results after you run the repair reoutines using the DISM and SFC tools – Ramhound Aug 4 '15 at 18:56
  • SFC Did not find errors, and DISM completed successfully – Stefan Teunissen Aug 4 '15 at 19:35
  • I am having similar issues. My one computer upgraded just fine (about 2 weeks ago). Today my other computer finally received the "upgrade"... and after completion... the Window Store will not launch. And lots of apps are in the "pending" or "in progress" install state. – Kris Krause Aug 20 '15 at 10:43
  • And NO... I have not manually edited the registry. – Kris Krause Aug 20 '15 at 10:45
  • I ran the following (as Admin) in powershell... and all appears to be well now: Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"} – Kris Krause Aug 20 '15 at 14:17
18

A solution posted by Loopey:

  1. Login to your current profile
  2. Press Win+X, and select "Command Prompt (Admin)"
  3. Enter the following commands, in this order

    1. net user "TempAdmin1" "password1" /add
    2. net user "TempAdmin2" "password2" /add
    3. net localgroup administrators "TempAdmin2" /add
  4. Press Ctrl+Alt+Del, click Sign Out

  5. Login to the "TempAdmin1" account using password "password1"
  6. Logout, and then login to the "TempAdmin2" account, using "password2" (note: you must fully sign out, not just switch users)
  7. Open File Explorer, select View, then check the box marked "Hidden Items"
  8. Directly navigate to C:\Users\TempAdmin1\AppData\Local\TileDataLayer by typing it in the address bar. (click "continue" to gain access when prompted)
  9. Right Click the folder "Database" & Copy
  10. Now, navigate to the same folder for your damaged profile (C:\Users\YOUR_USERNAME\AppData\Local\TileDataLayer)
  11. Right click "Database", and rename to "Database.BAD"
  12. Right click empty area in the folder, and select Paste
  13. Reboot, then sign back in with your original profile.

Now, assuming all is well, you want to delete the two accounts you created:

  1. Win+X → Control Panel → User Accounts → Manage Another Account
  2. Select Account, then "Delete Account"

Brief explanation:

  1. Your TileDataLayer database is damaged
  2. You need a new TileDataLayer database
  3. Create a new user (user A), and login with it (a new database will be created). Proceed with this procedure only if the Start Menu and all other apps are working correctly as user A.
  4. Because the database is locked when you're logged in, you create user B (with access to user A's profile and your user profile)
  5. Rename the old database, and copy the new database from user A to your profile
  6. Logout from user B, and your account should work again
  • I tried a number of different things, and this is the one that worked for me. Login took a long time. The taskbar and start button showed up right away, but it took forever for quicklinks to load. The start menu wouldn't open when I clicked on it, nor did the notification panel on the right. Most programs worked fine, but anything native to Windows (File Explorer and Task Manager most notably) took forever to start up. Maybe someone else with the same symptoms will find this helpful. – mHurley Oct 9 '15 at 16:52
  • I had tried 7 other fixes out there, and this fixed our issue on a domain account. – Jason W Oct 22 '15 at 11:58
  • Yup, this works. I'd upgraded to the latest Windows 10 Preview build and that had to rollback. Suspect that the TileDataLayer DB might have undergone schema changes and the rollback didn't understand it. – Dean Ward Oct 22 '15 at 21:08
  • Similar recommended fix regarding deleting TileDataLayer directory in FIX !!!! Windows 10 taskbar not working FIX!!!! Build 10074. That link worked for me however doesn't suggest creating a new user then deleting & copying the folder. Instead, one of the comments suggests stopping the tiledatamodelsvc service to allow deleting it. – Ray Vega Feb 1 '16 at 6:16
  • For Step 7, I couldn't access "AppData" folder uintil I went to Folder Options -> View tab and under Advanced settings: unchecked "Hide protected operating system files (Recommended)" – Kristen Waite May 13 '16 at 16:27
8

Here are some fixes I found online:

Fix One:

  • Right-click at Start and run Command Prompt as admin
  • Type command:
  • ren %windir%\System32\AppLocker\Plugin*.* *.bak
  • Reboot

Fix Two:

  • Right-click at Start and click Run
  • Type services.msc and press the Enter key
  • Right click on Application Identity and select Start
  • Reboot

Fix Three:

  • Right click on the Start button and select Command Prompt (Run as administrator)
  • Type dism /online /cleanup-image /restorehealth
  • Reboot

Fix Four:

  • Press (Windows key)+R on your keyboard.
  • Key in PowerShell and hit Enter.
  • Right click on the PowerShell icon on the taskbar and select Run as administrator. (Or create a shortcut with PowerShell and run as admin.)
  • Now paste the following command in the Administrator: Windows PowerShell window and press the Enter key:

    Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

  • Wait for PowerShell to execute and complete the command. Ignore the few errors (in red color) that may pop up.

  • Reboot.

None of these fixes worked for me, but I hope they may work for someone. I did do a restore point recovery, however; that worked. But I'm going to swap back to Windows 7 for the time being, as some of my other programs do not work properly either.

  • I already said that fix 3 and 4 didn't work. Don't edit it out, it may help other users. And I can't confirm if 1 or 2 work, because my computer is broken lol – Stefan Teunissen Aug 19 '15 at 11:14
  • I've already tryied all of them and none worked =/ This is super annoying – Metafaniel Aug 26 '15 at 22:54
  • 1
    Tried 1 through 4, none working. WTH Microsoft this is CRITICAL - fix this sh*t. Also did a System restore because I thought it was the Office install that farked things up, but alas. I only succeded in wasting 3 hours of reinstalling stuff. – Nilzor Sep 16 '15 at 7:56
  • finally this combination worked for me; I found a lot of similar tips on the net, did all the sfc /scannow and dism ... thing, but to now avail... the combination of fix two and fix four finally did it. – roetzi Jan 9 '16 at 16:27
  • Fix 2 worked for me – karancan Mar 17 '16 at 19:47
6

A good solution can be find in here.

Solution 1: (Chris Raisin)

Create a file with the following code:

@echo off
cd %SystemDirectory%
Taskkill /F /IM Runtimebroker.exe > nul
RuntimeBroker.exe

Save it as a .cmd file, for instance FixLockedDesktopProcs.cmd and run it as administrator.

Solution 2: (Robert Gavick)

This is a problem associated with Dropbox. The best way to solve the “Critical Error” message is to uninstall the Dropbox application.

  1. Launch control panel (right click on the start menu)
  2. Go to the Programs.
  3. Uninstall Dropbox
  4. Reboot.

Now the menu, search and cortana should work normally. You can re-install Dropbox app now but remember to disable the launch of Dropbox at the Windows start.

  • Yup. Killing RuntimeBroker.exe in Task Manager works around the issue. The system will simply restart it when needed. – bwDraco Apr 18 '16 at 23:02
  • Thanks for answer. I have checked only the first solution and it worked to me. If someone could check the second want tell us if it also works. – Angel Sanchis Apr 19 '16 at 10:32
  • +1 for uninstalling Dropbox - after trying everything else on this page, Dropbox removal finally fixed it. – Kristen Waite May 16 '16 at 13:42
  • This problem was following me across several computers and I kept having to reapply the fix. I realized that Dropbox was installed each time. I have just uninstalled Dropbox and so far haven't seen the problem come back. – Celeritas Feb 3 '17 at 21:08
5

I had the exact same behaviour of the task bar and store app. Start menu; volume, internet/wifi, notification icons and search not working. Also right clicking on apps/programs did not work.

So I tried multiple things, here are some options I'm sure you can find them on google..:

  • The powershell command: Get-AppXPackage -AllUsers.....
  • Add new user and replace TileDataLayers folder
  • Checked if the HREF's for some values in regedit were readable
  • Did the Dism /restorehealth
  • And a lot of other stuff

I did not want to reset my whole Windows 10, because reinstalling al my software would take ages. So this solution worked for me:

I made a new Windows 10 USB and installed a new Windows 10 version keeping my files, settings and programs/software/apps (like Photoshop, Office...).

Here is how you do this:

  1. Go to: https://www.microsoft.com/en-us/software-download/windows10
  2. Click: "Download tool now" to get the MediaCreationTool.exe
  3. Run this tool to make a Windows 10 installation USB or Disk (make sure you select the options to make it compatible with you Windows 10 version)
  4. Once the Windows 10 installation USB or Disk is created run it (setup.exe)
  5. Follow the instruction of the Windows 10 installation until you get at "Choose what to keep"
  6. Choose "Keep personal files and apps" (apps meaning your software...)
  7. Keep following the instructions and run the install and wait until it is done.
  8. When Windows 10 starts again your taskbar will work like it should
2

I'm having the same issue, but it affects the entire Taskbar. The only things that work are the pinned apps, the Task View, and the Arrow that hides running tasks (to the left of the Battery and Wi-Fi). This is very frustrating, seeing that this is also a reality:

Start Menu, Critical Error :: Search Results

Notifications won't Open :: Search Results

In most of the search results listed, the 'fixes' provided are temporary, with emphasis on the issue having a chance of coming back. Even Microsoft Engineers appear to be at a loss here. I have reason to believe that this is due to a recent update that may (in some cases) also have affected some computers' abilities to use recent Restore Points.

The solution (until Microsoft comes clean and patches this):

replace the start menu.

Windows Classic Shell can replace the Start Menu with a working alternative until Microsoft patches this. It also replaces the Search Bar as well, for those of you who can't access Cortana/Search. It also provides access to System Settings and Control Panel.

1

I KNOW this is not a real solution, but it's a an alternative, it could be useful while we found a solution to the real problem.

I found there are alternative Start Menus out there. You can download Classic Shell. It features an improved Start Menu, you can choose styles (classic XP style, Windows 7 style, etc), you can skin it and customize it's look and behaviour. It can be installed in Windows 7, 8, 8.1 and 10 versions, and it's free!

This doesn't solve the problem of course, but it's helpful to have an alternative Start Menu to be able to work in the meantime. Greetings!

  • 1
    Yeah, temporary workaround ;) – Stefan Teunissen Aug 28 '15 at 16:59
  • I updated my system from Windows 8.1 to Windows 10 and I faced all these problems. My only REAL solution was to reinstall Windows 10 from an actual DVD (ISO). I lost all my customizations and all software I installed before, so I had to start again from scratch. Only that helped me... And anyway, yeah, I installed Classic Shell anyway haha – Metafaniel Sep 11 '15 at 21:19
1

For me, merely replacing the TileDataLayer database didn't work. What did work is to remove & and rebuild my entire user profile:

  1. Create the secondary admin account, and log in with it.
  2. Back up your original account profile directory, zipped somewhere outside of the profile's directory. Warning, this might take all day.
  3. Hose the broken one.
  4. Recreate the original. Remember to make it an administrator if it was like that already.
  5. Restore the needed parts of the original directory structure: documents, pictures, videos and so forth. Another warning: This might take all day again.
  6. Log back in with the original profile ID.
  7. ?
  8. Microsoft might have just killed two days for you. Profit!
0

Opening a task manager and terminating "Windows Shell Experience Host" and/or updating the Spotify app worked for me.

Somehow two of my pinned apps are still blank, though. (Mail and Skype.)

-3

100% fix I found came directly from Microsoft Partner support:

  1. Right Click on Start Menu> Click Command Prompt(Admin)
  2. select Run as Administrator.
  3. Now Type PowerShell In Cmd
  4. Now paste the Below following press Enter key:

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}

  1. Wait for PowerShell to execute and complete the command. Ignore the few errors (in red color) that may pop up.
  2. When it finishes, try hitting Start and hopefully it’ll start working.

Not the answer you're looking for? Browse other questions tagged or ask your own question.