I recently installed Fedora 22 and I'm using GNOME v3.16.2. I am new to Fedora, but moderately experienced with Linux. I cannot figure out how to lock my screen with a keyboard shortcut.

I have tried setting the "Lock Screen" shortcut to Ctrl+Alt+L and Super+L in the keyboard settings. But no matter what I set key binding to, nothing ever happens.

The only way I can lock my screen is to manually open XScreenSaver, start the daemon and manually lock the screen. But this is not the lock screen I am used to from running an older version of GNOME on SUSE 11.


After a couple of days of no responses, I would like to change my question a bit.

  • How can I check that the GNOME screensaver is actually runnable?

  • Can it be launched from the command line? (How?)

  • What is the name of the process so I can check to see if it is actually running?

  • Can I reinstall the lock screen via DNF?

  • after doing a search on GNOME tag, I have discovered that almost all of the questions asked with this tag have gone unanswered. Perhaps there is a better place for these questions. I will comment for others as I find better sources / answers. – Jerunh Aug 6 '15 at 13:20
  • Seems to me that your question ended up being all over the place. Could you updated it to reflect one issue (or two)? Mainly because you are talking about 3 different ways to achieve (almost) the same thing. – slybloty Aug 20 '15 at 18:50

In order to set up keyboard shortcuts you need to go to Settings -> Keyboard -> Shortcuts -> System. Then you'll find the Lock screen.
This works for me without any issue.

Also, I recommend installing the Tweak Tool as well.


I just had this problem with a fresh install of Fedora Server 23.
Try running (as root):

dnf install system-switch-displaymanager
system-switch-displaymanager gdm
systemctl enable gdm

Log off/on or press Alt+F2 then R to restart the display manager.

Super+L should now lock your screen.

  • Did not work for me on Fedora 27/Gnome 3.26.2 – Vongo Mar 23 '18 at 16:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.